PDA

View Full Version : LABEL problems



foo1
15th April 2007, 01:05 AM
I'm trying to upgrade a FC3 box to FC7 test 3 (because the FC6 install hung and failed, but thats a different problem)

I can get a ways into the install, and then it tries to mount /boot, and it can't, because its all confused about the /dev/hdaX drives turning into /dev/sdaX drives.

The solutions that I have read indicate that using labels should get me past this problem.

Sure, no problem. So I do this:

> /home/vortex>/sbin/e2label /dev/hda3
/
> /sbin/findfs LABEL=/
/dev/hda3

Looks good!
Lets try boot.

> /home/vortex>/sbin/findfs LABEL=boot
findfs: Unable to resolve 'LABEL=boot'

Hmm, that's no good. I know I have one here somewhere... lets see...
>/sbin/e2label /dev/hda1
boot

WTF? There it is.

Why can't findfs find my partition labeled "boot"? Both partitions on on the same physical drive. Both are ext3. I've tried resetting the label. What gives? Any suggestions?

Thanks

stevea
15th April 2007, 01:19 AM
Huh - mine are labelled "/boot" and "/boot1" Sure you aren't missing a leading "/" ?

foo1
15th April 2007, 01:22 AM
yea - I've tried changing the label to other values, including /boot. Currently, as e2label says, anyway, the label is "boot". Yet, findfs won't find it.

foo1
15th April 2007, 03:41 AM
Well, I'm pretty sure this is related to the label problems:

> /home/vortex>/sbin/blkid
/dev/hda1: TYPE="ntfs"
/dev/hda2: TYPE="swap"
/dev/hda3: LABEL="/" UUID="8d9aa71a-3e5c-4f4b-92a2-f78404ffeff7" SEC_TYPE="ext2" TYPE="ext3"
/dev/hdb1: UUID="722c72f8-3b81-4a00-a218-cdd5b4186394" SEC_TYPE="ext2" TYPE="ext3"
/dev/hdd1: UUID="24b060b1-7a6d-4146-9a53-8e496900dbaa" TYPE="reiserfs"

The output from this is completely wrong on the first line. /dev/hda1 is a ext3 partition, which is being identified as ntfs. It doesn't show the label or the UUID which ARE assigned to this partition.

I tried clearing the /etc/blkid.tab file, and rerunning, but it continues to produce the wrong information.

Seve
15th April 2007, 05:19 AM
Hello:
Just a thought ?
And perhaps this is just silly and does not apply to your current issue :)

When you are executing these commands, which install / rescue disc are you using to boot from?
I am almost certain that you will need perhaps a FC3 /FC4 / or maybe a FC5 disk to be able to even see the FC3 installation.

Anything past that will not even find your installation and maybe this is what is causing you not to find the /boot etc.

I had this issue some releases back, [I'm sorry I cannot recall the details] however, I do recall that the rescue disk or install disc has to be close to the installation you are working on [Release Version Wise]?


Seve