PDA

View Full Version : cdemu wont compile on fc6



majik
14th April 2007, 04:12 AM
hi
im trying to compile cdemu 0.8 but i get this error

[majik@majik cdemu-0.8]$ make
make[1]: Entering directory `/usr/src/kernels/2.6.20-1.2933.fc6-i686'
CC [M] /home/majik/tmp/cdemu-0.8/cdemu_core.o
/home/majik/tmp/cdemu-0.8/cdemu_core.c: In function ‘cdemu_ioctl’:
/home/majik/tmp/cdemu-0.8/cdemu_core.c:489: error: implicit declaration of function ‘generic_file_read’
make[2]: *** [/home/majik/tmp/cdemu-0.8/cdemu_core.o] Error 1
make[1]: *** [_module_/home/majik/tmp/cdemu-0.8] Error 2
make[1]: Leaving directory `/usr/src/kernels/2.6.20-1.2933.fc6-i686'
make: *** [default] Error 2
[majik@majik cdemu-0.8]$

I have installed the correct kernel source and headers
this is driving me crazy, any help would be awesome

Seve
14th April 2007, 04:23 AM
Hello:
I'm pretty sure, although not certain that there is a problem with that app and newer kernels.
You can search through the forums here as I believe there are others that have had the same problem.

Seve

majik
14th April 2007, 04:29 AM
yeah i spent about 4hours searching last night with no luck :( i still cant work it out, and all my games/movies are cue/bin and its just to hard using bin2iso

Seve
14th April 2007, 05:36 AM
Hello:
Sorry I don't have a solution for you, however, have you tried it on an older kernel ?
You can browse through here and see if you can find one which date wise, may line up with the last release of cdemu ?
linux kernel museum (http://linuxmirror.museum.state.il.us/Fedora/core/6/updates/i386/repodata/repoview/SystemEnvironment.Kernel.group.html)
Don't know if it will help, but it may be worth a shot.

Seve

majik
14th April 2007, 07:11 AM
thanks, but everything else on the pc runs well with this kernel.
there has to be another way

Seve
14th April 2007, 07:24 AM
there has to be another way
Hello:

It looks like a nice app and I can see how it would be very useful.
If you have not done so already, perhaps shooting off an email to the developers might bring some rewards ?

Seve

sideways
14th April 2007, 07:38 AM
see the 2nd post here (http://forums.gentoo.org/viewtopic-t-519565.html?sid=b791467f487342ca3fe1dc887e30d3e9) for a fix


generic_file_read() has been removed from the kernel. Just replace every occurance of generic_file_read in cdemu_core.c with do_sync_read


edit
cdemu 0.8: there are two such occurances of 'generic_file_read' in cdemu_core.c at lines 489 & 493

majik
14th April 2007, 05:06 PM
bloody fantastic thanks sideways

now i have this error! :(
[majik@majik cdemu-0.8]$ sudo make install
Makefile:71: /mk/linux-2.6: No such file or directory
make: *** No rule to make target `/mk/linux-2.6'. Stop.
[majik@majik cdemu-0.8]$

majik
14th April 2007, 05:12 PM
fixed it on line 71

removed the '/' before mk/linux-2.6

works awesome
thanks everyone