PDA

View Full Version : HP PSC-2610v & HPLIP issues



Bad2theBone
13th April 2007, 02:36 PM
Recently I reinstalled FC6 from scratch, after rearranging my HDDs. I noticed that the current hplip version that Fedora has is 1.6.12. When I went to run hp-setup, it would dump out with "error:unable to connect to hpiod" and the same for hplip. It suggested that I restart hplip, which I did several times with no change. Googling only turned up the same feed back and most people were having problems with USB direct connects, mine is networked. I then downloaded hplip-1.7.3 and tried installing that getting the same thing.

After several hours I installed hplip-1.6.10, which is what I had prior to all this and it worked fine. The hp-toolkit GUI worked fine, for printing, FAXing, and scanning. I liked it because it gave me warnings of low ink. I even tried going through CUPs localhost:631 way to setup the printer. It would allow me to create the printer, but when I went to do a test print nothing would happen. I deleted it from there and recreated it through the system->admin->printing app. I am able to print but xsane does not "see" it. I would like to get working the way I had it before, through the HP Device Manager, as I think that's why some of the functions aren't working

Also even though it says that HPLIP-1.6.10 is the version that I've got running, with all of the switching versions, how do I know that bit and pieces of other versions aren't lingering around possibly causing problems. Short of reinstall of FC6 again, which I'm not sure how that would take since I'm now using LVM and I don't want to lose that as I've got about 2 weeks of .flac files (close to 100GB).

TIA

wrg3rd
21st April 2007, 06:35 PM
I am having the same problem as Bad2theBone. My printer is HP OJ 7310xi multifunction. hplip is 1.7.2-3.FC6.

Running hp-check gives me the following:
====
HP Linux Imaging and Printing System (ver. 1.7.2)
Dependency/Version Check Utility ver. 5.3

Copyright (c) 2003-6 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

---------------
| SYSTEM INFO |
---------------

Basic system information:
Linux achachila.altiplano 2.6.20-1.2944.fc6 #1 SMP Tue Apr 10 17:27:49 EDT 2007 i686 athlon i386 GNU/Linux


Detected distro (/etc/issue):
fedora 6

Detected distro (lsb_release):
FedoraCore 6 (Zod)

Currently installed HPLIP version...
HPLIP 1.7.2 currently installed in '/usr/share/hplip'.

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf

[hpiod]
# port=0 (dynamic IP port)
port=2208
[hpssd]
# port=0 (dynamic IP port)
port=2207

[hplip]
version=1.7.2
jdprobe=0

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/foomatic/db/source/PPD/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-1.7.2

# Following values are determined at configure time and cannot be changed.
[configure]
network-build=1
pp-build=1
gui-build=1
scanner-build=1
fax-build=1
installinitd=
chkconfig=/sbin/chkconfig
internal-tag=1.7.2.22

HPLIP running?
Yes, HPLIP is running (OK).

HPOJ running?
No, HPOJ is not running (OK).

Checking Python version...
OK, version 2.4.4 installed

Checking PyQt version...
OK, version 3.17 installed.

Checking SIP version...
OK, Version 4.5 installed

----------------
| DEPENDENCIES |
----------------

Checking for dependency libcrypto - OpenSSL cryptographic library...
OK, found.

Checking for dependency gcc - GNU Project C and C++ Compiler...
OK, found.

Checking for dependency SANE - Scanning library...
OK, found.

Checking for dependency GhostScript - PostScript and PDF language interpreter and previewer...
OK, found.

Checking for dependency libjpeg - JPEG library...
OK, found.

Checking for dependency libpthread - POSIX threads library...
OK, found.

Checking for dependency make - GNU make utility to maintain groups of programs...
OK, found.

Checking for dependency python-devel - Python development files...
OK, found.

Checking for dependency Reportlab - PDF library for Python...
Note Error==> This is an OPTIONAL dependency. Some HPLIP functionality may not function properly.

Checking for dependency PyQt - Qt interface for Python...
OK, found.

Checking for dependency cups-devel- Common Unix Printing System development files...
===> error: Not found!
===> error: This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency ppdev - Parallel port support kernel module....
OK, found.

Checking for dependency libusb - USB library...
===> error: Not found!
===> error: This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency scanimage - Shell scanning program...
OK, found.

Checking for dependency libnetsnmp-devel - SNMP networking library development files...
===> error: Not found!
===> error: This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency Python 2.2 or greater - Python programming language...
OK, found.

Checking for dependency LSB - Linux Standard Base support...
OK, found.

Checking for dependency xsane - Graphical scanner frontend for SANE...
OK, found.

Checking for dependency cups - Common Unix Printing System...
OK, found.

Checking for dependency Python 2.3 or greater - Required for fax functionality...
OK, found.

----------------------
| INSTALLED PRINTERS |
----------------------

HP7310xi
--------
Device URI: socket://192.168.1.90:9100
Installed in HPLIP? No
PPD: /etc/cups/ppd/HP7310xi.ppd
PPD Description: HP OfficeJet 7300 Foomatic/hpijs (recommended)
Printer status: printer HP7310xi is idle. enabled since Sun 25 Mar 2007 12:28:05 AM CDT


====> error: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend to function in HPLIP. (You can still print to this printer using another backend and HPIJS.)

----------------------
| SANE CONFIGURATION |
----------------------

'hpaio' in '/etc/sane.d/dll.conf'...
OK, found. SANE backend 'hpaio' is properly set up.

Checking output of 'scanimage -L'...


No scanners were identified. If you were expecting something different,

check that the scanner is plugged in, turned on and detected by the

sane-find-scanner tool (if appropriate). Please read the documentation

which came with this software (README, FAQ, manpages).


---------------------
| PYTHON EXTENSIONS |
---------------------

Checking 'cupsext' CUPS extension...
OK, found.

Checking 'pcardext' Photocard extension...
OK, found.

5 errors were detected.
Please refer to the installation instructions at:
http://hplip.sourceforge.net/install/index.html
=====
( Note: errors indicated by "====>")

I have attempted to install the following, but they are not provided in the FC6 repository:
libusb
libnetsnmp-devel

I have installed the following as indicated:
cups-devel-
Python-Reportlab

I have not been able to figure out how to install the printer "in HPLIP".

Any help is apprectiated.

Bad2theBone
21st April 2007, 08:08 PM
My problem was little different in that first I was unable to connect to hpio and hplip. I had also noticed that when I restarted hplip or in the process of shutdown that hpssd would fail on stop but would give an ok status on start or restart. I went through all of the requirements of dependencies as listed in the manual install at the sourceforge site for hplip and everything had been installed. Out of desperation I tried through Smart Pkge Mgr just searching for cups and I was missing cups-lpd. Once I installed that everything came together. The software updater then updated to 1.7.2, however when I run hp-check it comes back with 1.6.10, which what I had manually installed. Yum and Smart indicate 1.7.2, and the graphics appears to be something newer than 1.6.10, so beats the F out of me.

It works, so I think I'll just leave it alone. Also a problem that I've been having for about a year now has gone away. I used to have trouble printing certain PDF files. In Adobe the job would hang, in xpdf or evince the job would print but some of it got cut off. That has gone away.

Now if I can just get the update to keep the vboxdrv module intact when the kernel gets rebuilt, so that I don't have to reinstall VirtualBox and also now the file types of any OOo docs change to Java Archives when I try to open from Natilus. Oh, well, life could be worse, I could be running Vista................ :rolleyes:

wrg3rd
21st April 2007, 08:45 PM
I've got it running too. For me, following the steps at this site helped: (http://www.bobpeers.com/linux/hp_printing). I could seen that HPLIP was running, but I didn't understand how to get a printer 'in' hplip.

Glad you've got it.

Bad2theBone
21st April 2007, 09:25 PM
Glad you've got yours working ok. As for me I still can't figure why cups-lpd fixed my problem. It's supposed to be a backend for legacy printer drivers. I didn't think that HPLIP used any of the old legacy functions from lpr days, since they essentially use CUPS as a backend. Oh well