PDA

View Full Version : FC6 wont start after FAQ.



Synlaw
13th April 2007, 07:38 AM
Well... i have been following http://www.fedorafaq.org/ from and installing everything, everything installed fine except the java that i had 1 problem with... so i moved on to "Q: How do I enable 3D support for my ATI Radeon card in Fedora?"
I did these steps: #


su -

# Install the driver:

yum install kmod-fglrx

# Shut down X:

init 3
Then after the X shutdown i restarted PC and i failed to do these:
Mount local file system and HIDD and resolution was very high... so when the last thing was loaded i got a black screen (as usually) but this time it stayed black, and my monitor turned semi-off (monitor led was flashing) and there it stays...
I have a RADEON x800 GTO
A8N-SLI motherboard
2G RAM...
(if you need to know anything else just ask)
So does anyone have any idea what is wrong and how could i fix it (preferably without reinstalling it :mad: )
Thanks in advance

cswiii
14th April 2007, 05:02 AM
in my experience, a monitor acting the way yours is indicates that it shut itself off because it couldn't handle the signal sent by the vid card. Maybe the refresh rate is screwy or something. If you just installed new drivers, there's a good chance of that happening, I suppose, esp. if you had been using very high resolutions before.

Something to try:
1) make a BACKUP of /etc/X11/xorg.conf
2) Edit /etc/X11/xorg.conf and in the subsection for "Display", in the section called Section "Screen" add the following line

Modes "1024x768" "800x600" "640x480"

3) save and restart X

That should at least get you some basic working resolutions so you can go in and use xrandr or your video driver's settings tool to adjust things. If that doesn't help, replace your modified xorg.conf with your backup and maybe there'll be something else to try.

By the way, you may also try editing /etc/inittab and making the following change:

id:3:initdefault:

...which will mean you start in "init 3" each time you boot the system. Good for debugging.... if X is still loading all wonky, you can Ctrl-Alt-F1 (or F2, or whatever terminal you were on) to go back and easily see what kinda messages X is spewing. Once everything is working, you can change that '3' back to a '5'.

sideways
14th April 2007, 06:55 AM
You can also force a boot into text mode by hitting 'a' at the grub prompt and adding '3' to the kernel options.

For the fglrx driver you need an /etc/X11/xorg.conf like this (The monitor section should match your monitor obviously rather than the one here)


Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "ddc"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "freetype"
Load "type1"
Load "glx"
Load "dri"
EndSection

Section "ServerFlags"
Option "AIGLX" "off"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "gb"
EndSection

Section "Monitor"
Identifier "Monitor0"
ModelName "L1710B"
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 30.0 - 71.0
VertRefresh 56.0 - 75.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "fglrx"
Option "OpenGLOverlay" "off"
Option "VideoOverlay" "on"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection

Section "Extensions"
Option "Composite" "False"
EndSection