PDA

View Full Version : Fedora 7 and atrpms



danwaineo
12th April 2007, 11:28 PM
Has anyone gotten atrpms working with Fedora 7? I'm getting errors like I have a misconfigured atrpms.repo file. Here's mine:

[atrpms]
name=ATrpms for Fedora Core $releasever - $basearch
# baseurl=http://dl.atrpms.net/f$releasever-$basearch/atrpms/stable
baseurl=http://dl.atrpms.net/f7-i386/atrpms/stable
enabled=0
gpgcheck=1
gpgkey=http://ATrpms.net/RPM-GPG-KEY.atrpms

[atrpms-testing]
name=ATrpms (testing) for Fedora Core $releasever - $basearch
baseurl=http://dl.atrpms.net/f$releasever-$basearch/atrpms/testing
enabled=0
gpgcheck=1
gpgkey=http://ATrpms.net/RPM-GPG-KEY.atrpms

Notice I tried hard coding the URL without the variables, but it still didn't help. Other repos work great (livna, devel, etc.)

leigh123linux
12th April 2007, 11:34 PM
I dont know if there is a Fedora 7 atrpms.repo yet?

but it might help if you enabled it :rolleyes:

enabled=0 # =disabled

should be

enabled=1 # =enabled

danwaineo
12th April 2007, 11:54 PM
Thanks, but it's been enabled. I turned it off because of the errors. I typically try to get most packages through Core, extras (for <fc7) and livna. However I'd like to play around with mythtv.

danwaineo
12th April 2007, 11:57 PM
Also, yes there is a atrpms for fedora 7:

http://atrpms.net/dist/f7/

Seve
13th April 2007, 12:29 AM
Hello:
If you want the stable version for F7-i386 [for what that's worth :)]
then try this :

[atrpms]
name=Fedora Core $releasever - $basearch - ATrpms
baseurl=http://dl.atrpms.net/f7-i386/atrpms/stable
gpgkey=http://ATrpms.net/RPM-GPG-KEY.atrpms
enabled=0
gpgcheck=1


Just tested it and it does work.

# yum --enablerepo=atrpms check-update
Loading "installonlyn" plugin
primary.xml.gz 100% |=========================| 91 kB 00:00
atrpms : ################################################## 400/400
primary.xml.gz 100% |=========================| 60 kB 00:00
livna-deve: ################################################## 176/176
primary.sqlite.bz2 100% |=========================| 2.1 MB 00:06
http://mirror.linux.duke.edu/pub/fedora/linux/extras/development/i386/repodata/primary.sqlite.bz2: [Errno -1] Metadata file does not match checksum
Trying other mirror.
primary.sqlite.bz2 100% |=========================| 2.1 MB 00:03
primary.xml.gz 100% |=========================| 821 kB 00:07
developmen: ################################################## 2314/2314
primary.xml.gz 100% |=========================| 1.1 MB 00:00
updates_f7: ################################################## 3030/3030
primary.xml.gz 100% |=========================| 1.1 kB 00:00
macromedia: ################################################## 3/3

faad2.i386 2.5-7.fc6.91.at atrpms
lame.i386 3.97-15.fc6.91.at atrpms
lame-devel.i386 3.97-15.fc6.91.at atrpms
mpeg2dec.i386 0.4.1-3.fc6.91.at atrpms
mplayer.i386 4:1.0-58_r21812.fc6.89 atrpms
mplayer-fonts.noarch 4:1.0-7.at atrpms
mplayerplug-in.i386 3.40-31.fc6.91.at atrpms
xvidcore.i386 1.1.2-10.fc6.91.at atrpms

Seve

danwaineo
13th April 2007, 12:43 AM
Thanks Seve,

I did exactly what you said and cut and pasted your atrpms.repo in to mine but I still get errors:


# yum --enablerepo=atrpms check-update
Loading "installonlyn" plugin
Traceback (most recent call last):
File "/usr/bin/yum", line 29, in <module>
yummain.main(sys.argv[1:])
File "/usr/share/yum-cli/yummain.py", line 94, in main
result, resultmsgs = base.doCommands()
File "/usr/share/yum-cli/cli.py", line 263, in doCommands
return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
File "/usr/share/yum-cli/yumcommands.py", line 317, in doCommand
ypl = base.returnPkgLists(extcmds)
File "/usr/share/yum-cli/cli.py", line 769, in returnPkgLists
ypl = self.doPackageLists(pkgnarrow=pkgnarrow)
File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 1052, in doPackageLists
for (n,a,e,v,r) in self.up.getUpdatesList():
File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 509, in <lambda>
up = property(fget=lambda self: self._getUpdates(),
File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 410, in _getUpdates
self.pkgSack.simplePkgList())
File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 496, in <lambda>
pkgSack = property(fget=lambda self: self._getSacks(),
File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 379, in _getSacks
self.repos.populateSack(which=repos)
File "/usr/lib/python2.5/site-packages/yum/repos.py", line 200, in populateSack
sack.populate(repo, mdtype, callback, cacheonly)
File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 132, in populate
if self._check_db_version(repo, mydbtype):
File "/usr/lib/python2.5/site-packages/yum/yumRepo.py", line 189, in _check_db_version
if repo.repoXML.repoData.has_key(mdtype):
AttributeError: 'NoneType' object has no attribute 'repoData'

I don't get errors if I do this:


# yum update
Loading "installonlyn" plugin
Setting up Update Process
No Packages marked for Update/Obsoletion

Wierd, huh?

Seve
13th April 2007, 02:23 AM
Hello:
In the atrpms.repo make sure you leave at least one blank line / carriage return after the last line, save and exit.

Then try
yum clean all
then try it again.

Seve

danwaineo
13th April 2007, 03:10 PM
Hello:
In the atrpms.repo make sure you leave at least one blank line / carriage return after the last line, save and exit.

Then try
yum clean all
then try it again.

Seve

Thanks for the suggestion,
I did as you said, but I still get the errors. I have no idea what is wrong. Any other ideas?

JBa
9th June 2007, 03:22 PM
Thanks for the suggestion,
I did as you said, but I still get the errors. I have no idea what is wrong. Any other ideas?

G'day,

I had the same problem, but turns out it was because of the name change from fedora core (fc6) to fedora (f7).

See my /etc/yum.repos.d/atrpms.repo file below.. The variable $releasever is getting evaluated as 7, so the directory path is ...fc7..... But the atrpms site has gone with the new nomenclature of f7 for the path.

See in my file I have commented out the old line and added a new line without the c for core...


[atrpms]
name=ATrpms for Fedora Core $releasever - $basearch
#baseurl=http://dl.atrpms.net/fc$releasever-$basearch/atrpms/stable
baseurl=http://dl.atrpms.net/f$releasever-$basearch/atrpms/stable
enabled=1
gpgcheck=1
gpgkey=http://ATrpms.net/RPM-GPG-KEY.atrpms


[atrpms-testing]
name=ATrpms (testing) for Fedora Core $releasever - $basearch
#baseurl=http://dl.atrpms.net/fc$releasever-$basearch/atrpms/testing
baseurl=http://dl.atrpms.net/f$releasever-$basearch/atrpms/testing
enabled=0
gpgcheck=1
gpgkey=http://ATrpms.net/RPM-GPG-KEY.atrpms


Hope this helps.

danwaineo
9th June 2007, 04:29 PM
Thanks jBa,

If you look at my first message, I had already removed the c. Atrpms did start working after I upgraded from test to final. Not sure why though.

Thanks for looking,
Dan

Seve
10th June 2007, 03:01 AM
Thanks jBa,

If you look at my first message, I had already removed the c. Atrpms did start working after I upgraded from test to final. Not sure why though.

Thanks for looking,
Dan
Hello:

With the naming convention of the Test version of F7 ( likely 6.9x) etc. it would run into a block as based on the $releasever, which would be causing yum to look for the Fedora 6.9x, which did not exist on atrpms.
Once you installed the final version of F7, the $releasever macro would match up with the physical repo.

Seve