PDA

View Full Version : I get logged out when Beryl starts



Pyntix
11th April 2007, 08:36 PM
I recently installed Fedora Core 6 on my computer and then (after updating everything) installed Beryl using yum through the console. Now when I start it, I almost immediately get logged out. I stayed open a few minutes when I used GNOME, but otherwise it just crashes right away.

I've got a NVidia graphics card, and I've also done what is says on the bottom of this (http://wiki.beryl-project.org/wiki/Install_Beryl_on_Fedora_Core) page.

Some help would be very appreciated.

EDIT: I use KDE, but a solution for GNOME would be nice too.

Dies
11th April 2007, 09:52 PM
If you haven't installed the Nvidia drivers yet then :

su -
rpm -ivh http://rpm.livna.org/livna-release-6.rpm
yum install kmod-nvidia -y
shutdown -r now

If you already have them, try the following:

su -
mv /etc/X11/xorg.conf /etc/X11/xorg.junk
nvidia-xconfig
shutdown -r now

Pyntix
11th April 2007, 10:12 PM
I did exactly as you said, but when I wrote yum install kmod-nvidia -y in the console, I got this back:

Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
core 100% |=========================| 1.1 kB 00:00
livna 100% |=========================| 1.1 kB 00:00
http://macromedia.mplug.org/rpm/repodata/repomd.xml: [Errno 12] Timeout: <urlopen error timed out>
Trying other mirror.
http://macromedia.rediris.es/rpm/repodata/repomd.xml: [Errno 12] Timeout: <urlopen error timed out>
Trying other mirror.
Error: Cannot open/read repomd.xml file for repository: flash

YeOK
11th April 2007, 10:26 PM
Try :


yum clean all

Pyntix
11th April 2007, 10:56 PM
Still the same error.

Dies
11th April 2007, 11:38 PM
Not sure why anyone would need a Flash repo considering your browser should offer to install it the first time you need it but...........

su -
gedit /etc/yum.repos.d/flash.repo

then change

enabled=1

to

enabled=0

or use the yum switch to disable it temporarily :

yum --disablerepo=flash install kmod-nvidia -y

Pyntix
11th April 2007, 11:47 PM
It seems to have stuck like this, nothing happens at all...

yum --disablerepo=flash install kmod-nvidia -y
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
core 1.1 kB 00:00
livna 100% |=========================| 1.1 kB 00:00

EDIT: No, just when I posted it, this came up:

Could not retrieve mirrorlist http://www.jpackage.org/jpackage_fedora-6.txt error was
[Errno 4] IOError: <urlopen error (110, 'F\xc3\xb6rbindelsen dog ut (timeout)')>
Error: Cannot find a valid baseurl for repo: jpackage-fedora

Dies
11th April 2007, 11:59 PM
You really need to disable all those useless repos.
Do the same thing that I told you for Flash but this time go through all the repos in /etc/yum.repos.d/ and disable all the third party repos except for Livna.

You only need to have

Core
Extras
Updates
Livna

enabled full time.

Try

su -
nautilus /etc/yum.repos.d/

That should open Nautilus up to that directory and it should be easier for you to disable those.

Pyntix
12th April 2007, 12:14 AM
Ok, I've got some others with fedora or livna in the filename:

fedora-development
fedora-legacy
fedora-extras-development
fedora-updates-testing
livna-devel
livna-testing

Should I disable those too?

Dies
12th April 2007, 12:20 AM
Those shouldn't even be enabled by default, so if they are yes you should definitely disable those.

scotta3234
12th April 2007, 12:21 AM
Ok he's not the only one. I'm getting it too... seems to be something up with the nvidia drivers, in particular the 3d acceleration stuff. Even when i try and test glxgears it logs me out. I'm doing some tests now.

scotta3234
12th April 2007, 12:27 AM
Yeah, simply re-writing a new xconfig works.

Pyntix
12th April 2007, 12:38 AM
Ok, now I've done

yum install kmod-nvidia -y
shutdown -r now

and it worked like a charm after disabling those repos. :)
I may have misunderstood you Dies, but should I now do this:

su -
mv /etc/X11/xorg.conf /etc/X11/xorg.junk
nvidia-xconfig
shutdown -r now

EDIT: It seems to be working now, but please tell me if I need to do anything to avoid nasty things to happen. I'm no pro at Linux, yet anyway. :rolleyes:

Dies
12th April 2007, 12:49 AM
Nope, that's only if you're having problems if everything is cool then there's no need.

BTW - you should have a new Nvidia tool under Applications>System Tools. :)

Pyntix
12th April 2007, 12:52 AM
Ah! Wonderful. Hopefully this will work for my friend too.

Thank you very much, you have given me yet a reason to avoid that nasty thing that lies on another partition called Windows XP. :D

Dies
12th April 2007, 01:07 AM
You're welcome.

But you can have your cake and eat it too.

http://forum.fedoraforum.org/forum/showpost.php?p=775805&postcount=415

I'm too cheap to buy another printer. :D

Peyj
12th April 2007, 09:11 PM
Hmm.. I have this problem too, but when I install the nVidia driver my X-server goes crazy. At every startup it says X is impossible to run and creates a new config, fine, I can logon to the computer, but next startup the same thing happens, and beryl isn't working either >.< . I've just reinstalled, tested on a fresh system, same problem, any1 that has any idea?

Dies
12th April 2007, 09:37 PM
Well, it would help if you were to mention what kind of hardware you're running.