PDA

View Full Version : eth0 won't activate on boot.



Trapper
11th April 2007, 07:42 PM
"Suddenly" eth0 does not activate on startup or reboot. I see a message saying it's unable to connect because another source is already using that IP address. I never had this difficulty until yesterday after some FC6 Pup updates.

Here's the full picture. I am running a multiboot system with FC6, Ubuntu and Win2K. All are set up with a static IP of 192.168.2.2 behind an IPCop box. All have a gateway of 192.168.2.1. Up until yesterday they all worked perfectly when booting into them. Now FC6 refuses to activate. I have checked and rechecked all my settings for eth0 in FC6. They are exactly the same as they are for Ubuntu and Win2K and "activate on boot" is checked.

Here's the kicker. I can manually activate eth0 in my Network settings after I have logged in. No problem what-so-ever. eth0 activates as 192.168.2.2 without any difficulty.

This box is the only box using 192.168.2.1 as a gateway.

I need to retain the static address just as it is.

I cannot remember what updates I installed yesterday? Where do I find the log for them?

Any ideas or suggestions concerning my problem???

aragorn_246
11th April 2007, 10:32 PM
Afaik, pup uses yum at the backend, in which case /var/log/yum.log should indicate what was updated.

You could also check the messages file for eth0 errors:
grep -i eth0 /var/log/messages

HTH

Trapper
12th April 2007, 12:00 AM
Thanks. I checked out eth0 in the system messages. I saw nothing that immediately indicating a connection problem at boot up however I am not well versed to the lingo and probably didn't realize what I was seeing.

I also checked the yum log. Yesterday's updates were :

Apr 10 07:11:40 Updated: samba-common.i386 3.0.24-4.fc6
Apr 10 07:11:42 Updated: yum.noarch 3.0.5-2.fc6
Apr 10 07:11:42 Updated: brlapi.i386 0.4.1-2.1.fc6
Apr 10 07:11:43 Updated: libXfont.i386 1.2.8-1.fc6
Apr 10 07:11:44 Updated: samba-client.i386 3.0.24-4.fc6
Apr 10 07:11:45 Updated: iputils.i386 20070202-2.fc6
Apr 10 07:11:47 Updated: yum-updatesd.noarch 3.0.5-2.fc6
Apr 10 07:11:47 Updated: dhclient.i386 3.0.5-4.fc6

Today's updates were:

Apr 11 17:17:38 Updated: libX11.i386 1.0.3-7.fc6
Apr 11 17:17:44 Updated: ghostscript.i386 8.15.4-1.fc6
Apr 11 17:17:46 Updated: xorg-x11-server-Xorg.i386 1.1.1-47.8.fc6
Apr 11 17:17:48 Updated: system-config-printer-libs.i386 0.7.52.1-2.fc6
Apr 11 17:17:51 Updated: selinux-policy.noarch 2.4.6-54.fc6
Apr 11 17:17:54 Updated: libX11-devel.i386 1.0.3-7.fc6
Apr 11 17:17:57 Updated: system-config-printer.i386 0.7.52.1-2.fc6
Apr 11 17:18:12 Updated: selinux-policy-targeted.noarch 2.4.6-54.fc6

I am mentioning today's updates for a reason. After I completed these updates I rebooted and eth0 connected on reboot without any difficulty. I tried it several times and had the same success. I have no logical understanding as to why. Whatever, my connection now happens the way it should.

Thanks,
Trapper

aragorn_246
12th April 2007, 07:55 PM
Sorry I didn't reply earlier.

dhclient is the package that handle dhcp requests - ie give me an IP when the network card starts.

Sounds like a probable cause - grepping for dhc in messages might reveal the error. Of course, if it's working now ...

Trapper
12th April 2007, 08:52 PM
Before I even reached the yum log I was suspicious of dhclient and I was pretty sure an updated to it was one of the updates on the 10th. My updates on the 11th don't indicate anything that might reverse a flawed previous update. So I remain confused over the remedy that resolved the connection issue. All eth0 settings after the update on the 11th were exactly the same as prior to the update. Oh well, it works and that's what really counts. Thanks for the help and suggestions.

LinuxTom
15th April 2007, 02:55 AM
iputils is the culprit, both updates released since 04.09.2007 break eth0 activate at boot, thus breaking http, ssh, etc. Not sure of the cause yet, but the following forced downgrade should fix it.

sudo rpm -Uhv --force http://download.fedora.redhat.com/pub/fedora/linux/core/6/i386/os/Fedora/RPMS/iputils-20020927-41.fc6.i386.rpm

Trapper
15th April 2007, 12:46 PM
LinuxTom,

Okay. This clears up the mystery a bit. I'll keep the instructions you've given in the event this happens again in the future. For now I will keep things as they are seeing that eth0 eventually started activating properly. Thanks for the tip.

Is the " /p...41.fc6.i386.rpm" portion of your instruction correct? The "p...41" part seems a bit unusual.

Trapper

LinuxTom
16th April 2007, 02:27 PM
Trapper, it's correct the forum tends to concatenate links for display.

download.fedora.redhat.com/pub/fedora/linux/core/6/i386/os/Fedora/RPMS/iputils-20020927-41.fc6.i386.rpm