PDA

View Full Version : wacom volito on fedora 5



rik_cross
10th April 2007, 03:04 PM
hi,

i followed the howto, and set up my volito pen. it seems to work fine, but the tablet is an exact representation of the screen. in fact, i cannot move down far enough to click the bottom of the screen. i suspected a problem with Top/Bottom X/Y, so added lined to my xorg.conf, which had no effect.

xsetwacom doesn't seem to see the device, although wacdump works perfectly.

other things that might be useful to know:
xsetpointer -l doesn't return stylus/pointer, etc
i changed /dev/input/event0 to /dev/input/wacom
Removed NAME="input/%k", from the contents of /etc/udev/rules.d/10-wacom.rules (not 60-wacom.rules)

in totally stumped, so any pointers would be appreciated.

Rik.

rik_cross
11th April 2007, 01:14 PM
i just noticed, when i try to compile wacom.o (i'm not even sure i need to be doing this), make gives tre following error

make[5]: *** [/home/rj/linuxwacom-0.7.6-4/src/2.6.15/wacom.o] Error 1
make[4]: *** [_module_/home/rj/linuxwacom-0.7.6-4/src/2.6.15] Error 2
make[4]: Leaving directory `/usr/src/kernels/2.6.15-1.2054_FC5-i686'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/home/rj/linuxwacom-0.7.6-4/src/2.6.15'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/home/rj/linuxwacom-0.7.6-4/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/rj/linuxwacom-0.7.6-4'
make: *** [all] Error 2

John the train
11th April 2007, 08:37 PM
Hi rik. I've just been trying to compile my Wacom drivers and get virtually the same message as you. What I did notice during configure ( using --enable-wacom ) was a warning that wacom.o could not be compiled without XF86 or Xorg SDK, but I can't trace them through yum search or in yumex. As the warning referred to ' wacom.o (.ko ) ' it looks as if it may be an important part, I'll do some more digging.
Edit. Checking old threads on wacom I found that installing X development and XFCE development through add/remove software provided the missing libraries, and it looks as if I've successfuly compiled things. But it's nearly 10.00 pm local time, I'm getting tired and need a shower. Worse, no beer in the house! Tomorrow i'll see about installing the kernel modules, editing xorg and testing.
Thanks for the encouragement Paul, it helps to know that someone has got it working in FC6. With F7 methinks I may ' freeze ' the install, at least as far as kernel updates, and se if I can get it working with the default install drivers.

paul matthijsse
11th April 2007, 08:58 PM
Hello,
a quick and a bit fuzzy response: if I remember well, my Wacom Volito was not responding at all on fc5, but it does -- with some tuning -- on fc6. It did work on fc4 btw. Perhaps a kernel question or something?

Paul.