PDA

View Full Version : udev issue



tauro_kpo
10th April 2007, 08:59 AM
When I restart my system, it loads the kernel, it checks the clock, and inmidiately after, it says:

Initating udev: udevd[435]: add to rules: unknown key ´ATTRS{idVendor}´
udevd[435]: add to rules: unknown key ´ATTRS{idProduct}´
udevd[435]: add to rules: unknown key ´ATTRS{idVendor}´
udevd[435]: add to rules: unknown key ´ATTRS{idProduct}´
udevd[435]: add to rules: unknown key ´ATTRS{idVendor}´
udevd[435]: add to rules: unknown key ´ATTRS{idProduct}´
udevd[435]: add to rules: unknown key ´ATTRS{idVendor}´
udevd[435]: add to rules: unknown key ´ATTRS{idProduct}´
udevd[435]: add to rules: unknown key ´ATTRS{idVendor}´
udevd[435]: add to rules: unknown key ´ATTRS{idProduct}´
udevd[435]: add to rules: unknown key ´ATTRS{idVendor}´
udevd[435]: add to rules: unknown key ´ATTRS{idProduct}´
udevd[435]: add to rules: unknown key ´ATTRS{idVendor}´
udevd[435]: add to rules: unknown key ´ATTRS{idProduct}´
udevd[435]: add to rules: unknown key ´ATTRS{idVendor}´
udevd[435]: add to rules: unknown key ´ATTRS{idProduct}´

Why is this? It didn't happen always, I think something may have originated this. What could it be?

What's the solution to this?

Thank you very much!

Lindy
10th April 2007, 05:12 PM
But other than this does everything work? Do you have some unsupported HW, or something that doesn't have a driver installed yet? I have 2 sound cards in my machine, one onboard + a SB Audigy I have the onboard card disabled. By default Fedora kept trying to use the onboard card , and when I set the Audigy card to be the default, udev kept giving me some errors when I booted/rebooted the machine. What finally fixed this was updating udev. If you haven't updated udev give it go and see what happens.

tauro_kpo
11th April 2007, 03:40 AM
Hi!

Curiously I have two soundcards, same as you, and I'm using just the pci one.

But I had udev up-to-date. So I didn't know what to do :-S

Until I found the solution in another forum, I'll paste it.


You've installed kino, likely on Fedora, in which case this is a known bug. If this is not the case, please provide information on your distribution.

To correct the problem, edit the file /etc/udev/rules.d/kino.rules, and change all occurrences of ATTRS to SYSFS. With vi, you can do this with the command:

%s/ATTRS/SYSFS/g

Hope it helps somebody else!

Lindy
11th April 2007, 03:46 AM
Cool , glad you got it corrected even if I was out to lunch ;-)