PDA

View Full Version : MESSAGE: 'unknown filesystem type 'ntfs''



PabloTwo
9th April 2007, 10:56 PM
Just installed FC6 where FC5 used to be (did not 'update'... did a fresh install) on my W2K/FC6 dual boot system. With FC5 I had an NTFS windows partition mounted so I could access files from there.

When attempting to 'mount' that same partition after the FC6 install, the mount command returns this message:

unknown filesystem type 'ntfs'. Are you kidding, or what?

A peek into the /etc/filesystems file has no 'ntfs' entry and putting one there has no effect.
I did a 'fdisk -lu' to insure the target partition was listed.. yes, it was.
I created the folder '/media/ntfs' to mount the ntfs partition to.

#mount /dev/sda5 /media/ntfs -t ntfs -r -o umask=0222
unknown filesystem type 'ntfs'
#

All this worked fine in FC5....what gives with FC6 that it doesn't know an NTFS filesystem?

Paul
Seville FL

JEO
9th April 2007, 11:17 PM
You need to have an ntfs driver. I believe the kernel ntfs driver can be found on livna repository kmod-ntfs.i686 and in the extras repository there is a user space driver ntfs-3g which includes write access to the ntfs partition but I haven't personally tried it.

Janl
9th April 2007, 11:22 PM
I use the ntfs-3g driver and haven't had anything but success with it so far.

PabloTwo
9th April 2007, 11:39 PM
Sometimes the best way to solve a problem is to walk away from it for awhile.

Shortly after posting my original post, I shut down the computer, sat down to supper and watching the evening TV news. It was sometime then it dawned on me. Doh! I had forgotten to install the kernel-module-ntfs-<kernel_specific_version>blah-blah.rpm package.

Sorry for the false alarm...and thanks.

Paul
Seville FL

PabloTwo
10th April 2007, 11:02 PM
I thought I'd just go and download the 'kernel-module-ntfs-<version>.rpm file from linux-ntfs.org. No way. That repository stops with FC5. From FC6 and onward, you're expected to use Fedora Extras as a yum repos to get the ntfs module for your install.

Without a working internet connection on my FC6 install, I was forced to go the ntfs-3g route, all that stuff downloaded via Windows. That necessitated a 'fuse' install also prior to installing ntfs-3g. But that's done, it works, though nts-3g isn't happy with my version of FC6.

Nothing comes easy with this OS.

Paul
Seville FL

STeeLGuT
10th April 2007, 11:58 PM
mount /dev/sda5 /media/ntfs -t ntfs -r -o umask=0222

mount /dev/sda5 /media/ntfs -t ntfs-3g -r -o umask=0222

As I recall...