PDA

View Full Version : openoffice.org printing problem



kol
9th April 2007, 10:31 PM
Hello!

I have a problem with printing from openoffice programs (FC6, last updates). I have installed 2 my printers with system-config-printer. I can see them in the list, can select one, but 'print' button is often disabled (gray). I can 'Print to file' only. Sometimes I can't print to file either. :-( No problem with printing from Firefox- all works OK.

How can I resolve this problem? Why oo.org is so intellectual?

Thank you for help.

kol
9th April 2007, 10:44 PM
The same with evince. In xterm 2 messages: "** (evince:18391): WARNING **: Error result: Too many failed attempts".
So it is not oo.org problem.

Any idea?

byroniac
9th April 2007, 10:46 PM
Not sure what your problem is, but have you tried setting SELinux to Permissive? Go to System -> Administration -> Security Level and Firewall, then type in the root password at the dialog that pops up, then click the SELinux tab to see the current SELinux setting. It's a drop-down, so change it to Permissive (NOT Disabled!) and try printing. Recommend that you leave SELinux on the Enabled setting as much as possible, and only choose Permissive when necessary (such as printing most likely).

byroniac
9th April 2007, 10:49 PM
The same with evince. In xterm 2 messages: "** (evince:18391): WARNING **: Error result: Too many failed attempts".
So it is not oo.org problem.OK. I doubt your problem is with SELinux. Log in as root and browse your system message log by starting up Terminal in Applications -> Accessories -> Terminal:
su -
less /var/log/messagesYou can use spacebar, PgUp, PgDn, and just type "q" to quit when you're done (exits the "less" viewer) then Ctrl-D or type "exit" to get out of the "su" (substitute user) mode.

kol
9th April 2007, 11:13 PM
Thank you.

There are such messages in log:

Apr 10 00:50:23 unknown0001291b3250 hpiod: error reaping URB: No such device io/
hpiod/usbext.c 100
Apr 10 00:50:23 unknown0001291b3250 hpiod: invalid urb read completion hp:/usb/h
p_LaserJet_1320_series?serial=00CNHW61JLWF: No such device io/hpiod/device.cpp 2
41
Apr 10 00:50:23 unknown0001291b3250 hpiod: error discarding URB: No such device
urb=0x9d1e738 io/hpiod/usbext.c 131
Apr 10 00:50:23 unknown0001291b3250 hpiod: unable to read MlcReverseCmd header:
No such device
Apr 10 00:50:23 unknown0001291b3250 hpiod: invalid MlcCredit from peripheral, tr
ying miser
Apr 10 00:50:26 unknown0001291b3250 hal_lpadmin: Prompting for driver for printe
r Stylus_COLOR_740
Apr 10 00:50:26 unknown0001291b3250 hal_lpadmin: File "/usr/libexec/hal_lpadmin"
, line 198, in main h = HalLpAdmin()
Apr 10 00:50:26 unknown0001291b3250 hal_lpadmin: File "/usr/libexec/hal_lpadmin"
, line 172, in __init__ self.addPrinter()
Apr 10 00:50:26 unknown0001291b3250 hal_lpadmin: File "/usr/libexec/hal_lpadmin"
, line 185, in addPrinter printer.add()
Apr 10 00:50:26 unknown0001291b3250 hal_lpadmin: File "/usr/libexec/hal_lpadmin"
, line 127, in add self.uid, self.name)
Apr 10 00:50:26 unknown0001291b3250 hal_lpadmin: File "/usr/lib/python2.4/site-p
ackages/dbus/proxies.py", line 25, in __call__ ret = self._proxy_method (*args, **keywords)
Apr 10 00:50:26 unknown0001291b3250 hal_lpadmin: File "/usr/lib/python2.4/site-p
ackages/dbus/proxies.py", line 102, in __call__ reply_message = self._connec
tion.send_with_reply_and_block(message, timeout)
Apr 10 00:50:26 unknown0001291b3250 hal_lpadmin: File "dbus_bindings.pyx", line
455, in dbus_bindings.Connection.send_with_reply_and_block
Apr 10 00:50:26 unknown0001291b3250 hal_lpadmin: DBusException: The name com.red
hat.PrintDriverSelection was not provided by any .service files

I have tried to repeat the situation, but no such messages in log now.

Switching to 'Permissive' (and 'Disabled') in SELinux doesn't help.

byroniac
9th April 2007, 11:48 PM
Sorry, that leaves me clueless then. I just knew I couldn't get my USB fax/printer (Brother FAX-4100e) to work without setting SELinux to Permissive (to anyone else who's interested: yes, there's a FAQ entry for that on the Brother site, but I'm hesistant to even try it, and I seldom need to print anyway).

Anyways, I forgot to tell you, but you can do this too:
cat /var/log/messages | grep -i whatever | lessReplace the whatever, of course, with what ever you want.

kol
10th April 2007, 07:58 AM
I know about grep :-), but I don't know what can I use instead of 'whatever' word :-)
Thank you for your try to help.

kol
19th April 2007, 09:43 PM
software update give no solution. I think problem is near gnome printing libs. Openoffice.org and evince are built with gtk? Both have problems with printing dialog box. Is it gtk problem&? There is nothing special in /var/log/messages, /var/log/cups/access_log, /var/log/cups/error_log, other programs and direct printing works fine.
Can anyone help me? It's terribel print to file, then restart oo.org to print to file again. Looks like RedmondOS.

kol
19th April 2007, 10:27 PM
https://bugs.launchpad.net/ubuntu/+source/evince/+bug/66379

TheHammer
30th April 2007, 04:15 AM
I had the same problem with evince and open office. I don't know much about linux but I think I figured out my problem, it may work for you, I don't know. I was trying to access CUPS through my web browser with http://localhost:631 but it wouldn't work; http://127.0.0.1:631 was working though. After some reading between this thread and the one on Ubuntu I checked my network settings using System->Administration->Network. Under the hosts tab I had an entry for localhost but it was in IPv6 format (::1) I have previously disabled IPv6 on this install due to performance issues. When I changed the entry for localhost to 127.0.0.1 the entry disappeared. It seems IPv6 is running in some form on the system even though I removed it.(Although some updates may have reenabled it I guess). Anyways, just delete the host entry, save the changes. I was able to print again through evince and open office. I can't seem to put a hosts entry back in though for the 127.0.0.1 address but I'm not too worried at this point about that, I need to find the instructions again for removing IPv6 and see if something was reenabled. Also, I'm not sure what's going to happen on a reboot, may have to delete the entry again.

To sum it up:

System->Administration->Network
Hosts tab
delete localhost entry

kol
30th April 2007, 11:04 AM
Hm. You are right- it's my fault not gtk. I had a mistake in /etc/hosts:


127.0.0.0 localhost

I correct it to 127.0.0.1 and all works now.

abaumhau
30th April 2007, 04:33 PM
I have found several Ubuntu machines that had /etc/host entries for the hostname listed as 127.0.1.1 instead of 127.0.0.1. I don't know what application made the bogus change, but this was the problem with printing.