PDA

View Full Version : VIrtualization



carverj
9th April 2007, 11:50 AM
Good evening,
I have a MSI K9N SLI Platinum mainboard and cannot find anything in BIOS regarding enabling virtualization.
I also tried to do
cat /sys/hypervisor/properties/capabilities
as per XEN install instructions.
No file exists!!
Does this mean I need a new mainboard to run XEN?
Cheers in advance.

markkuk
9th April 2007, 12:35 PM
Did you install the virtualization software when you installed Fedora? Are you running a Xen kernel?

carverj
9th April 2007, 03:18 PM
Did you install the virtualization software when you installed Fedora? Are you running a Xen kernel?
No, I thought it would be preferable to get the base system working first.
I am following the instructions here : - http://fedoraproject.org/wiki/FedoraXenQuickstartFC6#head-712c355cbc215744acb585bb1e26bd781f0376ee
and under system requirements I failed fully virtualized guest test.
Could I still get XEN working? So I need to complie a XEN/Fedora kernel?

Seve
9th April 2007, 04:46 PM
Hello:
yum list | grep kernel-xen

should show you a kernel or 2 that you can install via yum

Seve

markkuk
9th April 2007, 05:04 PM
I am following the instructions here : - http://fedoraproject.org/wiki/FedoraXenQuickstartFC6#head-712c355cbc215744acb585bb1e26bd781f0376ee
and under system requirements I failed fully virtualized guest test.
Could I still get XEN working? So I need to complie a XEN/Fedora kernel?
Yes, you can run Xen in para-virtualized mode without hardware virtualization support. You don't need to compile anything, just install the software as instructed in http://fedoraproject.org/wiki/FedoraXenQuickstartFC6#head-a5731858dc41de62346f6075a14ca5a18da14de7

carverj
10th April 2007, 04:34 AM
I rebooted to install from Xen kernel and noticed it missing from grub menu.
So I edited grub so that it could only boot the new kernel. It started to boot and grumbled about not being able to mount something and shutdown (rebooted).
Ideas?

Seve
10th April 2007, 04:49 AM
Hello:
Can you boot to a standard kernel and open a terminal and log in as root
using
su -
yourpassword

and type and post the output of :

yum list | grep -F kernel

Seve

carverj
10th April 2007, 05:04 AM
Sure:
kernel.i686 2.6.20-1.2933.fc6 installed
kernel.i686 2.6.18-1.2869.fc6 installed
kernel-headers.i386 2.6.20-1.2933.fc6 installed
kernel-xen.i686 2.6.20-1.2933.fc6 installed
fortune-kernelcookies.i386 1.0-37.2.fc6.rf dries
fortune-kernelnewbies.i386 1.0-37.2.fc6.rf dries
kernel.i586 2.6.20-1.2933.fc6 updates
kernel-PAE.i686 2.6.20-1.2933.fc6 updates
kernel-PAE-debug.i686 2.6.20-1.2933.fc6 updates
kernel-PAE-debug-devel.i686 2.6.20-1.2933.fc6 updates
kernel-PAE-devel.i686 2.6.20-1.2933.fc6 updates
kernel-debug.i686 2.6.20-1.2933.fc6 updates
kernel-debug-devel.i686 2.6.20-1.2933.fc6 updates
kernel-devel.i586 2.6.20-1.2933.fc6 updates
kernel-devel.i686 2.6.20-1.2933.fc6 updates
kernel-doc.noarch 2.6.20-1.2933.fc6 updates
kernel-kdump.i686 2.6.20-1.2933.fc6 updates
kernel-kdump-devel.i686 2.6.20-1.2933.fc6 updates
kernel-xen-devel.i686 2.6.20-1.2933.fc6 updates
yum-kernel-module.noarch 1.0.3-1.fc6 extras

Seve
10th April 2007, 05:20 AM
Hello:
Try removing the kernel-xen
log in as root using
su - <--- the dash is important See root (http://www.fedorafaq.org/basics/#root)
yourpassword
then
yum remove kernel-xen.i686 2.6.20-1.2933.fc6
when it's finished type
gedit /etc/grub.conf
and make sure that the entry related to the kernel-xen [which you made in the file] is removed.
save your work, then in the same open terminal do a

yum clean all

then exit the terminal and reboot your machine

When it reboots open a terminal and login as root using
su -
yourpassword
then
yum install kernel-xen

and see how it goes this time.

Seve

carverj
10th April 2007, 07:52 AM
Ok, so I have installed Xen kernel again, here is the unaltered /boot/grub/grub.conf just in case something has gone wrong at this point..
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You do not have a /boot partition. This means that
# all kernel and initrd paths are relative to /, eg.
# root (hd0,0)
# kernel /boot/vmlinuz-version ro root=/dev/hda1
# initrd /boot/initrd-version.img
#boot=/dev/hda
default=1
timeout=5
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora Core (2.6.20-1.2933.fc6xen)
root (hd0,0)
kernel /boot/xen.gz-2.6.20-1.2933.fc6
module /boot/vmlinuz-2.6.20-1.2933.fc6xen ro root=LABEL=/ rhgb quiet
module /boot/initrd-2.6.20-1.2933.fc6xen.img
title Fedora Core (2.6.20-1.2933.fc6)
root (hd0,0)
kernel /boot/vmlinuz-2.6.20-1.2933.fc6 ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.20-1.2933.fc6.img
title Fedora Core (2.6.18-1.2869.fc6)
root (hd0,0)
kernel /boot/vmlinuz-2.6.18-1.2869.fc6 ro root=LABEL=/ rhgb quiet
initrd /boot/initrd-2.6.18-1.2869.fc6.img

The Xen entry isn't showing when I reboot!!

markkuk
10th April 2007, 08:46 AM
Comment out the "hiddenmenu" option by adding a # character in the beginning of that line.

carverj
10th April 2007, 08:59 AM
Oh, OK. BTW, moved post to
http://forums.fedoraforum.org/forum/showthread.php?t=152652