PDA

View Full Version : Slow SATA Disk



JoeHill
7th April 2007, 05:25 PM
All,

I am running FC6 (with latest update, 64-bit) on AMD Dual Core with 1GB
RAM. It contains a SATA hard disk. I am experience sluggishness when
files are opened or closed (saved). I suspect that i have slow SATA
performance even though i am not sure. I have following stats.

# hdparm -Tt /dev/sda

/dev/sda:
Timing cached reads: 2452 MB in 2.00 seconds = 1226.48 MB/sec
Timing buffered disk reads: 86 MB in 3.03 seconds = 28.35 MB/sec

I am concerned about 28.35 MB/Sec speed here.

# hdparm -i /dev/sda

/dev/sda:
HDIO_GET_IDENTITY failed: Inappropriate ioctl for device

# dmesg | grep -i sata
sata_nv 0000:00:0e.0: version 3.2
ata1: SATA max UDMA/133 cmd 0xE800 ctl 0xE482 bmdma 0xE000 irq 21
ata2: SATA max UDMA/133 cmd 0xE400 ctl 0xE082 bmdma 0xE008 irq 21
scsi0 : sata_nv
ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
scsi1 : sata_nv
ata2: SATA link down (SStatus 0 SControl 300)

# lsmod | grep -i sata
sata_nv 29509 4
libata 120553 1 sata_nv

Kernel Boot Parameter
kernel /vmlinuz-2.6.20-1.2933.fc6 ro root=LABEL=/1 noquiet
combined_mode=libata

Any suggestions/recommendations/comments are welcome.

Thanks

sej7278
7th April 2007, 09:13 PM
i thought there was a problem with the nvidia sata stuff, or that you had to use a mindstorm driver or something.

you should be getting at least 60mbps buffered, although that cached looks ridiculously high.

friez
8th April 2007, 05:57 PM
can you try booting with out the option *combined_mode=libata* and see what happends

JoeHill
9th April 2007, 03:07 PM
I already have that as mentioned in my initial post.

friez
9th April 2007, 08:02 PM
can you try booting with out the option *combined_mode=libata* and see what happends uhm your post does not say that you tried without that option