PDA

View Full Version : Updates not.. Updating.



Greens
7th April 2007, 01:50 AM
Hello all,

I seem to be having a problem and I'm not quite sure what to do about it. I have a bunch of packages that need updating. So I run the package updater, and it goes through everything just fine, everything seems to work very well(except a few problematic updates that I've unchecked), it says 'Software Installed Successfully'.. But all the updates are still there when I open the package updater again. Same updates, 277 of them, not installed at all.

I'm still fairly new to the Linux scene - been running Fedora for just a little less than a year now and haven't had a problem yet - so if this is something obvious, I apologize. In any case, any help would be greatly appreciated.

Thanks,
Greens

stevea
7th April 2007, 02:04 AM
?Package updater? Which utility are you running - it has a name.

I suspect that the problem is that the dependencies from the few packages that you have chosen not to update are now preventing the 277 packages from updating.

As a hypothetical example, imagine that you chose to NOT update some trivial gnome program. It may be dependent on some particular versions of several libraries - so they can't be updated either. Then you can't update the applications that now depend on the newer libraries that can't be updates . ... and so on. Stopping a few packages can have widespead impact in a short while.

What are the "problematic updates" that you are disallowing and why ?

[edit]
Oops - I see there is a "pup" package updater.

Greens
7th April 2007, 02:27 AM
I'm using pup(say's "[Package Updater]" on the panel thing). I also tried using yum, but I couldn't get that to work.

I didn't really think it would be a dependency issue; if that were the case wouldn't it tell me? Actually, that's why I disallowed these. Though, I suppose I could be wrong. Up til now, it hasn't been a problem. I'll list them just in case: firefox, eclipse, and SDL. SDL I know is pretty important, but up to now hasn't been a problem; though I did want to get that working. I'm trying to run the Updater to get whatever the specific errors were, and it's taking a while.. I don't think it's going to work.

Anyway it was all dependency issues that I was having trouble fixing. I can't recall what SDL was calling for offhand, but Eclipse was asking for some Lucene package - upon trying to install that, I found that I already have it, and a more recent version than what it was asking for(perhaps that was a problem?); and firefox was asking for gecko-libs or something like that, which I couldn't find a good source for.

strikeforce
7th April 2007, 02:54 AM
Make sure you clean out yum and then double check that you have got the uptodate repositories.



yum clean all
yum check-update