PDA

View Full Version : yum update, faad2 error



vertigo88x
6th April 2007, 08:46 PM
i got the notice that updates were available. it went fine except for faad2. i have this error:

[root@localhost ronald]# yum update
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
livna 100% |=========================| 1.1 kB 00:00
core 100% |=========================| 1.1 kB 00:00
updates 100% |=========================| 1.2 kB 00:00
freshrpms 100% |=========================| 1.1 kB 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
primary.xml.gz 100% |=========================| 1.6 MB 00:24
extras : ################################################## 5031/5031
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for gtk-murrine-engine to pack into transaction set.
gtk-murrine-engine-0.52-1 100% |=========================| 6.7 kB 00:01
---> Package gtk-murrine-engine.i386 0:0.52-1.fc6 set to be updated
---> Package faad2.i386 0:2.5-2.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: faad2 = 2.0-19.20050131.lvn6 for package: xmms-faad2
--> Finished Dependency Resolution
Error: Missing Dependency: faad2 = 2.0-19.20050131.lvn6 is needed by package xmms-faad2


but:

[root@localhost ronald]# rpm -q faad2
faad2-2.0-19.20050131.lvn6

ryptyde
6th April 2007, 10:14 PM
I always see these errors when repos are mixed, you will have to disable Fresh or Livna. I personally have Livna enabled but have drawn from other repos to get a package that may not be available otherwise but disable the repo when finished.

Mixing Repos=Problems!

Seve
6th April 2007, 10:18 PM
Hello:
You have 2 repositories enabled that are not [100%] compatible with each other.
livna
and
dries
That is the root cause of your dependency issue.
You should not have both livna and freshrpms enabled all the time.
One or the other, but not both.
Livna is the one that should be enabled and freshrpms should be disabled.


You can try the following:

yum disablerepo=freshrpms update

and see if that helps, if not then have a look see at this thread. It's pretty close to the same issue you have, meaning you may have to remove some packages and then re-install them from the livna repo etc.
Forum Thread (http://forums.fedoraforum.org/forum/showthread.php?t=141695)

Seve

LesNagy
6th April 2007, 11:32 PM
Is the livna preference just yours Steve? The reason I ask is that I was using livna as my main alternative repository but at some point fresh had some things that livna didn't, or livna confilicted with some other things I installed from various webpages that didn't exist in any repo. Since using freshrpms and disabling livna, I have had almost zero dependency issues and seem to be able to use other 3rd party programs with less trouble.

Seve
7th April 2007, 12:12 AM
Is the livna preference just yours Steve? Hello:
Who is Steve ?


The reason I ask is that I was using livna as my main alternative repository but at some point fresh had some things that livna didn't, or livna confilicted with some other things I installed from various webpages that didn't exist in any repo. Since using freshrpms and disabling livna, I have had almost zero dependency issues and seem to be able to use other 3rd party programs with less trouble.

Sorry, perhaps I should have phrased things better. :) I have used Freshrpms and Dries for ages, until the release of Fc6.
The reason for suggesting Livna [and it should have been phrased as a suggestion] over the others is outlined here : Livna FAQ (http://rpm.livna.org/rlowiki/FAQ) in the first paragraph.
Also, for new users having only the Livna 3rd party repo enabled is by far the best advice, in my humble opinion.
One only has to scan through this forum to see the hundreds if not thousands of posts related to repository conflicts.

However, I think you have hit the nail on the head, as long as you do not have [Freshrpms or Freshrpms&Dries] enabled at the same time as Livna you should not have any issues.
Equally so with not having [Livna] enabled at the same time as
Freshrpms or Freshrpms&Dries you should be fine.


You should not have both livna and freshrpms enabled all the time.
One or the other, but not both.

There is no reason to switch your repos at this point if it is working for you.

Seve

jimj_wpg
7th April 2007, 01:39 AM
Hello:
You have 2 repositories enabled that are not [100%] compatible with each other.
livna
and
dries
That is the root cause of your dependency issue.
You should not have both livna and freshrpms enabled all the time.
One or the other, but not both.
Livna is the one that should be enabled and freshrpms should be disabled.


You can try the following:

yum disablerepo=freshrpms update

and see if that helps, if not then have a look see at this thread. It's pretty close to the same issue you have, meaning you may have to remove some packages and then re-install them from the livna repo etc.
Forum Thread (http://forums.fedoraforum.org/forum/showthread.php?t=141695)

Seve

The old RedHat updater program used to have a graphical front end to do this ... to check and uncheck repos as needed.

How do I manually enable / disable a repo? I know how to add them to the etc/yum.repos.d folder.

I'd like to see that feature brought back as part of a new PUP or successor program.

LesNagy
7th April 2007, 01:45 AM
Hello:
Who is Steve ?
Oops, sorry, I should have checked my spelling before posting.

Thanks for the reply.

P.S. I am just down the highway from you. I am in Hamilton.

LesNagy
7th April 2007, 01:54 AM
The old RedHat updater program used to have a graphical front end to do this ... to check and uncheck repos as needed.

How do I manually enable / disable a repo? I know how to add them to the etc/yum.repos.d folder.

I'd like to see that feature brought back as part of a new PUP or successor program.

Perhaps you should give kyum a try and/or yumex. They both have the sort of features you ask for.