PDA

View Full Version : new 8800GTS - can't get into GUI



Cigaboo
6th April 2007, 01:49 AM
Hi. I dual boot with Windows XP and Fedora 6. I have the nvidia drivers installed in Fedora 6 and haven't had any issues. But I recently upgraded to an 8800GTS card, and when I tried to boot fedora it told me it was unable to load the GUI and instead gave me the command prompt. I assume I need to somehow disable the nvidia driver or install an updated driver via the command prompt. Any suggestions?

Dies
6th April 2007, 01:57 AM
When grub first comes up you can hit any key to display a menu of operating systems, if you have others, while in this menu there's a few things you can do to get into runlevel 3.
Note - If you set a grub password you'll have to hit p and enter it to go any further.

Highlight the Fedora entry with the arrow keys then press the letter 'e' to edit the entry now highlight the line that starts with kernel and hit 'e' again to edit, now leaving a space add the number '3' then hit enter and 'b' to boot.

A quicker way is to highlight the Fedora entry then hit 'a' for append and leave a space, add the '3' then hit enter to boot.

login in as root



rpm -ivh http://rpm.livna.org/livna-release-6.rpm <-- this will install the Livna repo as a source for yum which will give you access to the Nvidia drivers along with some other stuff you'll probably want.
yum remove kmod-nvidia <-- If that's what you had installed
yum clean all
yum install kmod-nvidia -y <-- install the drivers
mv /etc/X11/xorg.conf /etc/X11/xorg.conf.original <-- move your old config out of the way
nvidia-xconfig <-- and let Nvidia's tool generate a new, improved one for you
shutdown -r now <-- reboot and enjoy, hopefully


Basically just re-install the drivers, if you already have livna enabled then skip that step.
Here's my original post if you need it.

http://forum.fedoraforum.org/forum/showpost.php?p=759359&postcount=4

Cigaboo
7th April 2007, 12:44 AM
Thanks. This is probably exactly what I need to do.