PDA

View Full Version : [RESOLVED] Xmms MP3 Support



Bana
26th April 2004, 02:33 AM
Okay, I am quite well aware of the MP3 licensing situation and the xmms-mp3 binary that is available on the livna yum repository yet these are all for the i386. So I tried rebuilding the xmms-mp3.src.rpm and it goes successfully and then I install the rpm yet then when I add the mp3s to my playlist I can click on them but the active selection just flies through the list until it hits an .ogg file. Obviously the plugin isn't working yet I can see it in the input plugin selection list and configure it. Anyone have any previous experience?

I then tried rebuilding the xmms that I got off of xmms.org yet near the end of the build process I get this message:
.....libsong_change.so.debug()(64bit) libstereo.so.debug()(64bit) libtonegen.so.debug()(64bit) libvoice.so.debug()(64bit)
libvorbis.so.debug()(64bit) libwav.so.debug()(64bit) libxmms.so.1.3.1.debug()(64bit)
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/xmms-1.2.10-root
error: Installed (but unpackaged) file(s) found:
/usr/lib64/xmms/Input/libmikmod.la
/usr/lib64/xmms/Input/libmikmod.so
/usr/lib64/xmms/Input/libvorbis.la
/usr/lib64/xmms/Input/libvorbis.so


RPM build errors:
user havardk does not exist - using root
group havardk does not exist - using root
user havardk does not exist - using root
group havardk does not exist - using root
Installed (but unpackaged) file(s) found:
/usr/lib64/xmms/Input/libmikmod.la
/usr/lib64/xmms/Input/libmikmod.so
/usr/lib64/xmms/Input/libvorbis.la
/usr/lib64/xmms/Input/libvorbis.so
So I know it is something with the plugins yet there aren't any in there and there is no rpm in /usr/src/redhat/RPMS/x86_64/

SuperNu
26th April 2004, 04:32 AM
Just wondering, but did you enable the mp3 plugin under the preferences panel?

--SN

imdeemvp
26th April 2004, 06:13 AM
To be honest here i totally drop XMMS to play mp3's it is an unstoplable headache so i browsed around and found realone player, zinf, and totem for dvd playback and also mp3's and cd's.

1) zinf is no headache....easy to run!
2) realone player the same as zinf......easy to run!
3) for totem you have to download all the needed files to make it work it took less than 10 minutes to get it going....

no offense bana but i think to still try to play mp3's with XMMS is not worth the hassle! :D

Bana
27th April 2004, 04:58 AM
Supernu: Yes I did enable it.
imdeemvp: You have a point there, and I tried installing zinf (recompiling it for x86_64 and the corresponding id3libs) yet I hit a snag at the zinf recompiliation here:
/Panel.cpp -fPIC -DPIC -o .libs/Panel.o
/usr/include/c++/3.3.3/x86_64-redhat-linux/bits/atomicity.h: In member function
`void Panel::GetControlToolTips(std::vector<std::pair<Rect, std::string>,
std::allocator<std::pair<Rect, std::string> > >&)':
/usr/include/c++/3.3.3/x86_64-redhat-linux/bits/atomicity.h:40: error: inconsistent
operand constraints in an `asm'
make[3]: *** [Panel.lo] Error 1
make[3]: Leaving directory `/usr/src/redhat/BUILD/zinf-2.2.5/ui/zinf'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/usr/src/redhat/BUILD/zinf-2.2.5/ui/zinf'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/zinf-2.2.5/ui'
make: *** [all-recursive] Error 1
error: Bad exit status from /var/tmp/rpm-tmp.15880 (%build)


RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.15880 (%build)
So on to realone, but turns out it doesn't compile either so no mp3 music for me :(

imdeemvp
27th April 2004, 05:48 AM
Bana.....are you using the zinf rpm?

and with realone i had no problems either....i downloaded this one: r1p1_linux22_libc6_i386_a1.bin and it is a beauty for mp3's!

dont try to recompile anything.....just install it if nothing else works well download totem and all the needed files and YES you will have mp3's playing!

Bana
1st May 2004, 12:32 AM
The reason why I was trying to recompile them is that I run the x86_64 FC2Test3 so I would have had to install tons of i386 libs for it to work otherwise. Don't worry though I tried installing the bin version of real one and it works! Now just to get the ALSA devs to support my soundcard... :p

triplehead
26th May 2004, 10:05 PM
get the source tar.gz package of xmms, it works :D

Bana
3rd June 2004, 08:57 AM
RESOLVED Copied from here: http://www.fedoraforum.org/forum/showthread.php?s=&threadid=2860 :
I have found that for simple 1 package items that it is easiest to just visit the srpm folder and download the src rpm http://rpm.livna.org/fedora/2/i386/...lvn.2.2.src.rpm then (remeber this command well) rpmbuild --rebuild --target x86_64 xmms-mp3* If you have all the dependencies (the hardest part but usually you just need a yum install xmms-devel) then go over to /usr/src/redhat/RPMS/x86_64 and install your fresh golden-brown xmms-mp3.x86_64.

HTH

Päran
19th August 2004, 06:53 PM
OK, maybe this isn't much of a problem anymore (this thread is rather old) but the yeasiest way if you can't find the proper xmms-mp3-rpm is to surf in to http://www.xmms.org and download the latest source tar-file for xmms (e.g. xmms-1.2.10.tar.gz (http://www.xmms.org/files/1.2.x/xmms-1.2.10.tar.gz)). Then after you have unpacked it do

./configure
make
make install

just as the readme-file says. That's it. You're done. (but after reading the thread more thoroughly I realise that it was during this the problem started in the first place...)

Bana
21st August 2004, 01:48 AM
Added to the fact that compiling from source is not a good idea in a rpm based distribution as it makes hard to clean-up messes :p