PDA

View Full Version : mic not working



satyajit.r
28th March 2007, 01:00 PM
hi,

I have a compaq presario v3000 laptop, Fedora core 6 installed. my sound card detected properly, i can play songs but my microphone does not work. Trying to record in krec i couldn't. I have unmuted the kmix controls and used alsa mixer too. Nothing seems to work. I use a dual boot, windows jus for the yahoo voice chat. I want to get rid of windows and use skype in linux. Can some one help me please.

pheeror
28th March 2007, 02:35 PM
Did you choose right input (line/mic/master) for recoding?

satyajit.r
28th March 2007, 02:55 PM
well i did use the mic...even tried interchanging them...

SentientMachine
28th March 2007, 03:20 PM
I tried krec on my Fedora Core 6 desktop machine and I was also unable to get krec to work.

I tried audacity which is a Free, Cross-Platform Sound Editor and I was able to record a clip. You can check if your Mic is working by attempting to use this program instead.

yum install audacity

http://audacity.sourceforge.net/

satyajit.r
28th March 2007, 04:25 PM
i tried even that...nothing got recorded... and when i tried the play button
i got this message:

Error while opening sound device. Please check the output device settings and the project sample rate.

SentientMachine
28th March 2007, 04:31 PM
Maybe your Mic can only handle a certain sample rate. Try switching the sample rates:

In Audacity click Edit->Preferences. Choose the 'Quality' tab and set the sample rate to 11025 Hz. If that doesn't work then try other rates.

-Eric

satyajit.r
28th March 2007, 04:38 PM
well i tried that...still didnt work...the playback device couldnt be located...i get no options on the audio playback in the preferences....

SentientMachine
28th March 2007, 05:07 PM
Well at least we are homing in on the problem. In my Audacity preferences I have the following options.
Audio I/O Playback Device: OSS: /dev/dsp
Audio I/O Recording Device: OSS: /dev/dsp
Audio I/O Recording Channels: 2 (Stereo)

Something must be wrong with the sound card.
Try opening a terminal and run system-config-soundcard
enter root pw
Run the sound test.

If that does not work, try clicking system tab and click 'reload audio drivers', you will have to restart then try again. If that does not work, we will have to try messing with the sound card settings.

satyajit.r
28th March 2007, 06:36 PM
I tried system-config-soundcard, initially the sound card did test did not work, reloaded the audio drivers and rebooted the system. Now the audacity plays, well does not record yet.

satyajit.r
31st March 2007, 02:18 PM
Can you tell me how i could mess around with the sound card settings please.

SentientMachine
2nd April 2007, 01:20 AM
I did a google search for "fc6 microphone test" and thought this solution might help you:

http://forum.skype.com/lofiversion/index.php/t66544.html

If that does not work:

Try running in a terminal gnome-volume-control.
Make sure the line-in bar is moved up.
Click Edit and Preferences and make sure "Microphone" is selected. Make sure Microphone's volume level is pulled up half way.
Try choosing the 'switches' tab and check or un-check the "line-in capture" check box and the Headphone Jack Sense checkbox.