PDA

View Full Version : Graphical Boot screen gone



jimofcheeni
14th March 2007, 10:01 AM
I've been using Fedora 6 for 3 weeks now and I'm loving it up to now!

I noticed the other day that when my computer is booting, I no longer get the X boot screen. I presume it's X, the one with the progress bar (instead of plain text and green [ OK ] boxes). You'll have to forgive my noob-not-knowing-the-lingoness

It's not a major thing, but it'd be nice to have it back!

Thanks
James

Dies
14th March 2007, 03:45 PM
It is X, although the not the one you end up using but still X.
Open a terminal:

su -
gedit /boot/grub/grub.conf


and make sure at the end of the kernel line there is 'rhgb quiet'

So it might look like

kernel /boot/vmlinuz-something ro root=/dev/whatever rhgb quiet

If it's not there add it in, if it is there - then is it possible you removed something it relied on?

Nipperspot
14th March 2007, 04:43 PM
Make sure the default runlevel in /etc/inittab is set to 5 and not 3:


# Default runlevel. The runlevels used by RHS are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
#
id:5:initdefault:

Dies
14th March 2007, 05:57 PM
Make sure the default runlevel in /etc/inittab is set to 5 and not 3:


# Default runlevel. The runlevels used by RHS are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
#
id:5:initdefault:

That has no effect on the graphical boot screen.

u-noneinc-s
14th March 2007, 07:43 PM
I have the same situation so I will be interested in this thread too.

I have a fresh install of FC6 which boots fine with rhgb.

I have a FC6 upgrade which boots text all the way to the graphical login screen. It started with FC5. one day it just quit booting graphically. I thought when I did the upgrade it would fix the problem (replace the missing or corrupted file or whatever went wrong), but the text boot remains.

Both grubs are identical. I checked the files returned by "whereis rhgb" (/usr/bin/rhgb /etc/rhgb/temp /usr/share/rhgb), and /user/bin/rhgb show same date and time stamp and filesize, and /etc/rhgb/temp (empty) and /usr/share/rhgb (png's) are identical on both systems.

It's nothing I had been concerned with since it causes no problems and boots fine, but since there is this thread, I figured I would confirm the problem and monitor it for possible fixes.

anilbh
14th March 2007, 08:02 PM
I pressed ctrl-f7 to get it back . And set the preferences to show splash screen.

u-noneinc-s
14th March 2007, 09:21 PM
I pressed ctrl-f7 to get it back . And set the preferences to show splash screen.Thanks for your suggestion, but that is at (or after) login, and, if I understand jimofcheeni correctly, we are talking about the boot process (from power on up to login).
I am getting a graphical login screen as well as a graphical desktop.

It's the boot process itself that is running in text. This would be rhgb, not xdm or gdm or kdm.

Nipperspot
14th March 2007, 11:13 PM
That has no effect on the graphical boot screen.

Did you confirm the runlevel in /etc/inittab is set to 5 and not 3? If this is set to 3, X will not load the GUI.

Dies
14th March 2007, 11:25 PM
Did you confirm the runlevel in /etc/inittab is set to 5 and not 3? If this is set to 3, X will not load the GUI.

You are absolutely right, of course.

But I'm assuming that someone who's new to Linux would be complaining about booting to a login prompt instead of a login screen before worrying about the pretty boot screen, I could be wrong about that though.

Nipperspot
15th March 2007, 12:23 AM
If booting to a login prompt (text), log in and run gdm-binary to run X. This would at least narrow down a possible setting somewhere causing the problem.

Dies
15th March 2007, 12:58 AM
If booting to a login prompt (text), log in and run gdm-binary to run X. This would at least narrow down a possible setting somewhere causing the problem.

Either you're confused or I am.

There is nothing wrong other than the graphical boot not coming up.

u-noneinc-s
15th March 2007, 01:00 AM
I am sure James was referring to the boot process and not the login screen.
I no longer get the X boot screen. I presume it's X, the one with the progress bar (instead of plain text and green [ OK ] boxes) I definitely was referring to the boot process.

jimofcheeni
15th March 2007, 12:04 PM
Sorry to be slow replying here. I am running init 5. I narrowed it down to selinux and some changes I made in grub.conf and modprobe.conf to enable dma mode as in article http://www.fedoraforum.org/forum/showthread.php?t=114586. If these lines are added or if seLinux is not Enforcing, then I get text only.

I have removed selinux, then reinstalled it and now I get a mass of scrolling text which doesn't stop after HAL is loaded. I can make out it says error every so often, but it's impossible to read the rest of it as its scrolling up my screen so fast. Looks like a reinstall! (only my second reinstall, not bad for a noobie i think).

Dies
15th March 2007, 02:19 PM
(only my second reinstall, not bad for a noobie i think).

Nah, You tend to learn a lot each time around, besides there is no use getting too attached to an OS that releases as often as Fedora, just keep a separate home to make stuff easier on yourself.

jimofcheeni
15th March 2007, 08:05 PM
just keep a separate home to make stuff easier on yourself.
I do that already. I kept My Documents on a separate partition than the system in Windows, so it was a natural step to do that. I'm impressed that all your settings are kept after a restore, that never happened with wndows.

Just to let you know I restored and updated to the latest kernel... and the same thing has happened again. I am just running the rest of the yum updates now.

u-noneinc-s
15th March 2007, 08:44 PM
Well now I'm confused (nothing unusual ;)). The link you provided deals with a fix for choppy DVD playback by turning on DMA. What does that (DMA, not choppy DVD) have to do with graphical boot process?

I must admit that when I installed FC5 I used the ide=nodma option, and when I upgraded FC5 to FC6 I used the same option (only because I used it initially on FC5), and when I did the fresh install of FC6 I did not use the nodma option. So there may be something to it since the upgrade boot process is text and the fresh install boot process is graphical, but I would swear that FC5 used to boot graphically and all of a sudden started booting text. :rolleyes:

So, I need to ask, what would be the option (for grub) to turn on DMA (just to test before I start changing files)? Would it be ide=dma or would it be dma on or dma yes? ide=nodma is NOT in my grub kernel line so can I assume that dma IS on already? (I recall reading somewhere that after installing with ide=nodma the nodma should be removed, maybe I did that and just don't remember (again, nothing unusual;)))

I would RTFM, but I don't know which "FM to R" :D

jimofcheeni
15th March 2007, 11:31 PM
this was a method i found to fix nerolinux when it complained about dma mode not being enabled on my dvd-rw. Since I have reinstalled and updated to the latest kernel, nero doesn't moan about this any more, so I guess it was a bug in the previous kernel?
My graphical boot screen is now intermitant... more off than on at the moment.

oldbrad
16th March 2007, 11:38 PM
When is a boot not a boot? I think the thread is about the boot phase between grub and the and the greeter app. If we start-up in mode 3 then we get a text mode terminal in which the kernel boot progress is displayed. On the other hand, in mode 5 we get a graphical progress bar and ALT+ d shows the boot progress text, but now in a sudo terminal with a blue border. Very 'cool' (yuck!) but, dare I say it not very stable. Or at least very processor stressful!

I have had a hardware issue with newly installed FC6 which has cause some most confusing behavior including; black screen of death, 'greeter app has crashed ...', 'your session exited unexpectedly after 5 seconds' all during the switch from the graphical boot progress screen to the actual X login and strangely only on first power up from cold! In fact I gave up with FC5 because I could not, at the time, find any way to get an ordinary text terminal progress during a mode 5 boot. Swapping an otherwise perfectly good graphics card has 'fixed' the problem but ...

What's going on here? Can someone point us at the configuration details? Is it possible to turn the graphics off? Cool it might be, but at best slow and possibly subtly unstable.

KClaisse
12th July 2007, 10:04 PM
I am now having this problem on my Fedora 7 installation.

The boot process (where it shows services being loaded and reports OK or FAILED) is now in text mode. But when that process finishes, it will load X11 and proceed to a login screen.

So it's just the boot process. It tries to start X11 after it starts udev. The screen goes black for a second, but then it comes back to the text boot.

If anyone has a solution to this I would really like to know.

Dan
13th July 2007, 12:03 AM
Hmmm. The only time that happens to me is if an item in the startup sequence fails.

erikd
13th July 2007, 12:26 AM
(I should've read the entire thread. This has already been discussed.) Whoops.

The rhgb (Red Hat Graphical Boot -- an implementation bootsplash.org's bootsplash) is what handles the graphical booting. As TangledWeb mentions, the old boot screen will show up on errors. You can attempt to go back to the rhgb screen with ALT-CTRL-F8. If this doesn't work during boot, then it may be that the rhgb process has failed. In that case, check the xorg logs (/var/log/Xorg.0.log), dmesg, /var/log/syslog and /var/log/messages for any errors that might have occurred.

Also, the rhgb is invoked via a kernel parameter from the boot loader -- usually GRUB. Check /boot/grub/grub.conf, find the kernel line for the active kernel and verify that rhgb is on the command line.

Look for entries like this:

title Fedora (2.6.21-1.3228.fc7)
root (hd0,2)
kernel /boot/vmlinuz-2.6.21-1.3228.fc7 ro root=LABEL=/1 rhgb quiet
initrd /boot/initrd-2.6.21-1.3228.fc7.img

noident
13th July 2007, 01:36 AM
I have the same issue (I prefer it this way actually, so it's not an issue for me).
The way I explain it is: I install kmod-nividia, and the nvidia kernel module gets loaded some time AFTER the time when the boot should have gone graphical. So what probably happens is that when the time to start the graphical boot comes, the video driver is not loaded yet, so starting X fails (quietly at this stage), and the system continues booting in text mode.
Like I said, I prefer to boot this way therefore I didn't investigate this any further.

KClaisse
14th July 2007, 10:58 AM
Hmmm. The only time that happens to me is if an item in the startup sequence fails.

Ah ha! It was my windows drive that failed to mount. I restart into windows and ran chkdsk, and now my rhgb works. Thanks.

Dan
14th July 2007, 02:18 PM
... You're very welcome!