PDA

View Full Version : nvidia driver will not load



arnott
13th March 2007, 04:55 PM
hi all,
3d acceleration stopped working after an update and a reboot. some files may have gotten corrupted because of improper shutdown.

during boot I get this message : "nvidia.ko for 2.6.19-1.2911.fc6" was not found and the driver will not be enabled.

kernel : 2.6.19-1.2911.fc6 #1 SMP Sat Feb 10 15:51:47 EST 2007 i686 athlon i386 GNU/Linux
nvidia driver installed is for 2.6.19-1.2911.6.5.fc6. are they both the same ? I tried to create a link to /lib/modules/2.6.19-1.2911.6.5.fc6/extra/nvidia/nvidia.ko in /lib/modules/2.6.19-1.2911.fc6/weak-updates/nvidia/
, which did not work.

CPU : AMD Athlon(64) XP 3200+ . do I have the wrong kernel installed ?
Graphics card : GeForce4 FX5200XT (Lancer)

how do I get the nvidia driver to work ? Everything (beryl, etc..) was working fine before.

thanks for the help.

cheers
Arnott

itsthescottdog
13th March 2007, 05:17 PM
Make sure you're booting into the most recent kernel, and if you are, do a 'yum update kmod-nvidia'

If you don't know how to check if you're booting into the most recent kernel,

cat /boot/grub/grub.conf

the default kernel should be set to the most recent kernel... keep in mind that the numbering system in grub starts at 0, not 1.

arnott
13th March 2007, 05:27 PM
thanks for ur reply, scottdog. According to grub.conf , am booting to 2.6.19-1.2911.fc6. is it the latest kernel ?

itsthescottdog
13th March 2007, 10:05 PM
Yes and no, there are two different versions of the kernel.

2.6.19-1.2911.6.5.fc6
and .....6.6. or something like that

my laptop battery is dying now. ill write more later

arnott
13th March 2007, 11:31 PM
the kernel am running right now is 2.6.19-1.2911.fc6 and it seems the nvidia driver I have is for 2..6.19-1.2911.6.5.fc6. I need to upgrade the kernel , when it is ready ?

lazlow
13th March 2007, 11:39 PM
The updated kernels will always be ready first. The kmod is built off of the kernel.