PDA

View Full Version : YUM not connecting



jeepfreak
13th March 2007, 03:45 PM
I installed a DVD burner and wanted to install burning software. I go to use yum and I get:

Unable to retrieve software information. This could be caused by not having a network connection available.

I am on the forum typing this message, so it isn't my network connection. I may have screwed up a repository, but I do not think so. 2 questions:

1. How do I reinstall yum?
2. How do I replace/check the repositiries that I am using with/against the default repositories?

Nipperspot
13th March 2007, 03:54 PM
Try running:

yum clean all

When yum experienced an error on my system, this is what I used to clean up yum where I could download updates and packages.

See: man yum

jeepfreak
13th March 2007, 03:57 PM
Try running:

yum clean all

When yum experienced an error on my system, this is what I used to clean up yum where I could download updates and packages.

See: man yum

That looks like it fixed it! Thanks! What repositories are the default for Fedora?

wait - spoke too soon:

root@localhost spartan]# yum list
Loading "installonlyn" plugin
Setting up repositories
macromedia [1/8]
macromedia 100% |=========================| 951 B 00:00
core [2/8]
ftp://ftp.tecnoera.com/pub/fedora/linux/core/5/i386/os/repodata/repomd.xml: [Err no 4] IOError: [Errno ftp error] timed out
Trying other mirror.
http://redhat.secsup.org/fedora/core/5/i386/os/repodata/repomd.xml: [Errno 12] T imeout: <urlopen error timed out>
Trying other mirror.
core 100% |=========================| 1.1 kB 00:00
updates [3/8]
updates 100% |=========================| 1.2 kB 00:00
greysector-all [4/8]
http://rpm.greysector.net/yum/all/i386/repodata/repomd.xml: [Errno 14] HTTP Error 404: Date: T ue, 13 Mar 2007 14:56:48 GMT
Server: Apache/2.0.55 (Unix)
Content-Length: 312
Content-Type: text/html; charset=iso-8859-1
Trying other mirror.
Cannot open/read repomd.xml file for repository: greysector-all
failure: repodata/repomd.xml from greysector-all: [Errno 256] No more mirrors to try.
Error: failure: repodata/repomd.xml from greysector-all: [Errno 256] No more mirrors to try.


So is greysector crapping out?

Nipperspot
13th March 2007, 04:04 PM
When I run yum extended (yum install yumex), the GUI for yum, and click on Repos, it shows core, extras, and updates selected. Since I haven't changed any repos, these are the default I presume.