PDA

View Full Version : Does suspend / hibernate work for you?



BandC
12th March 2007, 09:22 PM
My FC6 desktop is in my room and I keep it on most of the time. It'd be nice to be able to suspend or hibernate it at night. Suspend / hibernate never worked for me so I was wondering if it works for people and maybe if people would share their success stories.

klapa
12th March 2007, 09:48 PM
It does not work for me - as with all my machines (at least servers) the BIOS fails the 2000 cutoff date for DPMI - thus the "green" feature is not even instaled.

As a footnote - CPUSPEED did not work either for my initial install of FC6 - after yum update the CPUSPEED seems to have even disappeared from the startup scripts.

paul matthijsse
12th March 2007, 10:15 PM
suspend on desktop works, except that my machine freezes when I insert a dvd (don't do that very often), rather sure this is related to suspend. hibernate on desktop works as well, except that my wacom pen isn't recognized any more after restarting. A suspend & "unsuspend" fixes that again.

Laptop: both do not work. I noticed though that with Ubuntu, everyting worked out of the box, that is: closing the lid (screen) shot down the laptop; opening it up again awoke everything. Very nice feature, though I decided for other reasons to re-install Fedora, my regular distro.

s_bostjan
12th March 2007, 10:35 PM
It works on my laptop - configured by hand. Have some issues with sound after suspend (got to move volume slider to get sound again)

JonC
12th March 2007, 10:57 PM
sort of. But the mythTV backend doesn't like it much, so I tend to avoid it.

jspaar
13th March 2007, 11:34 PM
Laptop works, but only with custom tweaks to /etc/pm/hooks/ to handle madwifi. Still about 5% of the time it doesn't resume properly due to madwifi.

Hibernate on the desktop worked fine until I installed proprietary nvidia drivers. I found a fix at: nvnews.net (http://www.nvnews.net/vbulletin/showthread.php?t=70000). So desktop hibernate is working fine for me again.

tomcat
14th March 2007, 12:01 AM
Works on my desktops out of the box. No tweaking necessary. :)

Henry Rayker
3rd April 2007, 05:25 AM
Laptop, hibernation works without a hitch but suspend has all sorts of issues.

If I don't rmmod ipw2200 (my wireless) I get a kernel panic, if I do, I resume to a completely white screen...still trying to fix that situation.

newfc2user
3rd April 2007, 03:59 PM
Dell D400 laptop with i810 video (855GM card) and Intel 2100 wireless.
Both suspend and hibernate work. Only glitch is that sometimes, NetworkManager does not detect any network devices after resume (happens 1 in 10 times maybe). But a quick "service NetworkManager restart" fixes it.
Also my usb devices are not recognized after resume unless I boot with the kernel the irqpoll option. I have read that using irqpoll degrades performance but it doesn't seem to be noticeable.

iamscottevil
20th April 2007, 02:25 AM
it works but I have to use cntl alt f7 to get back into X server, is there a fix for that because I used to think it didn't work, but instead it's on some no-video mode screen and my monitors are power standby.

tw2113
20th April 2007, 05:34 AM
never bothered with Suspend yet, but hibernate works, but when I unhibernate it, the mouse and other aspects react slowly, causing me to just reboot, and eliminating the need to hibernate. Lately I've just been shutting all the way down.

Coolerthanyou
20th April 2007, 05:52 AM
We'll never get suspend always working in every PC for linux, or most of the time at least, until a software hack for it is added to the kernel by default. The stupid thing is that on some installs for me it has worked in the past, then after some updates or reinstall, not. But then maybe I didn't test it enough the first time. Sadly, I do use shutdown because it doesn't work at all on my current system. Well it works, but it resumes into a locked system with a blank screen.

Kaanx
20th April 2007, 11:56 AM
it didnt work on fedora, i didnt try it on my new installation thats the part i dont like in fedora, there are some things that doesnt work properly

mentatidaho
30th May 2008, 03:10 PM
I have a Toshiba Tecra M9 with nVidia Quadro N130. I installed Fedora FC9 but The suspend/hybernate had a problem: it does not wakeup the nVidia.
from livna repository I download kmod-nvidia and now the suspend (not hybernate) seems to works (but I lost the F1-F6 terminal... :confused:)