PDA

View Full Version : mplayer installed but not working?



akcrogan
11th March 2007, 11:37 AM
I have installed mplayer several times using the add/remove programs dialog, yumex, and from a terminal each time it installs perfectly without any errors. But once installed it simply will not start at all nothing happens? The firefox plugin doesnt work ethier. I have vlc and Xine installed and working but i want mplayer so i can use Devede and the firefox plugin.
Please help i'm pretty new to linux so if i'm missing something obvious please excuse my ignorance.

platomxv
11th March 2007, 11:56 AM
I have mplayer and mplayerplug-in working fairly well on my Thinkpad T30. There are some good threads here in this forum on mplayer. I suggest you do a search on - mplayer, multimedia, or mediaplayerconnectivity. You will find the search button in the toolbar at the top the first page. It takes a bit of work to make mplayer work but you are on the right track.
Norm

akcrogan
11th March 2007, 12:10 PM
thanks Norm
I've tried lots of searches (and i just tried again) but i can't seem to find a solution theres lots of people with conflicts with realplayer, etc but i can't get it to do anything at all. Getting frustrated

glennzo
11th March 2007, 12:11 PM
Download a small video. Save it to your home folder. Open a terminal and type mplayer /home/akcrogan/filename. If there are errors you will see the output in the terminal. Using that info can be very helpful in getting mplayer to work.

akcrogan
11th March 2007, 12:29 PM
Thanks glennzo just tried your suggestion i got this error
mplayer: symbol lookup error: /usr/lib/libavcodec.so.51: undefined symbol: faacDecOpen

glennzo
11th March 2007, 12:59 PM
Good. Now you know what the root of your mplayer problem is. I just googled 'mplayer: symbol lookup error: /usr/lib/libavcodec.so.51' and got a ton of hits. I did the same for the term 'undefined symbol: faacDecOpen'. If you do the same I'm confident that you can solve your problem.

Vasquez
11th March 2007, 01:19 PM
hey akcrogan, i get this error also, and this is because of a repo clash between freshrpms and livna. You should check that all packages that depend on each other are installed from either livna or freshrpms, and then make a fress install of mplayer.

ronin1982
11th March 2007, 01:26 PM
what repos did you use to install mplayer?......be sure not to use livna and freshrpms in the same time because you will end up with a mess.

glennzo
11th March 2007, 01:36 PM
Maybe some helpful info:

[glenn@dad ~]$ sudo yum provides libavcodec
Password:
Loading "installonlyn" plugin
Setting up repositories
Reading repository metadata in from local files
Excluding Packages from Livna for Fedora Core 6 - i386 - Base
Finished
Importing additional filelist information
filelists.xml.gz 100% |=========================| 86 kB 00:00
livna : ################################################## 385/385
filelists.xml.gz 100% |=========================| 3.4 MB 00:04
updates : ################################################## 1310/1310
filelists.xml.gz 100% |=========================| 3.1 MB 00:03
extras : ################################################## 4379/4379



ffmpeg-libs.i386 0.4.9-0.34.20070204.lv livna
Matched from:
/usr/lib/libavcodec.so.51.30.0
/usr/lib/libavcodec.so.51
libavcodec.so.51



ffmpeg-libs.i386 0.4.9-0.34.20070204.lv livna
Matched from:
/usr/lib/libavcodec.so.51.30.0
/usr/lib/libavcodec.so.51
libavcodec.so.51



ffmpeg-devel.i386 0.4.9-0.34.20070204.lv livna
Matched from:
/usr/lib/pkgconfig/libavcodec.pc
/usr/lib/libavcodec.so



ffmpeg-devel.i386 0.4.9-0.34.20070204.lv livna
Matched from:
/usr/lib/pkgconfig/libavcodec.pc
/usr/lib/libavcodec.so



ffmpeg-libs.i386 0.4.9-0.34.20070204.lv installed
Matched from:
/usr/lib/libavcodec.so.51
/usr/lib/libavcodec.so.51.30.0
libavcodec.so.51
[glenn@dad ~]$

[glenn@dad ~]$ rpm -q ffmpeg
ffmpeg-0.4.9-0.34.20070204.lvn6
[glenn@dad ~]$

Do you have everything you need installed?

sdowney717
11th March 2007, 01:39 PM
http://www.mjmwired.net/resources/mplayer-fedora.html

you can always compile from source and probably solve your particular situation.

./configure --enable-gui --enable-largefiles \--enable-menu --prefix=/usr --confdir=/etc/mplayer
make
make install

I did this and during the configure, it will tell you if you are missing something, then go ahead and use add remove software or yum to fix that.
Once you get a successful configure, you do the make and that runs forever. You may see some errors, I did, but it still works.

Then you will need a default skin, put it in the directory it complains about when run from a terminal wndow. The skin you download should be extracted and put into that directory.
I chose Blue skin for the default.

it will also complain about a font.
I got New face failed for the font error,
I just told it to use a certain font, right click configure, but it still complains a little, something about a bitmap font. you will see those messages running mplayer in the terminal window.

I also had to tell it to use ffmpeg audio and video codecs. And tell it to use Alsa and x11 video.

The only reason I compiled from source is I am running FC7 test2 and there are no precompiled mplayers out ther yet. I can use the mplayer plugin for fc6 just fine.

AlexDudko
11th March 2007, 01:52 PM
I've installed mplayer from source codes and it started working at once. But when I installed mozilla mplayerplug-in it crushed completely. Reinstalled - have mplayer and no mplayerplug-in in my web browser.

AlexDudko
11th March 2007, 02:05 PM
it will also complain about a font.


It's not a problem Just choose in propeties some from /usr/share/fonts