PDA

View Full Version : yum update issue



obviousheart221
11th March 2007, 04:08 AM
Guys,

I've been trying to update using yum update, and I'm getting this strange error after all the downloads:
Transaction Check Error: file /usr/lib/libmpeg2.so.0.0.0 from install of mpeg2dec-0.4.1-2.lvn6 conflicts with file from package libmpeg2_0-0.4.0b-2.fc6.at
file /usr/lib/libmpeg2convert.so.0.0.0 from install of mpeg2dec-0.4.1-2.lvn6 conflicts with file from package libmpeg2convert0-0.4.0b-2.fc6.at

This is the first update I've tried running since I upgraded from FC5 to FC6. Any ideas? I used this command:
yum --disablerepo=dries --disablerepo=atrpms update

Thanks,
Jeff

lazlow
11th March 2007, 04:21 AM
You are mixing repos. Mixing atrpms with any other repo (including core and extras) will lead you into repo hell. Atrpms will replace core components of your system with ones that are incompatiable with any other repo. Many of use have had to wipe our drives due to atrpms. The "standard" repo (other than core and extras) is livna.

You have or are using atrpms becuase thats where that ".at" at the end of those files is coming from.

Lazlow