PDA

View Full Version : Need help with mondo/mindi



bseltzer
11th March 2007, 12:49 AM
I'm running FC6 on a pretty much plan Jane XPS 410, and now that I've got this single disk system just about where I want it, I'd VERY much like to be able to back it up so as to be able to do disaster recovery if necessay. In the distant past, I'd used mondo for such purposes on RedHat 8 and even 9 systems with success, but...

On this box, (fc5, 2.6.19-1.2911.6.5.fc6 kerenl) mindi is completely unable to create a bootable CD. It creates and ISO image just fine, and I can burn it to a CD just fine, BUT if I try to boot from the resulting disk, everything goes as expected until it tried to mount root. At that point I get the following;

EXT2_fs: block size too small for device
grow_buffers: requested out of range block (some huge number) for device ram0
isofs_fill_super bread failed dev=ram0
no file system could mount root, tried ext2, iso9660
kernel panic not syncing
VFS unable to mount root fs on unknown block

I get exactly the same result whether I tell mindi to use my kernel or its own "FAILSAFE" kernel. Just for grins, I did a test run of mondoarchive, and (no surprise) the initial DVD of the set it produced failed to boot with the same errors.

So is there some fix for this or am I stuck with a steaming pile of <whatever> and about half a dozen coasters that used to be CD/DVD's? As a follow on question, is there some other backup/disaster recovery tool that DOES work?

Thanks,
Bert

bseltzer
11th March 2007, 08:59 PM
Well, despite the deluge of suggestions...... :D

I did a bit of poking around and discovered the problem and its cure on my own. Seems when building the initrd.img, mindi was using the system default block size (4096) whether using my kernel or its own. Turns out this is bad ju-ju for bootable CD/DVD's.

The solution was to type "ramdisk_blocksize=1024" at the boot prompt. After that things went swimmingly. Backed up the whole system onto 4 DVD's without a hitch, then booted from the first disk in the set, and successfully restored a large chunk of data from /opt/d50/mar07 to my home directory. Course that resulted in a rather long path, ~<me>/opt/d50/mar07, but all the data was there, and my RAW editor couldn't tell the difference between it and the original.

So it anyone's looking for a B/U utility for FC6 that's free and capable of a bare metal restoration, you might want to try mondo. Just be forewarned, it is sloooowww...

Regards,
Bert

GL1800
12th March 2007, 11:09 AM
Also, note that mindi is a script. In there, you will find a number of params being passed to the kernel at boot time. Easy to add the block size there, and Voila!

bseltzer
13th March 2007, 08:16 PM
Also, note that mindi is a script. In there, you will find a number of params being passed to the kernel at boot time. Easy to add the block size there, and Voila!

That's exactly where I went next after discovering the need to specifiy "ramdisk_blocksize". Additionally, I did a bit of script hacking to prevent the needless loading and use of serveral uneeded kernel modules like "nvidia", "ipec_cisco" (for VPN), and parallel port support. That turned out to be a bit more challenging, but do-able none the less.

Thanks,
Bert

Starmonkey
15th April 2007, 01:16 PM
I have the same set up, and ran into the same problem creating the boot CDs. I created the ISOs separatly, and burned on a different machine.
On the restore, I had the same problem with the blocksize, so used the "ramdisk_blocksize=1024" optoin.
I'm still having problems. Mondo seems to be unable to create LVM2 partitions, and I'm nopt sure if it is restoring the bootloader (GRUB).
I'd love to know how you (or anyone else) got through this.