PDA

View Full Version : mouse wheel doesnt work.



l i t d i e
10th March 2007, 10:45 PM
hi all.

lemme explain the problem. im running a dell 9300 laptop. i have synaptics touchpad that works, and a usb cheapy mouse that works.

i also have an intellimouse explorer for bluetooth.

i have it working and connection to my laptop on restart, but for some reason my mouse wheel wont scroll.

ive searched these forums and google and nothing has helped me at all. i was wondering if anyone else has this mouse working if they could maybe help or post their xorg.conf file so i can see what im doing wrong.

heres my xorg.conf


# Xorg configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "CorePointer"
EndSection

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Synaptics"
Driver "synaptics"
Option "Device" "/dev/input/mice"
Option "Protocol" "auto-dev"
Option "Emulate3Buttons" "yes"
Option "LeftEdge" "120"
Option "RightEdge" "830"
Option "TopEdge" "120"
Option "BottomEdge" "650"
Option "FingerLow" "14"
Option "FingerHigh" "15"
Option "MaxTapMove" "110"
Option "VertScrollDelta" "20"
Option "HorizScrollDelta" "20"
Option "MinSpeed" "0.3"
Option "MaxSpeed" "0.75"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection


i found this on another forum saying add this to my xorg.conf but when i did and restarted it still didnt help. this was a confirmed setup for the same mouse i have but on ubuntu.

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "Buttons" "7"
Option "ZAxisMapping" "6 7"
EndSection

any help or insight is greatly appreciated. ty =-)

Dies
10th March 2007, 11:53 PM
Option "Protocol" "IMPS/2"
Option "ZAxisMapping" "4 5 6 7"

Try those lines, if not you may have to resort to something like:

http://imwheel.sourceforge.net/