PDA

View Full Version : MPlayer in Opera!!!!!!!!



New Fedora User
10th March 2007, 04:07 AM
I am definitely happier with Opera than Firefox as a browser. It is a lot faster and a lot nicer.

I just recently figured out how to remove Totem from Firefox and install MPlayer in it's place so I can watch online video. Opera doesn't have a plugin in it to watch video.

I did a search on this already and I see that you can install MPlayer in Opera as well. I just don't understand the directions. I've had Fedora a few months now and I'm still learning; I just don't have all the understanding of it yet. I've never tried any other versions of Linux, and I don't want to. If somebody can tell me how to install MPlayer into Opera so I can understand it, I would appreciate it.

Seve
10th March 2007, 04:13 AM
Hello:
You will never learn younger :)
http://www.opera.com/linux/docs/plugins/install/#mplayer

Locate the files mplayerplug-in*.{so,xpt} and copy them to /usr/lib/opera/plugins or /usr/lib/browser-plugins or /usr/lib/netscape/plugins or /usr/lib/mozilla/plugins, depending on your distribution.
Type ln -s /usr/lib/mozilla/libxpcom.so /usr/lib

Seve

New Fedora User
10th March 2007, 04:46 AM
I'm just not getting anything to work. MPlayer is made for Mozilla. Is there anything made specifically for Opera maybe???

Seve
10th March 2007, 05:02 AM
I'm just not getting anything to work. MPlayer is made for Mozilla.
Hello:
Where did you get that information ? You have allowed some confusion and mis-information to set in.
I posted the link with a summation of what you had to do for a reason ......... What reason you ask ?
Well .... because it works :)

Is there anything made specifically for Opera maybe???
Mplayer-plugin is ....... I suppose perhaps that's why it's included in Opera's how-to and FAQ section. :)

Start at the basics again :
See http://www.fedorafaq.org/#browsermovies
Once you have your yum configured correctly with and including the livna repo. [all of which is in the instructions] Then install the mplayer-plugin it will invaluable when you want to use it in say Opera :)
Just carefully follow the instructions in the FAQ noted above and you will be fine.
When you are done installing it as well as the codecs then open a terminal and log in as root using
su -
yourpassword
and type
updatedb
then open up the Opera how-to again for reference and
in the still open terminal type
locate libxpcom.so
then follow the instructions provided by Opera on the link in the previous post.

Seve

New Fedora User
10th March 2007, 08:21 AM
Here is where I am getting my information: http://mplayerplug-in.sourceforge.net/download.php
I'll take your word for it that it works, being as how I am only a rookie at using Linux.

Nonetheless, I still am not getting video on Opera. I have long since installed MPlayer, which is why I am getting video in Firefox. It now seems as if Opera is picking up the presence of the plug-in but is still not playing it.

So, in the very strong interest of learning what I clearly do not already know, what am I doing wrong????

Jongi
10th March 2007, 10:47 PM
Using FC6 x86_64



[root:~#] ls -la /usr/lib/opera/plugins/
total 1805
drwxr-xr-x 2 root root 776 Mar 10 23:15 .
drwxr-xr-x 4 root root 104 Mar 10 21:12 ..
lrwxrwxrwx 1 root root 39 Mar 10 21:12 libflashplayer.so -> /usr/lib/flash-plugin/libflashplayer.so
-rwxr-xr-x 1 root root 27800 Mar 10 23:02 libgcjwebplugin.so
-rwxr-xr-x 1 root root 137085 Mar 10 23:32 libjavaplugin_oji.so
-rw-r--r-- 1 root root 92448 Dec 14 15:17 libnpp.so
-rwxr-xr-x 1 root root 264188 Mar 10 23:32 mplayerplug-in-dvx.so
-rwxr-xr-x 1 root root 981 Mar 10 23:32 mplayerplug-in-dvx.xpt
-rwxr-xr-x 1 root root 264412 Mar 10 23:32 mplayerplug-in-qt.so
-rwxr-xr-x 1 root root 981 Mar 10 23:32 mplayerplug-in-qt.xpt
-rwxr-xr-x 1 root root 264444 Mar 10 23:32 mplayerplug-in-rm.so
-rwxr-xr-x 1 root root 981 Mar 10 23:32 mplayerplug-in-rm.xpt
-rwxr-xr-x 1 root root 265720 Mar 10 23:32 mplayerplug-in.so
-rwxr-xr-x 1 root root 264700 Mar 10 23:32 mplayerplug-in-wmp.so
-rwxr-xr-x 1 root root 981 Mar 10 23:32 mplayerplug-in-wmp.xpt
-rwxr-xr-x 1 root root 981 Mar 10 23:32 mplayerplug-in.xpt
-rwxr-xr-x 1 root root 57580 Mar 10 23:32 nphelix.so
-rwxr-xr-x 1 root root 5086 Mar 10 23:32 nphelix.xpt
-rwxr-xr-x 1 root root 65600 Mar 10 23:15 npwrapper.so
-rwxr-xr-x 1 root root 7008 Dec 14 15:17 operaplugincleaner
-rwxr-xr-x 1 root root 85496 Dec 14 15:17 operapluginwrapper


When I go to the apple trailers site for instance. All I get is a grey box where the video shoudl be playing. I downloaded the rpm for FC6 from the opera site. Looking at this site (http://www.opera.com/linux/docs/plugins/install/), it talks about a gecko sdk.



[root:~#] yum list *gecko* | grep installed
gecko-sharp2.x86_64 0.11-12 installed
gecko-sharp2-devel.i386 0.11-12 installed
gecko-sharp2-devel.x86_64 0.11-12 installed

No repos seems to have this gecko-sdk file. I do have firefox-devel for FF2 from the remi repo which provides a gecko-devel.

EDIT: I was using FF previously so all the mplayer plugins were installed prior to installing Opera v9.10 Build 521.



[root:~#] yum list *mplayer* | grep installed
kmplayer.x86_64 0.9.3a-1.fc6 installed
mplayer.x86_64 1.0-0.69.rc1.lvn6 installed
mplayer-fonts.noarch 1.1-4.lvn6 installed
mplayer-gui.x86_64 1.0-0.69.rc1.lvn6 installed
mplayer-skins.noarch 1.8-1 installed
mplayerplug-in.i386 3.31-2.fc6 installed
mplayerplug-in.x86_64 3.35-1.lvn6 installed
vdr-mplayer.x86_64 0.9.15-5.lvn6 installed


EDIT 2:
I see that the opera is a 32-bit version one. I will try install the 32-bit mplayer plugins



opera.i386 2:9.10-20061214.6 installed

New Fedora User
11th March 2007, 02:49 AM
Any luck with that???? Let me know what happens.

Jongi
13th March 2007, 11:46 PM
Can other Opera users try:

www.football365.com (try playing the video in the box on the left)
http://www.apple.com/trailers/fox/thesimpsonsmovie/trailer1_small.html

If it works for you please post:
# yum list mplayer* | grep installed
# ls -la /usr/lib/opera/plugins/

Stian1979
14th March 2007, 08:55 AM
I also try to find this gecko sdk file.

If you have progres or annyone know please let me know.

Jongi
15th March 2007, 09:53 PM
This is beginning to frustrate me to no ends. I even brought back my i686 install from the dead. Same issues.

Stian1979
30th August 2007, 04:37 PM
I have now folowed every step on the opera page to get the plugins working and only helix, flash and Java works. :mad:

nilssn
30th August 2007, 05:21 PM
There's a lot of problems using the mplayer plug-in in Opera. I'm using Gecko Media Player (http://dekorte.homeip.net/download/gecko-mediaplayer). It works better.