PDA

View Full Version : X_CreateColormap problem



ivlad
9th March 2007, 10:06 PM
I run an up to date FC6 box with KDE. Yum update daily. Until yesterday, when trying to run either wine or tuxtype2, I would get something like

X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 78 (X_CreateColormap)
Value in failed request: 0x0
Serial number of failed request: 25
Current serial number in output stream: 26

Today my yum downloaded some new version of xorg xserver, I do not recall exactly the name, but it is the only xorg package made available in the last 24h. Tuxtype2 gives the same error, but typing winecfg restarted my whole x server! Ironically, I was trying to get the exact error to post on this forum :-)

Searching for X_CreateColormap on this forum shows this question is more than a year old: http://forums.fedoraforum.org/showthread.php?t=103588&highlight=X_CreateColormap .

My hardware config is here (http://smolt.fedoraproject.org/show?UUID=f8ea0211-9ba7-439e-a1dc-3cc871456f6e). Software config here (http://ivlad.info/c/fedora/fc6install.html). My /etc/X11/xorg.conf is here (http://ivlad.info/c/fedora/xorg.conf) .

Anybody has any idea of what is going on?

Thank you in advance,
Nick