PDA

View Full Version : Error installing K9Copy



TeachMeLinux
9th March 2007, 05:45 PM
Hi
Was tyring to install K9Copy, and for some unknown reason I am getting a error mesage.

I am running the following commands:

wget http://www.fedoraserver.org/files/k9/K9copy-1.0.4_LP-2-1.i386.rpm
yum -y --enablerepo=freshrpms install libdvdread libdvdread-devel
rpm -ivh K9copy-1.0.4_LP-2-1.i386.rpm

The first wget command runs with no problems.
However, when I run the secon line (yum -y .....) then I get the following error message:

Error getting repository data for freshrpms, repository not found

What is wrong ? Any Advice ?
Does any one have any other software that they use to make copy's of their DVD's which works better than K9 ?

Thanks in Advance for the help

hiberphoptik
9th March 2007, 06:21 PM
sounds like you simply dont have a freshrpms.repo file in /etc/yum.repos.d/

TeachMeLinux
9th March 2007, 06:38 PM
okay -= so how do I get the freshrpms.repo file ?

Seve
9th March 2007, 06:54 PM
okay -= so how do I get the freshrpms.repo file ?
Hello;
Go here and click and follow the instructions: [click here]
Just make sure to disable the repo if you are also using livna
http://freshrpms.net/

Seve

TeachMeLinux
9th March 2007, 07:17 PM
Okay Thanks. Go the latest freshrpms and it works.
Now, when I am trying to run the last command of the script, (rpm -ivh K9copy-1.0.4_LP-2-1.i386.rpm) I am getting this error message;

error: Failed dependencies:
libDCOP.so.4 is needed by K9copy-1.0.4_LP-2-1.i386
libkdecore.so.4 is needed by K9copy-1.0.4_LP-2-1.i386
libkdefx.so.4 is needed by K9copy-1.0.4_LP-2-1.i386
libkdesu.so.4 is needed by K9copy-1.0.4_LP-2-1.i386
libkdeui.so.4 is needed by K9copy-1.0.4_LP-2-1.i386
libkio.so.4 is needed by K9copy-1.0.4_LP-2-1.i386
libkparts.so.2 is needed by K9copy-1.0.4_LP-2-1.i386
libkwalletclient.so.1 is needed by K9copy-1.0.4_LP-2-1.i386

Any ideas ?

Seve
9th March 2007, 07:38 PM
Okay Thanks. Go the latest freshrpms and it works.
Now, when I am trying to run the last command of the script, (rpm -ivh K9copy-1.0.4_LP-2-1.i386.rpm) I am getting this error message;

error: Failed dependencies:
libDCOP.so.4 is needed by K9copy-1.0.4_LP-2-1.i386
libkdecore.so.4 is needed by K9copy-1.0.4_LP-2-1.i386
libkdefx.so.4 is needed by K9copy-1.0.4_LP-2-1.i386
libkdesu.so.4 is needed by K9copy-1.0.4_LP-2-1.i386
libkdeui.so.4 is needed by K9copy-1.0.4_LP-2-1.i386
libkio.so.4 is needed by K9copy-1.0.4_LP-2-1.i386
libkparts.so.2 is needed by K9copy-1.0.4_LP-2-1.i386
libkwalletclient.so.1 is needed by K9copy-1.0.4_LP-2-1.i386

Any ideas ?
Hello:
When you see something like the above, open a terminal and log in as root and type
yum whatprovides libkwalletclient.so.1
and yum will come back with the rpm package that provides the missing files. [if available from your repo packages]
Then simply use yum to install the package

Seve