PDA

View Full Version : DVD and VCD disappears



Rezwan Mahbub
8th March 2007, 09:27 PM
Sir this time I have searched through google and this site forums but couldnt help me out. My DVD drive disappears whenever I instert a DVD video or Data DVD and reappears when I eject it. I am using Liteon DVD Rom. I cant even mount the DVD i used to install this linux. Please help me out.

Thetargos
8th March 2007, 09:41 PM
From what you say, it happens with all disks you pop into it, do you have a dual boot environment? Have you tried to inster a regular CD rom into it?

The most probable cause of this is either hardware failure or media failure (but in your case, the media seems to be OK), before panicking on hardware failure, I'd try to see if the problem is power realted (the molex connector is lose or it may even be your power supply), other parts are failing? (3D card, HDDs, etc?)

Rezwan Mahbub
8th March 2007, 09:49 PM
From what you say, it happens with all disks you pop into it, do you have a dual boot environment? Have you tried to inster a regular CD rom into it?

The most probable cause of this is either hardware failure or media failure (but in your case, the media seems to be OK), before panicking on hardware failure, I'd try to see if the problem is power realted (the molex connector is lose or it may even be your power supply), other parts are failing? (3D card, HDDs, etc?)


It does not play any data cd but if i instert an audio cd it shows it. I can use the drive well in windows xp. and as i said i used it to install fedora so it must not be a hardware problem.

Thetargos
8th March 2007, 09:55 PM
In such a case, what kernel are you running, have you recently installed any updates? Seems like hald problem (a hardware change monitoring tool). Have you tried to reboot the machine?

To find out about the currently running kernel type into a console.


uname -r

Rezwan Mahbub
8th March 2007, 10:05 PM
In such a case, what kernel are you running, have you recently installed any updates? Seems like hald problem (a hardware change monitoring tool). Have you tried to reboot the machine?

To find out about the currently running kernel type into a console.


uname -r


it like this:
u[root@localhost ~]# uname -r
2.6.18-1.2798.fc6xen

Thetargos
8th March 2007, 10:15 PM
Why are you running a Xen kernel? Are you running any virtualization environments?

Rezwan Mahbub
8th March 2007, 10:23 PM
I havent got U i m a new user. I am using fedora 6 with GNOME.

Thetargos
8th March 2007, 11:05 PM
I havent got U i m a new user. I am using fedora 6 with GNOME.
You are running a Xen kernel, which means you configured (at some point) a virtualization environment, maybe at install, maybe later. Also you are running an outdated kernel, and you need to update it, but first you have to run the standard kernel, could please check if you have system-config-boot installed? (within pirut [add/remove software] hit search and type that), if you don't, please install it. Then run it and tell me what does it show.

Brian1
8th March 2007, 11:15 PM
One thing maybe is the link you see for the drive changes when a disc is inserted which could mean the /etc/fstab is changing before and after an insertion. To check use the command ' cat /etc/fstab ' and then insert a disc, wait 30 seconds and run the ' cat /etc/fstab ' again. See if the line for the dvd drive changes.

Brian

Thetargos
8th March 2007, 11:18 PM
One thing maybe is the link you see for the drive changes when a disc is inserted which could mean the /etc/fstab is changing before and after an insertion. To check use the command ' cat /etc/fstab ' and then insert a disc, wait 30 seconds and run the ' cat /etc/fstab ' again. See if the line for the dvd drive changes.

Brian
But that can't be the case in FC5 & 6 as fstab mounting of optical media is no longer done via fstab-update (or whatever it name was), but rather by gnome-mount

Brian1
8th March 2007, 11:53 PM
Did know it changed. Never like the media mount point scheme using the managed option.

Brian

Rezwan Mahbub
9th March 2007, 12:31 PM
You are running a Xen kernel, which means you configured (at some point) a virtualization environment, maybe at install, maybe later. Also you are running an outdated kernel, and you need to update it, but first you have to run the standard kernel, could please check if you have system-config-boot installed? (within pirut [add/remove software] hit search and type that), if you don't, please install it. Then run it and tell me what does it show.

Boss this has solved my problem at last. Yes yes yes !!! Thanks a lot as my problems are getting solved I m loving Linux more and more. But my Boot screen in Grub2 is showing 2 fedora fedora..xn plays DVD. can I remove the other from the list.

Thetargos
10th March 2007, 01:30 AM
Yes, you can remove unused entries from GRUB, and that should be done automatically when you uninstall a previous kernel, just make sure none of the kernels you have listed there have a "xen" in there, as these are special kernels not intended for everyday use, but for special cases. Run the ones that don't have "xen" (like those marked Fedora Core (2.6.19-1.2911.6.5.fc6) and the like)

Rezwan Mahbub
10th March 2007, 05:06 PM
You are running a Xen kernel, which means you configured (at some point) a virtualization environment, maybe at install, maybe later. Also you are running an outdated kernel, and you need to update it, but first you have to run the standard kernel, could please check if you have system-config-boot installed? (within pirut [add/remove software] hit search and type that), if you don't, please install it. Then run it and tell me what does it show.


Hey My Dvd runs whichever way in fedora I go. What can I do to exclude the unwanted... Please help

Thetargos
10th March 2007, 05:22 PM
In your screenshot, the one selected as the default (top) is the kernel which will boot the next time you enter to Linux. If you want to remove the other line, you can:


Uninstall that kernel
Edit the grub.conf file to manually remove that line

The best way would be to remove the kernel, but that may drag some unwanted dependencies, so maybe for you, it would be best to edit the file /etc/grub.conf (as root) and remove all from the Title Fedora Core (2.6.18-1.2798.fc6xen to the next Title (Windows) leaving Windows in place, and just removing that other boot entry.