PDA

View Full Version : Error in yum



R-X
25th February 2007, 05:54 AM
hi

I need install program by yum but

look


[root@localhost ~]# yum install xine
Setting up Install Process
Setting up repositories
core 100% |=========================| 1.1 kB 00:00
dries 100% |=========================| 951 B 00:00
freshrpms 100% |=========================| 951 B 00:00
rpmforge 100% |=========================| 951 B 00:00
extras 100% |=========================| 1.1 kB 00:00
newrpms.sunsite.dk 100% |=========================| 951 B 00:00
updates 100% |=========================| 951 B 00:00
http://ftp.tugraz.at/mirror/redhat-linux/fedora/linux/core/updates/4/i386/repodata/repomd.xml: [Errno 4] IOError: HTTP Error 404: Date: Sun, 25 Feb 2007 04:47:46 GMT
Content-Length: 359
Content-Type: text/html; charset=iso-8859-1
Server: Apache/2.0.54 (Debian GNU/Linux)
Via: 1.1 Netcache2 (NetCache NetApp/6.0.3)
Trying other mirror.
updates-released 100% |=========================| 951 B 00:00
base 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package xine.i386 0:0.99.4-8.fc4.rf set to be updated
--> Running transaction check
--> Processing Dependency: libaa.so.1 for package: xine
--> Processing Dependency: liblirc_client.so.0 for package: xine
--> Processing Dependency: xine-lib >= 1.1.2 for package: xine
--> Processing Dependency: libxine.so.1 for package: xine
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package lirc.i386 0:0.7.2-1.1.fc4 set to be updated
---> Package xine-lib.i386 0:1.1.2-2.fc4.rf set to be updated
---> Package aalib.i386 0:1.4.0-5.fc4.rf set to be updated
--> Running transaction check
--> Processing Dependency: libportaudio.so for package: lirc
--> Processing Dependency: libmodplug.so.0 for package: xine-lib
--> Processing Dependency: libvcdinfo.so.0(VCDINFO_0) for package: xine-lib
--> Processing Dependency: libcdio.so.6(CDIO_6) for package: xine-lib
--> Processing Dependency: libiso9660.so.4 for package: xine-lib
--> Processing Dependency: libfame-0.9.so.1 for package: xine-lib
--> Processing Dependency: libXvMCW.so.1 for package: xine-lib
--> Processing Dependency: libvcdinfo.so.0 for package: xine-lib
--> Processing Dependency: libdvdcss for package: xine-lib
--> Processing Dependency: libmad.so.0 for package: xine-lib
--> Processing Dependency: libcdio.so.6 for package: xine-lib
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libdvdcss.i386 0:1.2.9-2.fc4.rf set to be updated
---> Package libmad.i386 0:0.15.1b-4.fc4.rf set to be updated
---> Package libXvMCW.i386 0:0.9.3-1.2.fc4.rf set to be updated
---> Package libcdio.i386 0:0.76-1.fc4 set to be updated
---> Package portaudio.i386 0:18.1-5 set to be updated
---> Package vcdimager.i386 0:0.7.23-5.fc4.rf set to be updated
---> Package libmodplug.i386 1:0.7-4.fc4 set to be updated
---> Package libfame.i386 0:0.9.1-12.fc4.rf set to be updated
--> Running transaction check
--> Processing Dependency: libcdio.so.7(CDIO_7) for package: vcdimager
--> Processing Dependency: libcdio.so.7 for package: vcdimager
--> Processing Dependency: libiso9660.so.5 for package: vcdimager
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libcdio.i386 0:0.77-1.fc4.rf set to be updated
--> Running transaction check
--> Processing Dependency: libcdio.so.6(CDIO_6) for package: xine-lib
--> Processing Dependency: libiso9660.so.4 for package: xine-lib
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.6) for package: libcdio
--> Processing Dependency: libcdio.so.6 for package: xine-lib
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libstdc++.i386 0:4.0.2-8.fc4 set to be updated
---> Package libcdio.i386 0:0.76-1.fc4 set to be updated
--> Running transaction check
--> Processing Dependency: libcdio.so.6(CDIO_6) for package: xine-lib
--> Processing Dependency: libiso9660.so.4 for package: xine-lib
--> Processing Dependency: libcdio.so.6 for package: xine-lib
--> Finished Dependency Resolution
Error: Missing Dependency: libcdio.so.6(CDIO_6) is needed by package xine-lib
Error: Missing Dependency: libiso9660.so.4 is needed by package xine-lib
Error: Missing Dependency: libcdio.so.6 is needed by package xine-lib
[root@localhost ~]#

in fc4

bob
25th February 2007, 12:32 PM
Well, you can use the --exclude=xine-lib option from 'man yum' but you must realize that official support for FC4 and previous versions has ended so you're likely to encounter this again and again. Any chance of upgrading?

kuifje00
25th February 2007, 02:55 PM
If you can do it by hand, then look here:
http://rpm.pbone.net/ search for fc4 and cdio
Fedora 4 dries.studentenweb.org/apt/fedora/fc4/i386/RPMS.dries/libcdio-0.77-1.fc4.rf.i386.rpm

success.