PDA

View Full Version : Unable to access home box, from specific IP range.



InfRecursion
14th February 2007, 03:13 PM
I have a box running Fedora Core 6 with Apache and SSH. I can connect fine when I'm local to the network (on the one 192.* range). Others can connect as well, from the outside of the network. Except me coming in from a specific range XYZ.N.N.N

At one point I referenced an image on this box on a remote site, and I was able to see it on the remote site when viewing that site from the local network, but when I'm viewing the remote site outside of the local network, the reference to the image on my Apache box returns an error image.

The browser cache is clear, firewall allows SSH and HTTPD, SELinux is disabled, and /etc/hosts.deny is currently empty, plus no entries into iptables/ipchains have been created.

/var/log/messages and /var/log/secure don't seem to return anything of value. /var/log/httpd/access_log appears to be listing other hits from outside the network.


Are there other places to look to see if the connection is being blocked?

sideways
14th February 2007, 04:25 PM
Is it being blocked at the router?

You may need to forward port 80 (HTTP) to your server's internal ip
(Port forwarding is usually an option in the router's admin console)

InfRecursion
14th February 2007, 08:07 PM
Thanks sideways...

It was blocked at the router, port forwarding enabled me to view my site from the IP range in question. Still not sure why it was being selective.

The last time I ran Apache on a box, I just enabled IP passthrough and pointed it ot that server's IP... never had to do a port forward... I guess that's what threw me off.

Thanks again.