PDA

View Full Version : Fuse 2.6.3



Error918
14th February 2007, 12:52 AM
Hey, well ok, I've had ntfs-3g running for a while, and now I'm sick of the error I continuously get."WARNING: Old FUSE kernel module detected."

A quick look at the ntfs-3g FAQs showed me that I needed the new FUSE. So, I go ahead and get fuse 2.6.3, I attempt to do a ./configure --enable-kernel-module.

Only to get the oh-so-popular...

=== configuring in kernel (/home/Paras/fuse-2.6.3/kernel)
configure: running /bin/sh ./configure '--prefix=/usr/local' '--enable-kernel-module' --cache-file=/dev/null --srcdir=.
checking for a BSD-compatible install... /usr/bin/install -c
checking kernel source directory... Not found
configure: error:
*** Please specify the location of the kernel source with
*** the '--with-kernel=SRCDIR' option
configure: error: ./configure failed for kernel


Yes, I know people have asked about this, but I do not know what to do. I myself know nothing about how a kernel works, can someone help?

Brian1
14th February 2007, 01:30 AM
The problem you are having is the kernel source is not installed on the machine. Run the following commands and post output.
uname -r
rpm -qa | grep kernel

Now if you are still running the orginal installed kerenl then from the cd there is an rpm kernel-devel-******.rpm where ****** is the same as the numbers from the uname command.
If you have updated then go where you have gotten the current running kernel and get the matching version of kernel-devel-*******.rpm and install that.

You can also goto http://rpm.pbone.net and get the 2.6.3 fuse if it matches your current running kernel version.

Fuse is compiled to run on a specific kernel. If you update the kernel you need to recompile fuse to work under the new kernel.

Brian

Error918
14th February 2007, 11:27 PM
EDIT: And ironically a new kernel update was available.

[Paras@localhost ~]$ uname -r
2.6.19-1.2911.fc6
[Paras@localhost ~]$ rpm -qa | grep kernel
kernel-2.6.19-1.2911.fc6
kernel-2.6.19-1.2895.fc6
kernel-headers-2.6.19-1.2911.fc6

So just download the devel? I'm using the kernel i got on my install.

EDIT#2: Nice, I downloaded the devel, attempted to configure, and it worked! thanks =) I mounted my NTFS to get the same error though. I haven't restarted. Will it work on reboot?

Brian1
15th February 2007, 01:05 AM
I would not think a reboot would be required if using the new kernel?
So which kernel-devel did you get?

Brian

feniks
20th February 2007, 08:42 PM
I would not think a reboot would be required if using the new kernel?
So which kernel-devel did you get?

Brian

I guess that Error918 did:

yum install kernel-devel
:)

That's what I did and it worked for me well. Had the same problem with FUSE and mounting NTFS drive with windows XP partition under FC6.

EDIT:
The FUSE compilation doesn't work still. I downloaded FUSE 2.6.3 package (tar.gz) and "untarred" it. Since with kernel source for current kernel-2.6.19-1.2911.fc6 and gcc I was able to do:

./configure --enable-kernel-module
I could not succesfully perform "make" and "make install". received in the end something like "nothing to be done"...

In deed the install didn't work right because when using
mount /dev/sda1 /mnt/windows -t ntfs I still receive the same error (old FUSE module), so something went wrong with new FUSE package installation.

could someone explain me this once over? I do not know what I am doing wrong... and I urgently need read/write access to my ntfs partition from Linux FC6. help please. Thank you!

joe.pelayo
20th February 2007, 09:17 PM
Hello feniks.

Unless you see the "error" word somewhere in the output you can not assume you have got an error during your compilation. By the way when I installed the latest fuse I only used the instruction ./configure (not enabling kernel). A reboot sufficed for changes to be applied (don't know if really necessary, just used to Windows).
(your mount command uses the option ntfs-3g instead of ntfs)

Joe.

feniks
20th February 2007, 09:26 PM
Thanks for a reply. just figured out my own way :)
Sorry for the "error" I ment "Warning". The problem was that new FUSE apckage was not loading, because I forgot to remove the old one

rmmod fuse
before installation. Just removed it, and made install again

make install
and all works perfectly with no more Warnings :)
Now I like it! NTFS-3G support built into the kernel as default ntfs, stable & nice!

EDIT:
Joe.Pelayo I think that your and mine ways our a bit different here :) you just installed ntfs-3g (fuse 2.6.3) support to your linux so the default ntfs for your system is still the same (kernel unchanged). For me it was crucial to have stable read/write access to NTFS partition which contains also my bootable Windows XP. Mostly that's why I chose to include the latest fuse into the kernel replacing the outdated ntfs support.
However both our ways seem to work for both of us right ;)

For the record. I am amazed how smart and safe the ntfs-3g (package fuse 2.6.3) is. I can read, write and delete files from my windoze partition with ease, never in 3 days experienced any problems. Once when my windows got stuck with something right before shutdown, linux could not mount ntfs partition with "error: unclear ntfs log" or something similiar. That's what I call safety! :) quick trip back to WinXP, chkdsk, safe shutdown, and linux approves the condition of NTFS drive mounting it with no other problems. I like it very much!