PDA

View Full Version : how to configure aria2c for metalink download



sn68
13th February 2007, 04:58 PM
I installed aria2c for downloading fc7 live cd, I was able to download the metalink file using aria2c only however I am not able to download the live cd iso file, the log is blank except

Tue Feb 13 21:02:23 2007 - INFO - aria2c 0.9.0
Tue Feb 13 21:02:23 2007 - INFO - Logging started.


>aria2c --version gives following

[project@localhost ~]$ aria2c --version
aria2c version 0.9.0
**Configuration**
http: yes
https: yes
ftp: yes
bittorrent: yes
metalink: no
message digest: yes
async dns: yes

Copyright (C) 2006 Tatsuhiro Tsujikawa


As can be seen from above, metalink is disabled. How do I enable metalink downloads?
The website http://aria2.sourceforge.net/ states that
In order to enable Metalink support, you need libxml2.
I have libxml2-2.6.23-1.2 installed

civilwarlord
13th February 2007, 05:47 PM
I installed aria2c & checked to see if I had metalink support, and I did. I have libxml, libxml-devel, & libxml-python installed. Though, my version of libxml was 2.6.17-1. You could try installing libxml-devel and/or libxml-python, then check for metalink suppport again.

sn68
13th February 2007, 06:30 PM
I installed libxml & libxml-devel & checked again however metalink support is still no. I removed aria2c & installed it again but the same result again.

civilwarlord
13th February 2007, 06:36 PM
Did you install everything through yumex or yum?

sn68
14th February 2007, 06:51 AM
yes, I installed through yum, infact I installed & checked on another fc5 machine, it gave me same result

twanj
27th March 2007, 05:39 PM
Hi,

I think aria2 requires a more recent version of libxml2 than what you have - 2.6.24 or greater.

I haven't tried it on fc5 but it works on fc6/7test.