PDA

View Full Version : FC6:gnome-terminal: error creating the child process of this terminal



mnisay
12th February 2007, 05:01 PM
anyone had this experience?

upon launching gnome-terminal, the popup shows, then that it, it wont drop to a shell.

i tried to remove gnome-terminal package, and reinstall it back again from CD. its the same.

i tried loggin in as root, existing non-root and a new non-root account, but its still the same.

additionally, xterm won't launch. i yum updated it, it wont launch still.

i tried booting from older kernel, both xterm and gnome-terminal doesnt work anymore.

i tried Ctrl+Alt+F1, yes i can login as root and non root accounts, so i guess gnome-terminal and xterm doesnt work even using a new profile or old one.

no idead what was the cause of it. i need to be dropped from shell using these softwares from runlevel 5.

attached is a screen shot.

anyone pls?

sideways
12th February 2007, 08:55 PM
Ok, weird one, let's start with this:

Do you have /dev/pts and /dev/shm entries in /etc/fstab?
(Pseudo terminals and shared(eg swap) memory)

mnisay
12th February 2007, 10:47 PM
yes i have that. its weird.
unfortunately, i gave up working on it the whole afternoon and tired doing the commands under Ctrl+Alt+F1,
so i have to do a quick 1 hour FC6 install and restore stuff from my desktop, and now im back again.
appreciate your reply though. thanks!

oh i restored back /root/* to the newly reformatted /root folder then gnome-terminal and xterm still works.
so it was a weird and misleading issue from me.

sideways
12th February 2007, 11:04 PM
well, glad your're back. If the problem ever recurs we should try to fix it without a reinstall :)