PDA

View Full Version : ntfs-3g in fstab gives permission error?



sdowney717
12th February 2007, 04:46 PM
or something as i watch it scroll on by.

ok ,the only way to get this to mount is for me to run
'mount -t ntfs-3g /dev/hda1 /mnt/windows'
as a session startup program or from a terminal window

the instructions here produce some error and no mount when placing this line in fstab
http://www.ntfs-3g.org/index.html#usage

what command line to make it work automatically as you should by editing fstab?
the examble by them does not work for me.
I am running 2.6.19-1.2895.fc6

Also where is the startup log, If I can find it I can post the errors

Dies
12th February 2007, 04:48 PM
Set Selinux to permissive if you want fstab to mount it at boot.

sdowney717
12th February 2007, 04:50 PM
how do you get to this menu?
thanks

Dies
12th February 2007, 04:56 PM
System>Administration>Firewall and Security Level>Selinux>Permissive.

then open a terminal:

su -
gedit /etc/fstab


/dev/hda1 /mnt/windows ntfs-3g rw,defaults,umask=0000 0 0

Add something like that to it, leave an empty line or two at the bottom then save the file and reboot.

sdowney717
12th February 2007, 05:06 PM
great, that worked fine.

what do these options mean umask=0000 0 0 ?
some people are posting to use umask=0222 0 0

Dies
12th February 2007, 05:34 PM
http://www.tuxfiles.org/linuxhelp/fstab.html

http://www.ss64.com/bash/umask.html

umask=0000

means that anyone can read/write/execute files on that drive

umask=0222

would mean that everyone can read/write but only the owner can execute files

Using the one I gave you is fine as long as there aren't a lot of users on your system that you don't want having full access to that drive, if so then you'll have to read up on permissions.