PDA

View Full Version : Another yum issue



tkoco
11th February 2007, 10:56 PM
I have been installing packages, but every so often yum hickups. I get error messages like below, or worse.


Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for nfs-utils to pack into transaction set.
nfs-utils-1.0.10-5.fc6.i3 79% |=================== | 24 kB 00:00 ETA
nfs-utils-1.0.10-5.fc6.i3 100% |=========================| 30 kB 00:00
---> Package nfs-utils.i386 1:1.0.10-5.fc6 set to be updated
--> Running transaction check
Dependencies Resolved
================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Updating:
nfs-utils i386 1:1.0.10-5.fc6 updates 333 k
Transaction Summary
================================================== ===========================
Install 0 Package(s)
Update 1 Package(s)
Remove 0 Package(s)
Total download size: 333 k
Downloading Packages:
(1/1): nfs-utils-1.0.10-5 9% |== | 32 kB 00:03 ETA
[lines deleted]
(1/1): nfs-utils-1.0.10-5 100% |=========================| 333 kB 00:02
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Updating : nfs-utils [1/2]
[lines deleted]
Updating : nfs-utils ######################### [1/2]
error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
error: error(-30987) getting "
" records from Filemd5s index
error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
error: error(-30987) getting "
" records from Filemd5s index
error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
error: error(-30987) getting "
" records from Filemd5s index
error: db4 error(-30987) from dbcursor->c_get: DB_PAGE_NOTFOUND: Requested page not found
error: error(-30987) getting "
" records from Filemd5s index
Updated: nfs-utils.i386 1:1.0.10-5.fc6
Complete!

tkoco
11th February 2007, 11:24 PM
Here is another script of a crash. How do you deal with that sort of database issue?


yum -y install e2fsprogs
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for e2fsprogs to pack into transaction set.
e2fsprogs-1.39-7.fc6.i386 100% |=========================| 25 kB 00:00
---> Package e2fsprogs.i386 0:1.39-7.fc6 set to be updated
--> Running transaction check

Dependencies Resolved

================================================== ===========================
Package Arch Version Repository Size
================================================== ===========================
Updating:
e2fsprogs i386 1.39-7.fc6 updates 955 k

Transaction Summary
================================================== ===========================
Install 0 Package(s)
Update 1 Package(s)
Remove 0 Package(s)

Total download size: 955 k
Downloading Packages:
(1/1): e2fsprogs-1.39-7.fc6.i386.rpm 955 kB 00:02
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
Updating : e2fsprogs ######################### [1/2]
rpmdb: page 723: illegal page type or format
rpmdb: PANIC: Invalid argument
error: db4 error(-30977) from dbcursor->c_get: DB_RUNRECOVERY: Fatal error, run database recovery
error: error(-30977) getting "�͟o)~�*��꺸�" records from Filemd5s index
rpmdb: PANIC: fatal region error detected; run recovery
error: db4 error(-30977) from dbcursor->c_get: DB_RUNRECOVERY: Fatal error, run database recovery
error: error(-30977) getting "*�፴�L���" records from Filemd5s index
[additional PANIC messages were deleted]

u-noneinc-s
11th February 2007, 11:36 PM
I have never seen those errors before. :confused: However, it appears that the update completed successfully after the errors. To make sure, rpm -q nfs-utils and compare the versions.

Well, it looks like you snuck in another post while I was typing this one, and that one looks like a corrupted rpmdb. The first thing to try is
yum clean all, and try again.
If that doesn't work, (make sure it's the same error before taking this next step)
rm /var/lib/rpm/__db.* (that is 2 underscoresdb*) then
rpm --rebuilddb
I hate to recommend this because I have broken FC3 once (probably made a mistake) but many recommend this.
You may want to wait for confirmation. The error is typical of a corrupt db.

Seve (or anybody) please confirm???

leigh123linux
11th February 2007, 11:41 PM
I have never seen those errors before. :confused: However, it appears that the update completed successfully after the errors. To make sure, rpm -q nfs-utils and compare the versions.

Well, it looks like you snuck in another post while I was typing this one, and that one looks like a corrupted rpmdb. The first thing to try is
yum clean all, and try again.
If that doesn't work, (make sure it's the same error before taking this next step)
rm /var/lib/rpm/__db.* (that is 2 underscoresdb*) then
rpm --rebuilddb
I hate to recommend this because I have broken FC3 once (probably made a mistake) but many recommend this.
You may want to wait for confirmation. The error is typical of a corrupt db.

Seve (or anybody) please confirm???

I wouldn't bother with yum clean all, just delete and rebuild the database