PDA

View Full Version : Ethernet 1 stalls when torrent traffic starts flowing



camoguy
9th February 2007, 03:33 PM
Hi guys, don't have much time to type this but I'm using Evga 680i Nforce 4 chipset mobo and Fedora 6.

When I open up my internet connection to Ktorrent, my connection drops to 0.0 after a couple minutes. I have recorded a tcpdump during that time.

I'll check on this after work.

IFCONFIG

eth1 Link encap:Ethernet HWaddr 00:04:4B:00:C7:D5
inet addr:192.168.1.2 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:30750 errors:0 dropped:0 overruns:0 frame:0
TX packets:29850 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:5701135 (5.4 MiB) TX bytes:47633508 (45.4 MiB)
Interrupt:17 Base address:0xe000

ilbh
10th February 2007, 12:57 AM
if you are using a router, you should configure port forwarding.
also check you firewall configuration or if it is related to selinux

camoguy
10th February 2007, 01:54 AM
I don't have firewall enabled on linux. I have forwarded the appropriate ports for torrenting. My download speeds are limited to 1.5Mbits and I do hit that often, but moments later my internet connection stops working all together.
Just so you know, I have an associates in networking, so I have tried pretty hard to work out the things that I can think of.
This is what I have done.

I have statically assigned an ip address, I have two onboard Nics/Lan. Just as I type this message, I thought I would give Eth0 a go and it did the same thing. Right now I'm seeing no activity to the router this is what I can see:
[This is me pinging the network adapter]
root@dorthy etc]# ping 192.168.1.2
PING 192.168.1.2 (192.168.1.2) 56(84) bytes of data.
64 bytes from 192.168.1.2: icmp_seq=1 ttl=64 time=0.028 ms
64 bytes from 192.168.1.2: icmp_seq=2 ttl=64 time=0.017 ms

[This is me pinging my router] Netgear
--- 192.168.1.2 ping statistics ---
2 packets transmitted, 2 received, 0% packet loss, time 1000ms
rtt min/avg/max/mdev = 0.017/0.022/0.028/0.007 ms
[root@dorthy etc]# ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
From 192.168.1.2 icmp_seq=2 Destination Host Unreachable

My other pc's do have internet connection.

I have a feeling it's something to do with the kernel or motherboard. I have tested both of these NICs in windows xp pro and they have worked perfectly for weeks without this problems.

I'm just learning Linux, so, I will take any advice I can. I know basic commands, but I have materials I am reading. I just wish I could get this problem address as it is a basic computer function.

I checked modprobe.conf it says for my eth1 which I am now not using : alias eth1 forcedeth, there is no entry for eth0. Also when I was using eth1 yesterday and the connection would stall I would be able to resolve it with ifdown eth1, ifup eth1.
I just tried to do that but it didn't work. Look at this.
[root@dorthy etc]# ifdown eth0
[root@dorthy etc]# ifup eth0
[root@dorthy etc]# ping 192.168.1.200
PING 192.168.1.200 (192.168.1.200) 56(84) bytes of data.
From 192.168.1.2 icmp_seq=1 Destination Host Unreachable
From 192.168.1.2 icmp_seq=2 Destination Host Unreachable
From 192.168.1.2 icmp_seq=3 Destination Host Unreachable
From 192.168.1.2 icmp_seq=5 Destination Host Unreachable
From 192.168.1.2 icmp_seq=6 Destination Host Unreachable
From 192.168.1.2 icmp_seq=7 Destination Host Unreachable

Thanks, I appreciate your help any way that it comes.

One more thing, I couldn't send this message to you because it was down. I tried : #service network stop/start and then that got it going. Please Help I don't know what's going on.

ilbh
10th February 2007, 02:04 AM
hi
run
system-config-network
and see if there is some configuration of your needs.
are you giving automatic ip address ?

bseltzer
10th February 2007, 02:28 AM
Who is your service provider?

I've experienced the same issue with BT downloads. Things go just fine for a while, then slow down dramatically until finally, my internet connectivity dies altogether. I'm on comcast.net and they get very unhappy about anyone running an outbound service on their network. Although I can't prove it, I suspect they've set up some sort traffic monitoring system that throttles outbound connections if they exceed some threshhold in terms of number &/or bandwidth and kills you outright if it continues for too long. When I tried to bit torrent the FC6 ISO's, it got to the point where I had to power cycle my cable modem in order to re-establish any kind of connectivity.

Maybe I'm just paranoid :rolleyes: , but there may be forces at work here over which you have no control :eek:

Regards,
Bert

camoguy
10th February 2007, 05:16 AM
Ip address are being set statically. As I type now, I am dual booted into my XP machine. I am downloading from that same nic in question bit torrent traffic at full speed and my isp doesn't slow me down.

A few days ago I was reported / tattled on by a "watchdog" group for downloading files via bit torrent, but I've since then started using the encryption option they have and using proxies in all. They shut down my connection temporarily, but when I talked with someone in charge at my isp, they said to not worry about these losers.

So anyways, I'm just going through the xp system an settings things up, because it will actually play music and internet works. I'll run that command in a few minutes, maybe after a few more cigarettes and beers.

Also I have a problem with my sound.

I have a intel hda sound chip on board and X Fi. I enabled the onboard, boot'd the os, and it worked great. Did one reboot and it's gone. I know it's proboably in a file setting somewhere, but I just don't know which ones. I look in /etc/ but I just don't know where to start. I looked in modprobe.conf and it's there, but after that reboot I bet it added that --disable command or something. What I would really like to know is which files are read during kernel load? I guess that's my question, but since, I know my question now I'll try to find that out too.

Is there any docs that anyone expirienced can suggest for fedora or sites? I find the fedora docs a little confusing.