PDA

View Full Version : Dual Boot with Fedora Core 5 Win XP X64 on raid SAS disk



clete
9th February 2007, 09:38 AM
I have a Precision Workstation 690 with 4 off SAS disks in two raid 0 sets.
1 off the sets is runnin with Win XP X64 and the secont two shall be
with Fedora Core 5.

It works fine installing Fedora. But when the machine shall boot it
seems that the boot manager will not work. Is it anything that I
should be aware of when specifying how the boot manager shall be
installed.

( today it was set up to be installed on the master disk wich is
listed first for booting in the Bios. However it will not work?? )

Thank you in advance for any hints.


Regards
Anders Austad

marcrblevins
9th February 2007, 10:06 AM
You don't see grub running?
Search for "grub-install" in this forum. I believe you got this right.

While back Fedora had issue booting from raid system. Had to do with nash.

Can you try Fedora Core 6 this time around? First two CDs for minmal installation and then use Add/Remove Software at later time.

clete
9th February 2007, 11:55 AM
Thaks a lot.

I did a search and found several hints.
I will try them when I get back home.

Anders

clete
10th February 2007, 01:35 PM
Hi again.

Now I have tried a lot and my GRUB is installed but I do not manage to get the GRUB.conf file correct.

This is my disks:
/dev/sda: (SATA disk single)
empty SATA disk for backup

/dev/sdb: (SATA disk single)
sdb1:
Boot x
Start 1
End 30401
Blocks 244196001
ID 42
Syst SFS

/dev/sdc: ( 2 SAS disks in Raid 0 )
sdc1:
Boot x
Start 1
End 13
Blocks 104391
ID 83
Syst Linux

sdc2:
Boot
Start 14
End 35500
Blocks 285049327+
ID 8e
Syst Linux LVM

/dev/sdd: ( 2 SAS disks in Raid 0 )
sdd1:
Boot
Start 1
End 10
Blocks 80293+
ID 6
Syst FAT16

sdd2:
Boot x
Start 11
End 35500
Blocks 285073425
ID 7
Syst HPFS / NTFS


Is it any hints for a grub.conf file for FC5 distribution.
( This is the one supported for Algor FEM software (they are testing it right now) )

Thanks in advance for your help.

I have also tried FC6 but still it stop on GRUB.

disk a & b has becom c and d. and grub.conf seem to be updated.

Is there any hints on this ?

Regards
Anders Austad