PDA

View Full Version : Login Manager disappeared from Control Center (KDE)



Jongi
9th February 2007, 09:34 AM
After updating KDE to the 3.5.6 on my FC6 x86_64 install, the Login Manager under Control Center --> System Administration has disappeared. Here are the installed kde related packages



[root:~#] yum list | grep kde | grep installed
PyQt.x86_64 3.17-0.1.fc6.kde installed
PyQt-devel.x86_64 3.17-0.1.fc6.kde installed
beryl-kde.x86_64 0.1.9999.1-2.fc6 installed
kde-config.noarch 3.5-16.fc6 installed
kde-filesystem.noarch 3.5-6 installed
kde-i18n-British.noarch 1:3.5.5-0.1.fc6 installed
kdeaccessibility.x86_64 1:3.5.6-1.fc6 installed
kdeaddons.x86_64 3.5.6-2.fc6 installed
kdeadmin.x86_64 7:3.5.6-1.fc6 installed
kdeartwork.x86_64 3.5.6-1.fc6 installed
kdeartwork-extras.x86_64 3.5.6-1.fc6 installed
kdeartwork-icons.x86_64 3.5.5-1.fc6 installed
kdeartwork-kxs.x86_64 3.5.6-1.fc6 installed
kdebase.x86_64 6:3.5.6-3.fc6 installed
kdebase-devel.x86_64 6:3.5.6-3.fc6 installed
kdebindings.i386 3.5.5-0.1.fc6 installed
kdebindings.x86_64 3.5.6-1.fc6 installed
kdeedu.x86_64 3.5.6-1.fc6 installed
kdegames.x86_64 6:3.5.6-1.fc6 installed
kdegraphics.x86_64 7:3.5.6-1.fc6 installed
kdegraphics-devel.x86_64 7:3.5.6-1.fc6 installed
kdegraphics-extras.x86_64 3.5.6-1.fc6 installed
kdelibs.i386 6:3.5.5-1.fc7 installed
kdelibs.x86_64 6:3.5.6-3.fc6 installed
kdelibs-devel.x86_64 6:3.5.6-3.fc6 installed
kdemultimedia.x86_64 6:3.5.6-2.fc6 installed
kdemultimedia-extras.x86_64 6:3.5.6-2.fc6 installed
kdemultimedia-extras-nonfree.x86_64 6:3.5.6-1.fc6 installed
kdenetwork.x86_64 7:3.5.6-1.fc6 installed
kdenetwork-devel.x86_64 7:3.5.6-1.fc6 installed
kdepim.x86_64 6:3.5.6-4.fc6 installed
kdepim-devel.x86_64 6:3.5.6-4.fc6 installed
kdesdk.x86_64 3.5.6-1.fc6 installed
kdeutils.x86_64 6:3.5.6-1.fc6 installed
kdeutils-devel.x86_64 6:3.5.6-1.fc6 installed
lockdev.x86_64 1.0.1-10 installed
lockdev.i386 1.0.1-10 installed
lockdev-devel.x86_64 1.0.1-10 installed
lockdev-devel.i386 1.0.1-10 installed
sip.x86_64 4.5.2-0.2.fc6.kde installed
sip-devel.x86_64 4.5.2-0.2.fc6.kde installed

Jongi
9th February 2007, 06:25 PM
Hmmm. Just noticed kdeadmin and kdebase are not the same version number.

ilbh
10th February 2007, 12:28 AM
are doing it using kde repository ?

Jongi
10th February 2007, 06:49 AM
The kde repo is setup but I see that not everything is being pulled from there. Will look into that.

Jongi
20th February 2007, 09:46 PM
An install of kde-config and kdeconfig-kdm returned the login manager.

Jongi
20th February 2007, 11:47 PM
I have the login manager back but under K --> Log Out --> Restart Computer, it doesn't give me the GRUB options



[root:~#] cat /etc/sysconfig/desktop
DESKTOP="KDE"
DISPLAYMANAGER="KDE"



[root:~#] cat /etc/kde/
env/ kdm/ shutdown/ xdg/
[root:~#] cat /etc/kde/kdm/kdmrc
[General]
ConfigVersion=2.3
ConsoleTTYs=tty1,tty2,tty3,tty4,tty5,tty6
PidFile=/var/run/kdm.pid
ReserveServers=:1,:2,:3
ServerVTs=-7
StaticServers=:0

[Shutdown]
BootManager=Grub
HaltCmd=/sbin/poweroff
RebootCmd=/sbin/reboot

[X-*-Core]
AllowShutdown=Root
AutoReLogin=false
ClientLogFile=.xsession-errors-%s
Resources=/etc/X11/xdm/Xresources
Session=/etc/kde/kdm/Xsession
SessionsDirs=/usr/share/xsessions,/usr/share/apps/kdm/sessions,/etc/X11/dm/sessions
Setup=/etc/X11/xdm/Xsetup_0

[X-*-Greeter]
AntiAliasing=true
BackgroundCfg=/etc/kde/kdm/backgroundrc
ColorScheme=
EchoMode=OneStar
FaceSource=AdminOnly
FailFont=Sans,12,-1,5,75,0,0,0,0,0
FocusPasswd=true
ForgingSeed=1108476160
GUIStyle=
GreetFont=Sans,16,-1,5,75,0,0,0,0,0
GreetString=Welcome to %s at %n
GreeterPos=50,50
HiddenUsers=
Language=en_GB
LogoArea=Clock
LogoPixmap=/usr/share/apps/kdm/pics/kdelogo.png
MaxShowUID=65000
MinShowUID=500
SelectedUsers=
ShowUsers=NotHidden
SortUsers=true
StdFont=Sans,10,-1,5,50,0,0,0,0,0
Theme=/usr/share/apps/kdm/themes/FedoraDNA
UseBackground=false
UseTheme=true
UserCompletion=false
UserList=false

[X-:*-Core]
AllowShutdown=All
NoPassEnable=false
NoPassUsers=
ServerArgsLocal=-nolisten tcp

[X-:*-Greeter]
DefaultUser=jongi
FocusPasswd=true
LoginMode=DefaultLocal
PreselectUser=Previous

[X-:0-Core]
AutoLoginAgain=false
AutoLoginDelay=0
AutoLoginEnable=false
AutoLoginLocked=false
AutoLoginUser=jongi

[Xdmcp]
Enable=false
Willing=/etc/X11/xdm/Xwilling
Xaccess=/etc/X11/xdm/Xaccess

Jongi
21st February 2007, 11:51 PM
Seems it needed a reboot rather than a logout of a session and login again