PDA

View Full Version : How do i view/edit NTFS files/drives?



broncbuster
8th February 2007, 03:01 PM
I've read some other threads on how to setup fuse and ntfs-3g, but i can't figure it out. will someone please point me in the right direction? I'm new to fedora and not too code-literate, but i'm learning.
Thanks,
Steve

Seve
8th February 2007, 03:05 PM
Hello:
First you need install ntfs-3g
yum install ntfs-3g
it will / should install all the required packages.
Then you need to make a mount point for you ntfs partition
and mount it.
Post the output of
fdisk -l
and someone will help you

Seve

broncbuster
8th February 2007, 03:45 PM
[administrator@localhost ~]$ fdisk -l
bash: fdisk: command not found
[administrator@localhost ~]$

I don't know how to mount a drive. Also, i don't have fuse on this particular computer. Is that in the livna rep? if so, how do i add livna rep?

Seve
8th February 2007, 03:51 PM
[administrator@localhost ~]$ fdisk -l
bash: fdisk: command not found
[administrator@localhost ~]$

I don't know how to mount a drive. Also, i don't have fuse on this particular computer. Is that in the livna rep? if so, how do i add livna rep?
Hello:
You need to be root to run the fdisk -l command
If you do not know how to become root have a look here:
http://www.fedorafaq.org/basics/#root
su - <-----the dash is important
yourpassword
then run
fdisk -l
If you use install ntfs-3g with yum, fuse will also be installed.
There is no need to do anything else to get fuse, hence the previous instructions.
To prove it to yourself
type
rpm -aq | grep fuse
and or
rpm -aq | grep ntfs-3g

Seve

zivko_sudarski
8th February 2007, 08:25 PM
Install NTFS Support

1.Open terminal
2. su -
3. your root pass
4. yum install fuse fuse-libs ntfs-3g ntfsprogs ntfsprogs-gnomevfs


Check Your Partitions

1. su -
2. your root pass
3. /sbin/fdisk -lu /dev/hda | grep NTFS

Create Mount Points

1. su -
2. your root pass
3. cd /media/
4. mkdir c_drive d_drive e_drive

Mount Partitions

1. su -
2. your root pass
3. mount /dev/hda1 /media/c_drive -t ntfs-3g -ro umask=0222
4. mount /dev/hda2 /media/d_drive -t ntfs-3g -ro umask=0222
5. mount /dev/hda3 /media/e_drive -t ntfs-3g -ro umask=0222

Update /etc/fstab
Every time Fedora boots, the partitions must be mounted. To automatically mount, you must edit /etc/fstab.

1. su -
2. your root pass
4. gedit /etc/fstab
/dev/hda1 /media/c_drive ntfs-3g ro,defaults,umask=0222 0 0
/dev/hda2 /media/d_drive ntfs-3g ro,defaults,umask=0222 0 0
/dev/hda3 /media/e_drive ntfs-3g ro,defaults,umask=0222 0 0

Read/Write Access: The above is for read-only access. In order to mount read/write, you must use the rw,defaults,umask=0000. Example:

/dev/hda1 /media/c_drive ntfs-3g rw,defaults,umask=0000 0 0

lxgamer
8th February 2007, 08:36 PM
thanks mate

broncbuster
9th February 2007, 01:20 AM
K, I installed all the fuse files and then f-disk'd. this iswhat i got

[root@localhost ~]# fdisk -1
fdisk: invalid option -- 1

Usage: fdisk [-b SSZ] [-u] DISK Change partition table
fdisk -l [-b SSZ] [-u] DISK List partition table(s)
fdisk -s PARTITION Give partition size(s) in blocks
fdisk -v Give fdisk version
Here DISK is something like /dev/hdb or /dev/sda
and PARTITION is something like /dev/hda7
-u: give Start and End in sector (instead of cylinder) units
-b 2048: (for certain MO disks) use 2048-byte sectors
[root@localhost ~]# fdisk -l

Disk /dev/sda: 74.3 GB, 74355769344 bytes
255 heads, 63 sectors/track, 9039 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sda1 * 1 13 104391 83 Linux
/dev/sda2 14 9039 72501345 8e Linux LVM

Disk /dev/sdb: 74.3 GB, 74355769344 bytes
255 heads, 63 sectors/track, 9039 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sdb1 * 1 9038 72597703+ 7 HPFS/NTFS

Disk /dev/sdc: 250.0 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/sdc1 * 1 30401 244196001 7 HPFS/NTFS
[root@localhost ~]#

broncbuster
9th February 2007, 01:23 AM
Then i did this:


[root@localhost ~]# mount /dev/sdb1 /media/c_drive -t ntfs-3g -ro umask=0222
WARNING: Old FUSE kernel module detected. This means, some driver features
are not available (swap file on NTFS, boot from NTFS by LILO),
and unmount is not safe unless you make sure the ntfs-3g process
naturally terminates after calling 'umount'. The safe FUSE kernel
driver is included in the official Linux kernels since version
2.6.20-rc1, or in the FUSE 2.6 software package. Please see the
next page for more help: http://www.ntfs-3g.org/support.html#fuse26

[root@localhost ~]#

broncbuster
9th February 2007, 02:11 AM
Ok, I've got the ntfs drives mounted. Thanks so much for the help. I tried to add the mounting procedure to my /etc/fstab file, but it didn't work. This is what i entered:



/dev/VolGroup00/LogVol00 / ext3 defaults 1 1
LABEL=/boot /boot ext3 defaults 1 2
devpts /dev/pts devpts gid=5,mode=620 0 0
tmpfs /dev/shm tmpfs defaults 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs defaults 0 0
/dev/VolGroup00/LogVol01 swap swap defaults 0 0
/dev/sdb1 /media/c_drive ntfs-3g ro,defaults,umask=0000 0 0
/dev/sdc1 /media/d_drive ntfs-3g ro,defaults,umask=0000 0 0

Seve
9th February 2007, 01:27 PM
Hello Bronco:
Open a terminal and log in as root using
su-
yourpassword
then type
system-config-securitylevel
and disable SELinux

Save, exit and reboot and your should be good to go.

Seve

dmbyer
11th February 2007, 04:11 PM
Hey, I am temporarily mounting my NTFS partition so I can move a 1GB zip file over to it. I installed ntfs-3g and tried using the above method for read/write access, but I just kept getting the syntax/help screen.

This is what I attempted to do, after making the required directories:


mount /dev/hda1 /media/c_drive -t ntfs-3g -rw umask=0000

I also tried:


mount /dev/hda1 /media/c_drive -t ntfs-3g rw,defaults,umask=0000 0 0

And also tried the latter command without the two trailing zeros.

Is the only way to get it mounted read/write by having it mount on startup?

Seve
11th February 2007, 06:03 PM
Hello:
Try
mount -t ntfs-3g /dev/hda1 /media/c_drive

Seve

sdowney717
12th February 2007, 01:23 PM
Hi, does this mean it is mounted?
And how do you even view the ntfs files?
I looked at file browser but it still only shows the same old linux listings

thanks

[root@localhost ~]# fdisk -l

Disk /dev/hda: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 22860 183622918+ 7 HPFS/NTFS
/dev/hda2 22861 22873 104422+ 83 Linux
Partition 2 does not end on cylinder boundary.
/dev/hda3 22874 24321 11631060 8e Linux LVM
Partition 3 does not end on cylinder boundary.

Disk /dev/hdb: 10.2 GB, 10239860736 bytes
255 heads, 63 sectors/track, 1244 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hdb1 * 1 13 104391 83 Linux
/dev/hdb2 14 1244 9888007+ 8e Linux LVM
[root@localhost ~]# cd /media/
[root@localhost media]# mkdir c_drive
[root@localhost media]# ls
c_drive
[root@localhost media]# mount -t ntfs-3g /dev/hda1 /media/c_drive
WARNING: Old FUSE kernel module detected. This means, some driver features
are not available (swap file on NTFS, boot from NTFS by LILO),
and unmount is not safe unless you make sure the ntfs-3g process
naturally terminates after calling 'umount'. The safe FUSE kernel
driver is included in the official Linux kernels since version
2.6.20-rc1, or in the FUSE 2.6 software package. Please see the
next page for more help: http://www.ntfs-3g.org/support.html#fuse26

[root@localhost media]# uname -r
2.6.19-1.2895.fc6

sdowney717
12th February 2007, 01:33 PM
Oh, it is in the media/cdrive directory.

but what does the warning indicate for me?

sdowney717
12th February 2007, 01:57 PM
while playing around with this, I have a large 600mb file. When I tried to copy then paste into the newly mounted partition of ntfs, it would not copy, just kept getting increasing amounts of time message needed to finish the copy. But when I dragged the file to the folder, the copy proceeded unhindered.
So does copy paste have a problem with large files?

jimmy7
12th February 2007, 11:31 PM
When I try to mount the partitions I get this message:
WARNING: Old FUSE kernel module detected. This means, some driver features
are not available (swap file on NTFS, boot from NTFS by LILO),
and unmount is not safe unless you make sure the ntfs-3g process
naturally terminates after calling 'umount'. The safe FUSE kernel
driver is included in the official Linux kernels since version
2.6.20-rc1, or in the FUSE 2.6 software package. Please see the
next page for more help: http://www.ntfs-3g.org/support.html#fuse26

How can I remove this old fuse kernel module? Or should I even bother?

igknighted
13th February 2007, 12:27 AM
while playing around with this, I have a large 600mb file. When I tried to copy then paste into the newly mounted partition of ntfs, it would not copy, just kept getting increasing amounts of time message needed to finish the copy. But when I dragged the file to the folder, the copy proceeded unhindered.
So does copy paste have a problem with large files?

It might, as ntfs-3g is still beta. If it continues to have issues file a bug report. You might want to consider using an ext3 partition to share files between windows and fedora if this copy/paste thing is an issue.