PDA

View Full Version : A remote connect server setup problem ??



lalientw
8th February 2007, 09:12 AM
Operation system:Fedora Core 6(GNU/Linux)
Hardware:
1.CPU type:Intel P4 630(3000MHZ)
2.Motherboard chipset:Intel Grantsdale-Gi915G
3.system memory:512MB
4.Video adapter:Inter(R)812915G/GV/910GL Express Chipset Family(64MB)
5.Network Adapter:Marvell Yukon 88E8053 PCI-E Gigabit Ethernet Controller
Portrayal of problem:
I want to use a remote software to control remote My Frdora linux server.
So I use XDMCP(X Display Manager ) service in my Fedora Linux.
And want to remote Fedora server on the Windows 2000 OS.
The X-Win32 software can achieve this funation, So I take it.
But I attempt very many times, still can not connect to Fedora Linux.
At last I find that happen problem, It's must active TCP port number and UDP port number.
-------------------------------------------------------------------------------------------------
As follows:
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 0.0.0.0:6000 0.0.0.0:* LISTEN 5920/X
tcp 0 0 :::6000 :::* LISTEN 5920/X
udp 0 0 :::177 :::* 5918/kdm
-------------------------------------------------------------------------------------------------
I just to lack that TCP port number 6000.Should I that hot to active the tcp port number!?
And I can to provide what information help disposed of the problem.
I really thank your help.

Thetargos
8th February 2007, 06:15 PM
Hello, and welcome to Fedora Forum.

First off, let me get this straight: You are trying to remotely manage your Fedora Box, but you want to use XDMCP (AKA X11) to do so, right? Comments aside[1], you will have to make sure the box you want to manage remotely hs the required port opened, you do that by opening the Firewall and Security level application located in Desktop - > Administration -> Security level or with the command system-config-securitylevel, then add the port you need. Since XDMCP is considered to be insecure, it has been disabled by default in the GDM setup (assuming you're using GDM), so you will have to enable that with the command gdmsetup and change that.

Assuming you already have done that, all you have to do is make sure Win2K can communicate with the server and you should be able to login remotely. Alternatively you can use VNC.


It is usually considered "a bad idea™" to mange Linux server through X, as it adds unnecessary overhead to the server machine. The "preferred" method is to use ssh (with an app like Putty) and if you require so, use X11 apps remotely through the use of X11-cygwin installed on a Windows machine (or straight from another Linux box), as this does not add the overhead of X running, but gives the abilty to run remote X apps through ssh.

lalientw
13th April 2007, 04:08 AM
Thank you for help, but still can not use, so we decided not to use XDMCP.

Janl
13th April 2007, 07:11 PM
Going along the lines of what Thetargos said, you may want to to using XMING to connect to the box. It can be configured to connect to your Linux box through an SSH connection, but rather than setting up a full Cygwin install it's much lighter and will allow you to open your X applications locally. Also there are other alternatives such as FreeNX or VNC, etc...