PDA

View Full Version : Low Video Resolution



N74JW
8th February 2007, 03:02 AM
Hello Everyone,

I have a Dell Optiplex GX260 and an accompanying FP1504 LCD monitor. Tonight, I installed FC6. The installation went pretty well, except for the video. The best resolution I can get is 800x600, but I know the LCD can support 1024x768.

What would be the best way of modifying xorg to permit 1024x768?

Thanks

Seve
8th February 2007, 10:29 AM
Hello:
Type system-config-display and make sure that the monitor and video card are set to the correct model.
Then install the 3rd party video drivers, if available.
If that fixes the issue then you good to go, if not you can edit your /etc/X11/corg.conf file and add a Mode. Similar to below:

SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600"
EndSubSection
Save, exit and Ctrl Alt Backspace to restart your Xserver.

Seve

N74JW
8th February 2007, 02:28 PM
It's weird... I added the subsection you have suggested (thanks). I also had my monitor configured wrong, so I told X to use the Dell FP1703 Digital and rebooted the computer. Ctrl + Alt + Backspace only makes me have to log in again. The boot sequence and the splash screen is displayed in 1024x768, but after I log in the best I can get is still 800x600. 1024x768 is an option, but never sticks. What am I doing wrong?

Here is my Xorg.conf...

# Xorg configuration created by system-config-display

Section "ServerLayout"
Identifier "single head configuration"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "Monitor"

### Comment all HorizSync and VertSync values to use DDC:
Identifier "Monitor0"
ModelName "Dell 1703FP (Digital)"
### Comment all HorizSync and VertSync values to use DDC:
HorizSync 30.0 - 80.0
VertRefresh 56.0 - 76.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "i810"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection


Thanks for the help, it is greatly appreciated...

Paul_Vandenberg
8th February 2007, 02:38 PM
Go to Screen Resolution is System | Preferences. See if you can select 1024x768 there. There is an equivalent setting in KControl under Peripherals if you use KDE.

Paul

Seve
8th February 2007, 02:40 PM
Hello:
You may want to look at installing the
915resolution rpm package from fedora-extras
You can read some more about it here:
http://fedoraproject.org/extras/6/i386/repodata/repoview/915resolution-0-0.5.2-4.fc6.html
yum install 915resolution

Seve

N74JW
8th February 2007, 02:43 PM
Hello,

1024x768 is available, but not applied when selected.

I haven't got to configuring Yum yet. Past experiences have been awful...

N74JW
8th February 2007, 02:46 PM
I tried Yum, but like I stated earlier, it never works...

Existing lock /var/run/yum.pid: another copy is running. Aborting.

Seve
8th February 2007, 02:50 PM
I tried Yum, but like I stated earlier, it never works...

Existing lock /var/run/yum.pid: another copy is running. Aborting.
Hello:
From a terminal type
system-config-services
and stop and then disable yum-updatesd <--it's the offending application
While you are there you may as well disable all the other services that you do not require. There is a guide here to asssit you:
http://www.mjmwired.net/resources/mjm-services-fc6.html
When you have finished save, exit and reboot then open a terminal and log in as root using
su -
yourpassword
and type
yum clean all
then you should be good to go.

Seve