PDA

View Full Version : Adjust Date & Time



axiopisty
8th February 2007, 01:34 AM
Hi, I'm dual booting Windows XP and FC6. Every time I toggle operating systems, the system time changes. I have to log in as root every time and manually fix it. I don't understand why starting my computer in one OS affects the time shown when the other OS starts, especially if I have both OS's configured to automatically adjust the time according to a designated time server. I looked at the time set in the bios and it is correct regardless of which OS was the last one used.

Are there any tips on how to make it so the time will be right no matter what OS is currently running?

Thanks,

PS. I've verified that both OS's are set to use the same timezone.

AlexThomson_NZ
8th February 2007, 01:40 AM
How much is the time out by? Maybe one OS is set to use UTC and the other isn't? If it's just a matter of minutes it would be a little odd sisnce you are syncing time with a timeserver.

Are you finding one OS is constantly correct while the other one needs adjusting?

axiopisty
8th February 2007, 01:56 AM
The amount of time it differs by is significant. I haven't paid attention to see if it is consistent or not. This time when I started FC6, the time was off by 5 hours.

The time is off/corrupted when I toggle OS's only if I manually fix it in the other OS.

In other words, I just fixed the time in FC6, when I boot into Windows, the time will be messed up. If I do not fix it in Windows and reboot into FC6 again, the time will be correct in FC6. If on the other hand I would fix the time in Windows, then when I reboot into FC6, the time is off again.

or

If I just fixed the time in Windows, when I boot into FC6, the time will be messed up. If I do not fix it in FC6 and reboot into Windows again, the time will be correct in Windows. If on the other hand I would fix the time in FC6, then when I reboot into Windows, the time is off again.

jlnissley
8th February 2007, 03:18 AM
Hi axiopisty,

Most likely you have FC6 set to "System clock uses UTC". Windows XP adjust the system time to match the time set from within Windows XP. FC6 gives you the option to have the system time set to UTC, which I think is the default setting. Which in my case means that my system clock is set 6 hours ahead of the time displayed on my computer (US-CST).

So, when you set the time in windows it sets the system time to match. When yo set the time in FC6, it's setting the system +/- based on the time zone you have selected. Therefore each time you switch OSs it move the time ahead or back by the amount of offset your time zone is from UTC (six hours in my case).

To fix the problem in KDE, from Kmenu select "Administration" and then "Date and Time". Select the "Time Zone" tab and unselect "System time uses UTC". (If fact there's a tool tip that pops up when you move your cursor over the checkbox telling you not to use this if you are using OSs such as MS Windows)

Hope this helps,
James

axiopisty
8th February 2007, 03:28 AM
I'm sure that was it. Thank you both for the explanation and the fix.

Elliot