PDA

View Full Version : invalid compressed format (err = 1)



Gaspode
7th February 2007, 09:40 AM
Hi all,
Big problem , my FC5 has just started hanging on boot. It fires up , gets to the “uncompressing linux bit then comes to a screaming halt with the error :-

invalid compressed format (err = 1)

-- system halted

I googled around but this seems to be a problem that turns up with initial installations
and on installing new hardware. This set up has been running fine for some months and i have made no recent changes nor installed any new hardware or software.

Any suggestions or have I lost the lot ?
Thanks in advance.
Gaspode
Desktop PC
700 coppermine Intal cpu
Fedora Core5

jcliburn
9th February 2007, 04:27 AM
Wow, that's a pretty impressive error! Congratulations! :)

Sounds like the kernel image or perhaps initrd -- both of which are a compressed files that live in the /boot directory -- have somehow become corrupted. Or perhaps you have a hardware problem (memory?). Can you use grub to select another kernel to boot? If so, you can use yum to remove the dead kernel and reinstall it.

Gaspode
9th February 2007, 07:21 AM
Hi jcliburn,
Yes ,well if your gunna stuff up ,forget
"my printer wont work :-)" lets go for the good stuff.

First ,thanks for taking the time to reply ,much appreciated.I eventually got a shell running with a rescue disk and dragged my important stuff to another HDD on this setup.

I repeated this problem around a few forums ,and I have to say that your reply was the most helpful ; Ta.

First ,my hardware is fine ,should be , it gets pulled down and rearranged ,with appropriate tests once a month (I'm a fiddler :-))

I only run one kernel and without grub I could'nt use yum.

However I eventually did a full reinstall and solved a couple of old problems on the way (like some j2re install probs I'v now got sorted. :-)

I'm not to far behind the eight ball now , we are up and running again with not to much pain , but I'd still like to know how that corruption happened on a pretty solid and safe system ??????? wtf

P.S. I'm just getting into torrents and have some weird stuff happening , what in your opinion would be the best bittorrent forum ? I've tried sourceforge but it's pretty unresponsive .....

Ta anyway..
gaspode

jcliburn
9th February 2007, 02:20 PM
Sorry, someone else will have to chime in on the torrent question. I use it occasionally to download a Fedora distribution when released, but hardly ever otherwise.