View Full Version : 3d Rendering Problem

6th February 2007, 04:15 AM
Before I switched to Fedora Core 6, I used to use Ubuntu (my 1st attempt at Linux) and I had this horrible annoying 3D Problem. I've tried almost every solution suggested in every Ubuntu forum I had been to, and to no avail on Ubuntu, so I was suggested to try Fedora Core out. I actually like it better than Ubuntu, but I still have this problem.

Problem: When starting ANY (And I mean any) type of 3d program (wheither a game, like UT2004, or glxgears) It will go smoothly for a bit, then suddenly and randomly FREEZE. In Ubuntu it froze the entire system. Thankfully here, on Fedora, the only thing it has frozen so far is the Application that I was using, in the most recent case, glxgears. I'm posting the FPS rating during it working.

20203 frames in 5.0 seconds = 4040.462 FPS
20369 frames in 5.0 seconds = 4073.782 FPS
19935 frames in 5.0 seconds = 3986.892 FPS
22398 frames in 5.0 seconds = 4478.831 FPS
25468 frames in 5.0 seconds = 5093.546 FPS
22924 frames in 5.0 seconds = 4584.645 FPS
20365 frames in 5.0 seconds = 4072.872 FPS
20326 frames in 5.0 seconds = 4065.012 FPS
20014 frames in 5.0 seconds = 4002.630 FPS
1008 frames in 12.3 seconds = 81.777 FPS
20154 frames in 5.0 seconds = 4030.640 FPS

Notice, it goes really really well for about 50 seconds, then POOF, It freezes. Even the counter freezes, causing it to take over 12 seconds to report instead of the normal 5. This is exactly the problem I had in Ubuntu, which is aggrivating the hell out of me.

What I did in Ubuntu: I did several things in Ubuntu that either didnt help, or made the problem worse.
1) I used the Synaptic Package Manager's version of my NVIDIA drivers.
2) I used the official site NVIDIA drivers.
3) I turned off/on various settings (1 at a time) on the NVIDIA Settings.
4) I reset my BIOS (Apparently this helped one guy on Ubuntu, how I dunno)
5) I tried both Ubuntu Normal and Xubuntu. Both had the same exact problem.
6) I tried minimizing the settings on the game that I was testing it on (UT2004)
Nothing worked.

System Specs:
Processor: AMD 64bit 3500+
Graphics: Geforce 6800 Ultra
Sound: Creative Sound Blaster Audigy SE

I heard and somewhat experienced(I think) on Windows that Geforce 6800 brand has several problems with some apps. This could be the problem, but I doubt it, since UT worked fine on Windows, with the same drivers that Im (I think) using now.

I haven't done anything yet on Fedora Core to anything to check settings or to mess around with stuff. I havent even installed UT2004 yet, because glxgears is even having problems.

I would love if anyone could assist me with this. It is the most aggrivating thing I've ever dealt with, but Linux has already shown so much more efficency when I was actually getting things done. I would love to be able to continue using it, but this 3D problem is a very serious one for my needs.

Thanks to anyone who tries to help

6th February 2007, 08:18 AM
Is your Video Card a PCI or AGP ?
What is the make and model of your motherboard?


6th February 2007, 01:24 PM
My Video Card is AGP. That reminds me, when I was on Ubuntu, the xorg.conf's BUSID for it was something like "PCI:1:0:0" but I never got an answer on any Ubuntu forums when I asked about this.

Is there a way to check my motherboard information on Fedora? I can't remember off the top of my head, but I'll reboot to check, but it would be good if there were any type of checking software for future referance.

Edit: Crap I can't remember and I don't know where to check on bootup. It's been a long time since I've had to change my motherboard. If you could jog my memory how to figure it out, I thought it was the first few lines that appear at bootup, but all I saw was stuff about the Energy Saving thing.

6th February 2007, 02:43 PM
To determine the make and model you will have to look at the board itself. It will be on the pcb somewhere.
Once you determine what the motherboard is you should check and see if there is a newer BIOS for it.
In the meantime you should enter you BIOS and disable anything that you are not using nor are you ever likely to use. Such as serial ports etc. And if your board has on-board sound and or video doulbe check to see they are disabled as well.
Save your settings and reboot.
When back in FC open up a terminal and type system-config-services
and disable all the services that you do not require. There is a guide here to assist you.
When you are finished, save your settings exit and reboot and then
run glxgears again.


6th February 2007, 03:42 PM
I've never actually updated my BIOS, so do you have a guide I can use to help me with that? Also, Can I put the BIOS update files on my Flash Drive, or do I have to use a Floppy Drive?

Also, I disabled every service that I know what it is + I don't need, like bluetooth and battery monitoring features. THere are some that had no description, so I didn't touch them, but that had no effect. I suppose the only possible solution can be the BIOS, I've done almost anything else I can imagine.

Any guide to help me update my BIOS would be great.
Thanks for replying, by the way. I appreciate it.


6th February 2007, 03:48 PM
The web-site for your motherboard's manufacturer will have the instructions.
First you should read any notes associated with the newer BIOS and see if there are any changes that may help you. If not, then you may not need to update it.
Did you disable the un-needed items in your BIOS ?

Does your computer still freeze up in UT ?


6th February 2007, 03:59 PM
I forgot to disable stuff in my BIOS, but it still freezes up in glxgears with the disabled services.

The only thing I can find that could be the Chipset information for my Motherboard was this:
FC Gigabyte (The C in FC was a double C, like a c in the C)
The name Gigabyte seemed familiar when I saw it, I think that's it.

When I went to their site, this was the changelog for the BIOS:
Download Version Date Description
Download from ... F5 2005/12/02

1. Update CPU microcode

Download from ... F4 2005/10/27

1. Update CPU microcode
2. Change SATA mode default to IDE

Download from ... F3 2005/07/25

1. Fixed HDD LED always turn on if disabled SATA controller

Download from ... F2 2005/06/28

1. Support Athlon 64x2 dual core CPU

Download from ... F1 2005/05/18

1. First Release

How do I check my current version?

6th February 2007, 04:04 PM
Can you post the output of
cat /proc/driver/nvidia/agp/status


6th February 2007, 04:09 PM
Status: Enabled
AGP Rate: 8x
Fast Writes: Disabled
SBA: Enabled

I think AGPs can go to 16x, can't they?

6th February 2007, 04:21 PM
Can you also post the output of
dmesg | grep - F irq
cat /proc/modules | grep snd


6th February 2007, 04:22 PM
response from dmesg | grep - F irq
grep: F: No such file or directory
grep: irq: No such file or directory

response from cat /proc/modules | grep snd
snd_ca0106 37701 2 - Live 0xf8aa3000
snd_rawmidi 28481 1 snd_ca0106, Live 0xf8a9b000
snd_intel8x0 37085 0 - Live 0xf8a90000
snd_ac97_codec 99813 2 snd_ca0106,snd_intel8x0, Live 0xf8ab1000
snd_seq_dummy 8133 0 - Live 0xf8a3f000
snd_seq_oss 37057 0 - Live 0xf8a85000
snd_seq_midi_event 11841 1 snd_seq_oss, Live 0xf89ff000
snd_seq 57009 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event, Live 0xf8a23000
snd_seq_device 12365 4 snd_rawmidi,snd_seq_dummy,snd_seq_oss,snd_seq, Live 0xf89fa000
snd_pcm_oss 46433 0 - Live 0xf8a32000
snd_mixer_oss 20545 1 snd_pcm_oss, Live 0xf8a1c000
snd_pcm 80965 4 snd_ca0106,snd_intel8x0,snd_ac97_codec,snd_pcm_oss , Live 0xf8a63000
snd_ac97_bus 6593 1 snd_ac97_codec, Live 0xf89a7000
snd_timer 26693 2 snd_seq,snd_pcm, Live 0xf8a04000
snd 58181 15 snd_ca0106,snd_rawmidi,snd_intel8x0,snd_ac97_codec ,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,sn d_mixer_oss,snd_pcm,snd_timer, Live 0xf8a0c000
soundcore 12193 1 snd, Live 0xf89a3000
snd_page_alloc 14281 3 snd_ca0106,snd_intel8x0,snd_pcm, Live 0xf88b6000

6th February 2007, 04:25 PM
My typo mistake sorry ... :)
I should have been
dmesg | grep -F irq


6th February 2007, 04:27 PM
No problem, here's the output
ACPI: INT_SRC_OVR (bus 0 bus_irq 0 global_irq 2 dfl dfl)
ACPI: INT_SRC_OVR (bus 0 bus_irq 9 global_irq 9 low level)
CPU 0 irqstacks, hard=c0808000 soft=c07e8000
PCI: If a device doesn't work, try "pci=routeirq". If it helps, post a report
ALI15X3: not 100% native mode: will probe irqs later
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
serio: i8042 KBD port at 0x60,0x64 irq 1
serio: i8042 AUX port at 0x60,0x64 irq 12
ohci_hcd 0000:00:0f.0: irq 17, io mem 0xed001000
ohci_hcd 0000:00:0f.1: irq 18, io mem 0xed002000
ohci_hcd 0000:00:0f.2: irq 19, io mem 0xed003000
ehci_hcd 0000:00:0f.3: irq 20, io mem 0xed004000
ata1: SATA max UDMA/133 cmd 0xD400 ctl 0xD802 bmdma 0xE400 irq 16
ata2: SATA max UDMA/133 cmd 0xDC00 ctl 0xE002 bmdma 0xE408 irq 16
parport0: PC-style at 0x378, irq 7 [PCSPP,EPP]

Thanks for helping, this is the only fourms that has tried to assist me in this problem.

6th February 2007, 04:37 PM
Do you have on-board sound on your motherboard ?
I know you have a Soundblaster as well ?
Can you post the output of
cat /proc/modules | grep -F soundcore


6th February 2007, 04:42 PM
I might have an onboard sound card, but I couldnt find anything about it in the BIOS. Ah, I just looked at the back of my comp, and yes, I do. Here is the output from the terminal
soundcore 12193 1 snd, Live 0xf89a3000

I do get sound, but if I remember correctly, on Ubuntu there were 3 choices, and only 1 worked, and here, I had to set it directly to the card instead of the ALSA drivers during the install to get sound. Just a question, how would this effect 3D?

Thanks again for helping

6th February 2007, 04:51 PM
Yes and No .... sometimes the addition of certain pci cards especially sound cards can cause certain issues that manifest themselves as video issues.
One more thing
Can you post the out put of :
cat /proc/interrupts
cat /var/log/Xorg.0.log | grep -F EE


6th February 2007, 05:05 PM
Output of cat /proc/interrupts:
0: 2697450 IO-APIC-edge timer
1: 2 IO-APIC-edge i8042
6: 6 IO-APIC-edge floppy
7: 0 IO-APIC-edge parport0
8: 1 IO-APIC-edge rtc
9: 1 IO-APIC-fasteoi acpi
12: 4 IO-APIC-edge i8042
14: 26677 IO-APIC-edge ide0
16: 2578 IO-APIC-fasteoi libata, snd_ca0106
17: 17626 IO-APIC-fasteoi ohci_hcd:usb1, eth1
18: 4953 IO-APIC-fasteoi ohci_hcd:usb2
19: 16839 IO-APIC-fasteoi ohci_hcd:usb3
20: 5 IO-APIC-fasteoi ehci_hcd:usb4
21: 0 IO-APIC-fasteoi ALi M5455
22: 228275 IO-APIC-fasteoi nvidia
NMI: 0
LOC: 2697374
ERR: 0
MIS: 0

Output of cat /var/log/Xorg.0.log | grep -F EE:
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER

Oh alright, thats understandable, but if glxgears has no sound, how could it effect that?

6th February 2007, 05:17 PM
Oh alright, thats understandable, but if glxgears has no sound, how could it effect that?
Well as I mentioned before ... yes and no :) It usually has to do with the IRQ the soundcard is using and not the actual sound.

Can you open a terminal and log in as root and type
it will take a minute or two and then type
locate nivida.ko
and post the output


6th February 2007, 05:25 PM
locate nvidia.ko gave me this output:

Was updatedb supposed to give me absoultly no response when it completed? Just making sure.

6th February 2007, 05:32 PM
locate nvidia.ko gave me this output:

Was updatedb supposed to give me absoultly no response when it completed? Just making sure.
Yes, there should be no response just a return to the prompt.

Can you post your /etc/X11/xorg.conf file


6th February 2007, 05:35 PM
# Xorg configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"

Section "Files"
ModulePath "/usr/lib/xorg/modules/extensions/nvidia"
ModulePath "/usr/lib/xorg/modules"

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
Option "AddARGBGLXVisuals" "True"

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24

I mentioned in the other thread I was in about the NVidia Drivers, that my xorg.conf is a lot smaller than it was in Ubuntu, but I dont know how it works in Fedora Core, that's why I didnt mention anything about it until now.

6th February 2007, 05:49 PM
Your /etc/X11/xorg.conf file is smaller due to the version of Xorg, nothing
much to worry about.
Can you add to the bottom of your /etc/X11/xorg.conf

Section "Extensions"
Option "Composite" "Enable"
Save, exit and Ctrl Alt Backspace to restart your X server.
Can you also check your nvidia-settings
and make sure that under OpenGL Settings the Sync to VBlank is not enabled. And that nothing is enabled under Antialiasing Settings.
Then run glxgears again and see if anything has changed


6th February 2007, 05:57 PM
Here were the results from glxgears:

20371 frames in 5.0 seconds = 4074.185 FPS
20037 frames in 5.0 seconds = 4007.372 FPS
20252 frames in 5.0 seconds = 4050.380 FPS
20237 frames in 5.0 seconds = 4047.259 FPS
20242 frames in 5.0 seconds = 4048.315 FPS
20269 frames in 5.0 seconds = 4053.793 FPS
20398 frames in 5.0 seconds = 4079.421 FPS
20393 frames in 5.0 seconds = 4078.477 FPS
20247 frames in 5.0 seconds = 4049.224 FPS
17014 frames in 5.0 seconds = 3402.691 FPS
20021 frames in 5.0 seconds = 4004.171 FPS
20143 frames in 5.0 seconds = 4028.552 FPS
17291 frames in 5.0 seconds = 3458.091 FPS
20273 frames in 5.0 seconds = 4054.567 FPS
20450 frames in 5.0 seconds = 4089.822 FPS
20248 frames in 5.0 seconds = 4049.409 FPS
19845 frames in 5.0 seconds = 3966.338 FPS
2772 frames in 5.0 seconds = 554.376 FPS
20527 frames in 5.0 seconds = 4105.264 FPS
20277 frames in 5.0 seconds = 4055.243 FPS
19916 frames in 5.0 seconds = 3983.073 FPS

The 4th to last one it was jumping alittle, but I assume this is from cpu usage, it was loading something right then, I dont know what I wasn't doing anything.

I'll install UT2004 now, and test it on the real test enviroment, where I'll need to know if it works. There were NO actual FREEZES in the entire test of glxgears. If this did it, I am EXTREMELY thankful for all your help.

I'll edit this (or reply if someone else has said something) when I get UT installed and testing.
Thanks again if this works!

6th February 2007, 06:56 PM
Damn, I was hoping that it fixed this. I finally loaded UT, and within seconds of starting a random map, it froze, but I thought "Maybe is a map loading thing" that I got sometimes in Windows, so I kept going, 10 seconds later, I got it again. I hope you have more tricks up your sleeve =P (Not trying to be rude or anything, I really appreciate you helping me out with this)

6th February 2007, 07:40 PM
Damn, I was hoping that it fixed this. I finally loaded UT, and within seconds of starting a random map, it froze, but I thought "Maybe is a map loading thing" that I got sometimes in Windows, so I kept going, 10 seconds later, I got it again. I hope you have more tricks up your sleeve =P (Not trying to be rude or anything, I really appreciate you helping me out with this)
The only other suggestion I have, before sending you to the nVidia site is as follows:
Check that your video card and other cards and cables are seated properly.
It seems that as soon as your graphics comes under load it starts to fail?
Does anything like this happen in Windows ?


6th February 2007, 07:49 PM
No, there was never a problem on Windows. Games like UT2004, Dark Messiah, Quake 4, Doom 3, Prey, they all worked absolutly fine when I had the computer on Windows. Should I send a query in to Nvidia support about this problem?

6th February 2007, 07:53 PM
Well ... at the moment I am out of any helpful suggestions.
So I would suggest that you post your issue here, as they are very knowledgeable and are moderated by nVidia folks.
I'm sure they can help you.


6th February 2007, 09:45 PM
They refered me to this topic: http://www.nvnews.net/vbulletin/showthread.php?t=58498
But I really have no idea what most of that means, so I can't really know. I don't want to do something stupid that could destroy my system, so can you please help me one more time? Which of those should I refer to for the problem? Thanks a lot.


6th February 2007, 09:58 PM
Are you using FC 32 or 64 bit ?
Then go from there......if nothing really applies to your set up then post back to the nvida forum following the instructions that they posted regarding http://www.nvnews.net/vbulletin/showthread.php?t=46678


7th February 2007, 04:59 PM
I have a quick question. While emailing with an Nvidia guy, he asked to see my X server's crash log that had just happened from one of his suggestions. Where would I find this log? I cant find it in /var/log.

7th February 2007, 11:03 PM
If it's occuring in many distros, it's probably not a software problem... Have you tried with another card, even a cheap one? That way assuming it is a hardware problem it determines card or mobo problem.

7th February 2007, 11:12 PM
The problem was "solved" with help from the NVidia support person. Here is his last email to me so far:
You can experiment with other values for NvAGP (see the driver README),
or you could try reducing the AGP rate (also see the driver README).
Its possible that your motherboard just isn't stable at higher AGP
rates. Either way, this is clearly an AGP problem, and not a driver bug.

When I added Option "NvAGP" "0" to the xorg.conf in the Device section for my Vcard, it made the problem no longer occur, but it created a LARGE drop in my performance. I used to be able to play UT2004 in Windows at everything at highest settings with 0 lag, now its at defaults with lag often. I'm going to read those readmes and see if I can increase the performance to tollerable amounts.

Thanks to Seve for your assistance and to everyone who helped me getting my 3D working. I don't really care how my games look, im not a graphics guy, so it doesnt bother me, but it would be nice to see it at least at Normal and no lag. Besides, I play a lot of modern games that will definatly lag if I have to keep these settings, like Prey and Quake 4. I'll see how I do. Wish me luck.


Edit: I read over his email again, and I dont quite agree with it, but I'm not going to complain to him over it =P

Why don't I agree? Because unless Windows uses a slower AGP rate, that would mean that my motherboard is stable, because it works in Windows fine. Whatever, I'm just glad I got it workin.

7th February 2007, 11:36 PM
Option "NvAGP" "0"
Seems to be the best option so far, according to the Readme, 0 uses no AGP adapter, 1 uses an NVIDIA adapter, 2 uses some other adapter, and 3 uses both. 1 Is alittle laggier than 0, and 2 is what causes the flickering and freezing.

How do I change the speed of the AGP card that the computer uses? I cant find anything about it on the driver README even though the NVidia guy said I could find somethin about it there.

Oh, I found it. It was on a special page. This stuff doesnt work though, at least not on Fedora. Most of their Readme stuff does not work in Fedora, which gets aggrivating, because he tells me to look at the Readme, but its wrong.

AGP Rate

You may want to decrease the AGP rate setting if you are seeing lockups with the value you are currently using. You can do so by extracting the .run file:

# sh NVIDIA-Linux-x86-1.0-9746-pkg1.run --extract-only
# cd NVIDIA-Linux-x86-1.0-9746-pkg1/usr/src/nv/

Then edit os-registry.c, and make the following changes:

- static int NVreg_ReqAGPRate = 15;
+ static int NVreg_ReqAGPRate = 4; /* force AGP Rate to 4x */


+ static int NVreg_ReqAGPRate = 2; /* force AGP Rate to 2x */


+ static int NVreg_ReqAGPRate = 1; /* force AGP Rate to 1x */

and enable the "ReqAGPRate" parameter:

- { NULL, "ReqAGPRate", &NVreg_ReqAGPRate, 0 },
+ { NULL, "ReqAGPRate", &NVreg_ReqAGPRate, 1 },

Then recompile and load the new kernel module. To do this, run nvidia-installer with the -n command line option:

# cd ../../..; ./nvidia-installer -n

Anyone know how to get that working for me? Thanks.

8th February 2007, 02:45 AM