PDA

View Full Version : X-Server often fails to start at boot



ColinA
3rd February 2007, 03:49 PM
Hi. I have installed FC6 (ZOD) xen version on an Asus M2N32-SLI deluxe m/b with a dual core Athlon AM2 3800. Graphics card is Nvidia Quadro FX. Drive is 250 GB SATA.

It seems to be working OK except that about 50% of the time it fails to bring up the X-server and dumps me at the command line. If I try and run the server with startx I get a series of messages viz:

hostname: Host Name lookup failure
xauth: creating new auth file /home/Colin/.serverauth.3235

Fatal Server Error
Server is already active for display 0
If this server is no longer running, remove /tmp/.xo-lock
and start again.

Xlib: connection to":0.0" refused by server
Xlib: Invalid MIT-MAGIC-COOKIE-1 key
giving up

Xinit: unable to connect to xserver
Xinit: No such process (errno 3): Server Error


Re-booting the machine has about a 50:50 chance of recreating the error.

Anyone have any suggestions as to a cure?

ColinA

sideways
3rd February 2007, 03:58 PM
Try this, login as root (hit ctrl+alt+F1 if the xserver doesn't start)



mv /usr/lib/xorg/modules/libint10.so /usr/lib/xorg/modules/unused-libint10.so

sideways
3rd February 2007, 04:45 PM
A followup

- this 'fix' may actually disable your xsever altogether! I was recalling a fix from FC4 xen installs.

In this case you may not even have virtual terminals available so will have to boot in a text mode and mv the file back. eg at the grub prompt hit 'a' and add '1' to the kernel parameters, this will boot you into single user mode where you have a root environment.

Sorry for the bad advice

ColinA
3rd February 2007, 04:56 PM
Hi Sideways. Tried that but it seems to kill x-server altogether. I couldn't even see the bootup sequence display and had to ,reverse the command to get back to normal. It didn't like not finding libint10.so!
ColinA

olenb
3rd February 2007, 05:05 PM
I also have had the Xserver fail to start, and have had to login from a command line.
I have a kvm, if i'm kvm'd to my other linux box while all the boot up probing is happening, its very unlikely the Xserver will fail to start, and I can get my monitor to
run at a higher resolution than I can, if my kvm is set to my linux box and actually probes
my monitor. I kind of dislike the automatic monitor probing, because it fails to reach the higher resolutions my monitor is capable of. I reported this back for the test2 or test3 release, but its still a problem for me, even with all the updates. I haven't tried FC6 without the KVM in the circuit, that could be causing the probing to not work so well, but in theory it shouldn't be a problem.

I have asus A8VE AMD3200 (939) and an NVIDIA 6600GT or something similar, so we
have very similar PCs.

mwette
3rd February 2007, 05:10 PM
ColinA, From the error messages it seems to me that your networking is not working perfectly.

Do you have SELINUX enabled? What does /etc/selinux/config have SELINUX set to?

Did you install with networking? What does /etc/hosts look like?

Does /var/log/messages indicate any errors?

Does /var/log/Xorg.0.log indicate errors? Errors are denoted with "(EE)".

ColinA
3rd February 2007, 07:50 PM
Hi mwette.
SELINUX is disabled in the config fil. /etc/hosts originally had the line 1::. local host.local domain which I changed to 127.0.0.1 in order to try running a guest OS(Cured problem with console not being available). The effect occurs on both settings.The original install was just a vanilla desktop version to which I later added KDE. I have installed a beta version of software to get the ASUS wireless LAN working (ASUS only provide Windows drivers),but I think from memory tha this effect occured before that. Xorg.0.log doesn't show any errors and only two warnings. With /var/log/messages i am not sure what I am looking for but nothing shouts at me.
ColinA

mwette
3rd February 2007, 08:05 PM
can you "ping localhost" ?
what does "hostname" return ?

ColinA
3rd February 2007, 08:27 PM
Yes, I can ping localhost. and hostname returns "localhost. localdomain". But of course this is when the system is working correctly!.