PDA

View Full Version : APIC error on CPU0



spamllama2000
2nd February 2007, 05:30 PM
Hey, I'm kind of a newbie... but I've been using Fedora Core 6 as my main system OS for about 4 months now... so I'm not totally in the dark.

I'm not sure why this is happening, but occasionally when shutting down, I'll get a message saying:
Spurious APIC error on CPU0, should never happen.

When I use dmesg, I also get the APIC error on CPU0 repeated many, many times.

I've done some searching on that, and APIC is disabled in my BIOS... I'm not using it at all. I was also running Freespire and Mandriva distros to test out a few different flavors, and don't get those errors on those distros when looking at dmesg.

I have added the noapic tag to the kernel line in Grub when booting to my Fedora core 6 build. That's pretty much the end of most posts I've found... it says to do that and it takes care of it. Well... did that, still getting the error.

So what else could it be?
If APIC is disabled in the BIOS and Grub, I'm not sure where else to disable it.

Thanks,
Derrick

spamllama2000
2nd February 2007, 08:12 PM
Just wanted to add another comment here. I found some info on another forum saying to add apm=force to my kernel line in my menu.lst for grub. I tried that... and am still getting the same error.

spamllama2000
2nd February 2007, 09:08 PM
Maybe this'll help. Here is what I get with dmesg:


APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
hdc: ATAPI 48X DVD-ROM DVD-R CD-R/RW drive, 2048kB Cache, UDMA(33)
Uniform CD-ROM driver Revision: 3.20
APIC error on CPU0: 01(01)
NET: Registered protocol family 23
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
input: PC Speaker as /class/input/input2
ACPI: PCI Interrupt 0000:00:0b.0[A] -> Link [LNKD] -> GSI 10 (level, low) -> IRQ 10
3c59x: Donald Becker and others. www.scyld.com/network/vortex.html
0000:00:0b.0: 3Com PCI 3c905C Tornado at e084e000.
Linux video capture interface: v2.00
APIC error on CPU0: 01(01)
bttv: driver version 0.9.16 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Bt8xx card found (0).
ACPI: PCI Interrupt Link [LNKC] enabled at IRQ 5
PCI: setting IRQ 5 as level-triggered
ACPI: PCI Interrupt 0000:00:09.0[A] -> Link [LNKC] -> GSI 5 (level, low) -> IRQ 5
bttv0: Bt878 (rev 2) at 0000:00:09.0, irq: 5, latency: 32, mmio: 0xe7002000
bttv0: detected: Hauppauge WinTV [card=10], PCI subsystem ID is 0070:13eb
bttv0: using: Hauppauge (bt878) [card=10,autodetected]
bttv0: gpio: en=00000000, out=00000000 in=00fffffb [init]
bttv0: Hauppauge/Voodoo msp34xx: reset line init [5]
tveeprom 0-0050: Hauppauge model 62471, rev A , serial# 1124520
tveeprom 0-0050: tuner model is Philips FM1236 (idx 23, type 2)
tveeprom 0-0050: TV standards NTSC(M) (eeprom 0x08)
tveeprom 0-0050: audio processor is TDA9850 (idx 3)
tveeprom 0-0050: has radio
bttv0: Hauppauge eeprom indicates model#62471
bttv0: using tuner=2
bttv0: i2c: checking for MSP34xx @ 0x80... not found
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found
tvaudio 0-005b: tda9850 found @ 0xb6 (bt878 #0 [sw])
bttv0: i2c: checking for TDA9887 @ 0x86... not found
tuner 0-0061: chip found @ 0xc2 (bt878 #0 [sw])
tuner 0-0061: type set to 2 (Philips NTSC (FI1236,FM1236 and compatibles))
tuner 0-0061: type set to 2 (Philips NTSC (FI1236,FM1236 and compatibles))
bttv0: registered device video0
bttv0: registered device vbi0
bttv0: registered device radio0
bttv0: PLL: 28636363 => 35468950 .. ok
bt878: AUDIO driver version 0.0.0 loaded
bt878: Bt878 AUDIO function found (0).
ACPI: PCI Interrupt 0000:00:09.1[A] -> Link [LNKC] -> GSI 5 (level, low) -> IRQ 5
bt878_probe: card id=[0x13eb0070], Unknown card.
Exiting..
ACPI: PCI interrupt for device 0000:00:09.1 disabled
bt878: probe of 0000:00:09.1 failed with error -22
APIC error on CPU0: 01(01)
parport: PnPBIOS parport detected.
parport0: PC-style at 0x378, irq 7 [PCSPP,TRISTATE]
Linux video codec intermediate layer: v0.2
Zoran MJPEG board driver version 0.9.5
ACPI: PCI Interrupt 0000:00:10.0[A] -> Link [LNKA] -> GSI 11 (level, low) -> IRQ 11
MJPEG[0]: Zoran ZR36067 (rev 2) irq: 11, memory: 0xe7003000
MJPEG[0]: subsystem vendor=0x1031 id=0x7efe
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
ZORAN: 1 card(s) found
DC10plus[0]: zr36057_init() - initializing card[0], zr=e0a811c0
ACPI: PCI Interrupt Link [LNKB] enabled at IRQ 11
ACPI: PCI Interrupt 0000:00:0d.0[A] -> Link [LNKB] -> GSI 11 (level, low) -> IRQ 11
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
ACPI: PCI Interrupt 0000:00:09.1[A] -> Link [LNKC] -> GSI 5 (level, low) -> IRQ 5
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
lp0: using parport0 (interrupt-driven).
lp0: console ready
sonypi: Sony Programmable I/O Controller Driver v1.26.
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
SELinux: initialized (dev ramfs, type ramfs), uses genfs_contexts
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
Mobile IPv6
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
ACPI: Power Button (FF) [PWRF]
ACPI: Power Button (CM) [PWRB]
ACPI: Sleep Button (CM) [SLPB]
APIC error on CPU0: 01(01)
md: Autodetecting RAID arrays.
md: autorun ...
md: ... autorun DONE.
APIC error on CPU0: 01(01)
device-mapper: multipath: version 1.0.5 loaded
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
EXT3 FS on hda2, internal journal
SELinux: initialized (dev tmpfs, type tmpfs), uses transition SIDs
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
Adding 2096472k swap on /dev/hda3. Priority:-1 extents:1 across:2096472k
Adding 1048568k swap on /dev/VolGroup00/LogVol01. Priority:-2 extents:1 across:1048568k
SELinux: initialized (dev binfmt_misc, type binfmt_misc), uses genfs_contexts
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
ip6_tables: (C) 2000-2006 Netfilter Core Team
APIC error on CPU0: 01(01)
ip_tables: (C) 2000-2006 Netfilter Core Team
Netfilter messages via NETLINK v0.30.
ip_conntrack version 2.4 (4095 buckets, 32760 max) - 232 bytes per conntrack
APIC error on CPU0: 01(01)
process `sysctl' is using deprecated sysctl (syscall) net.ipv6.neigh.lo.base_reachable_time; Use net.ipv6.neigh.lo.base_reachable_time_ms instead.
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
eth0: setting full-duplex.
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
SELinux: initialized (dev rpc_pipefs, type rpc_pipefs), uses genfs_contexts
APIC error on CPU0: 01(01)
Bluetooth: Core ver 2.11
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: L2CAP ver 2.8
Bluetooth: L2CAP socket layer initialized
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM ver 1.8
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
eth0: no IPv6 routers present
Bluetooth: HIDP (Human Interface Emulation) ver 1.1
SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
SELinux: initialized (dev autofs, type autofs), uses genfs_contexts
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
ISO 9660 Extensions: Microsoft Joliet Level 3
APIC error on CPU0: 01(01)
ISOFS: changing to secondary root
SELinux: initialized (dev hdc, type iso9660), uses genfs_contexts
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)
APIC error on CPU0: 01(01)


I'm guessing that it has to be an interrupt problem, but I'm not sure what to do about it.

Here's what that looks like:


CPU0
0: 667198 XT-PIC-XT timer
1: 2190 XT-PIC-XT i8042
2: 0 XT-PIC-XT cascade
5: 113 XT-PIC-XT bttv0, Bt87x audio
6: 4 XT-PIC-XT floppy
7: 1838 XT-PIC-XT parport0
8: 1 XT-PIC-XT rtc
9: 0 XT-PIC-XT acpi
10: 2876 XT-PIC-XT uhci_hcd:usb1, uhci_hcd:usb2, uhci_hcd:usb3, eth0
11: 384 XT-PIC-XT DC10plus[0], Ensoniq AudioPCI
12: 33774 XT-PIC-XT i8042
14: 23219 XT-PIC-XT ide0
15: 2176 XT-PIC-XT ide1
NMI: 0
LOC: 666206
ERR: 3088
MIS: 0

spamllama2000
2nd February 2007, 09:18 PM
OK, so not finding a lot of help and answer on this one, so hopefully other people can use this thread to help themselves.

I appear to have found an answer to my troubles.

The end of my kernel line in GRUB now reads "apm=force noapic acpi=off pci=noacpi"

Between all of these, it seems to have done the trick.

dmesg reports no more errors showing: APIC error on CPU0: 01(01)

Good luck to anyone else who may experience this!