PDA

View Full Version : Troubles at boot



canduc
2nd February 2007, 04:54 PM
Hi everybody. First of all, sorry for my english.
I have a trouble at boot, after a RAM upgrade (from 256MB to 1GB) on a desktop with AMD Athlon processor.
The error message is:
error while loading shared libraries: librt.so.1: cannot openshared object file: Inputo/output error What has happened?!

glennzo
2nd February 2007, 04:57 PM
I'm not clear on your problem. The system won't boot to Linux or it boot's up ok, but there's a message that concerns you.

canduc
2nd February 2007, 05:02 PM
The system won't boot at all...

glennzo
2nd February 2007, 05:04 PM
Take the new memory out of the computer. Put the old memory back in the computer. See if it boots. Then we go from there.

canduc
2nd February 2007, 05:10 PM
I've done it.
Same error...

glennzo
2nd February 2007, 05:32 PM
How many sticks of memory originally? How many slots do you have? Any beep codes? Did you put them back in the same slots? How many sticks for the upgrade? Is the upgrade all new memory? Don't mean to be a pain in the a**. Just trying to help. Are hardware upgrades something you've done before or is this your first time? When you turn the computer on how far does it get? Post screen? A screen that says 'starting' something or other? Does it beep once or several times? So many questions when one isn't sitting in front of the machine.

gr8BBQ
2nd February 2007, 05:52 PM
Whether you currently have your old memory or new in place, run memtest. see if it passes.

canduc
2nd February 2007, 06:26 PM
Sorry, you're right...
1.Originally 2 sticks of 128MB each, but one go off (this is the reason for the upgrade);
2.I have 3 slots;
3.What is a beep code?
4.No, I have put the working memory in another slot, just for ease;
5.It's all new memory. 2 sticks of 256MB and 1 of 512MB;
6.This is my first upgrade;
7.It stops immediately, just after "Uncompressing linux...booting the kernel"
8.What is a post screen?
9.No beeps;

I don't think the trouble was caused by memory.
I have upgraded the memory yesterday and yesterday the system had no problems, it started perfectly.
Just this morning the boot failed...

How can I use "memtest" if the system doesn't boot?
I have tried with a kubuntu live distro, but this command is unerecognized.

gr8BBQ
2nd February 2007, 06:50 PM
Regarding memtest on a machine that wont boot to your hard-drive: it can be used standalone.

You're able to post so you have access to another machine.

Looking quickly around on the net, go to www.memtest86.com and download one
of their iso images and burn a cd, boot off that.

Or go to www.memtest.org (another version), they even have a usb bootable
version of memtest if your machine can boot off a jump drive. But they also have
a "Pre-Compiled package for Floppy". Just look about 1/2 way down their splash page.

Either package is good.

Typically, I'll check with one of these when I put in new memory or build a new system.

Once you do that, at least you'll know its the memory or not. No point in chasing
gremlins in your hard-drive install till you know that.

canduc
2nd February 2007, 09:13 PM
I have made the cd from ISO downloaded at www.memtest86.com.
In a 2-hours test (the test seems infinite, I have stopped it manually!) I have encountered 1691 errors.
But in the same machine Windows works perfectly with new memory...

gr8BBQ
2nd February 2007, 11:23 PM
Perhaps Windows is normally active in only the lower portion of your memory?

I think memtest has the option of looking at assigned regions of memory. That might help
isolate the particular memory chip (or installation thereof) that is the problem.

And you can stop after the first few errors. There shouldn't be any.

canduc
3rd February 2007, 11:03 AM
I just know that Windows works perfectly with the entire 1GB of memory...

gr8BBQ
3rd February 2007, 07:24 PM
You have to follow your own logic in this matter.

What I know is that if I had just changed memory and then memtest gave me large number of errors then I would suspect either the memory itself or its installation. At one time, 10 years or so ago, it was not unheard of for people with Windows on their machines to dual-boot install Linux and then suddenly uncover memory problems. I went thru this myself, but its been a long time now since I've had a memory issue.

Sorry to not been of more help.

Good Luck