PDA

View Full Version : Shooting myself in the foot. Ow.



BPBomber
1st February 2007, 08:13 PM
Here I am, another newbie trying to enter the world of Linux.

I was hoping some of you smart people can point me in the correct direction; which is probably right out the back door :rolleyes:

I was looking at two unused (old) computers sitting in my office, while simulaneously thinking that if I really want to understand computers and servers, I need to learn how to use Linux. So, I took one of the computers which was a 466Mhz 20GB 198MB RAM and installed Fedora Core 6 on it. It worked okay, but was slow. The other computer sitting there was just about as bad 766Mhz 16GB 128MB RAM. It was then that I got the bright idea to put them together. I added the hard drive from the 466 to the 766. I set the hd with FC on it to Master and the other harddrive (which is blank) to slave. Now I can't get FC6 to boot up. I can get to logging in, but when I enter "startx", I get the following error

Fatal Server Error:
No screens found.

XIO: Fatal IO error 104 (connection reset by peer) on xserver "0.0" after 0 requests (0 known processed) with 0 events remaining


The video card in the 766 (which is integrated, emachine) is a Intel Corporation 82810 CGC. I've tried to bring up the log file, it tells me there is no log file. I tried running /etc/x11/xorg.conf and it tells me that does not exist either.

Does anyone know what may be going on here? Do you think that the video card in this 766 machine is just not compatible with FC6?

Thanks for your help!
Brian

sideways
1st February 2007, 08:38 PM
You should reinstall on the 766Mhz machine, you can't just move the hardrive over, there will be too many hardware incompatibilities.

btw I assume you merged the ram as well, since you'll need as much as you can, ideally at least 512Mb.
766Mhz is a bit slow, but ram is more crucial, especially for gnome/kde desktops

John the train
1st February 2007, 08:40 PM
First thought, did you just swap the HD into the 766 machine? FC6 requires a minimum of 192Mb RAM to run in graphical mode, and even then, as you say, it's slow. If the RAM modules in the two machines are compatible I'd suggest swapping the RAM from the 466 into the 766, otherwise your best bet might be to switch back to the original arrangement and put FC6 on a diet. The usual first step is to enter System>Administration>Services and shut down any services you don't use, such as Bluetooth. You'll find advice on which services you can safely switch off by doing a forum search using ' disable services ' or similar. That should free up your resources somewhat, then you can look at switching to less resource hungry applications. You could look at Xfce, which is a desktop with a smaller ' footprint ' than Gnome, again, you'll find quite a bit by a forum search. In fact I'm working up an FC6 install on a P2 laptop, around 350Mhz, 192MB RAM, and while no speedburner I've got quite a usable system.
Hope this is of some help.

AlexThomson_NZ
1st February 2007, 10:06 PM
I'd suggest shuffling the bits around, so you get a better PC (with the smaller HD) and a rubbish PC (with a bigger HD). I would the rubbish PC as a file/web-server (don't need a GUI for this). On the better PC I would use as a desktop and look at installing something like enlightenment (a brilliant WM that looks awesome on lower-end PCs).

You will definitely have to re-install whatever you decide though, as your xorg.conf is configured for an entirely different gfx card (among other things) so will be using the wrong drivers all over the place!

sosullivan
2nd February 2007, 02:47 PM
Not to dis-credit what others have said (I think a fresh reinstall will go a long way to solving the problem) but I have successfully transplanted hard drives from one PC to another. I installed FC6 on a USB hard drive, and I succesfully booted on Fedora on (at least) 4 different PC (3 laptops and 1 desktop). The was a wee problem with the graphic display, but the Xorg config program settled it.

Note: All PC had the "boot from USB" option enabled in the BIOS.

Steve

slade17
2nd February 2007, 09:43 PM
everyone else gave good advice, and you should reinstall. but one more note:


I tried running /etc/x11/xorg.conf and it tells me that does not exist either.
linux is case sensitive. its /etc/X11/xorg.conf, not /etc/x11/xorg.conf. for future reference, you can use nano to edit the file: "nano /etc/X11/xorg.conf", although reinstalling is the correct way to go.